Announcements

Autoplay setting is ignored when set to 'off'

Autoplay setting is ignored when set to 'off'

Plan

Premium

Country UK

 

Device

Windows 10, Mac

 

My autoplay setting is set to 'off', but the app is ignoring it and playing random other things after I've finished listening to an album. This is happening on Mac and PC. I've just tested it by listening to the last track of an album, and it immediately picks something else to play.

 

 

 

Reply
26 Replies

Bump. I can't be the only person with this issue. I don't like having the algorithm giving me things to listen to and then assuming I like them

Hi there @Godwhacker,

 

Thanks for reaching out to the Community!

 

Can you let us know if this is happening in the desktop app, the web player, or both? We'd also like to know if it's happening when using another device via Connect.

 

Keep us posted.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Same problem here on web player, with every browser I tried. It's REALLY annoying.

I don't use the desktop app, so I can't say if it happens there too.  It's happening as long as the player is the web player, even if remotely controlled. But it does not happen when the web player control another playing device.

Same problem here both in the Desktop and the Android app. I have autoplay turned off everywhere, but Spotify keeps adding songs after my current queue finishes, and it's *really* annoying.

Desktop app, not the web player- like I said, same problem on both Mac and Windows. 

I'm also having the same problem on the desktop app. Windows 10. 
It is also happening web player for me. I tried looking for a way to change this setting but I came to find out that you just don't have settings for the web player. How would I disable this in the web player if I can't even change it there?

Hi folks,


Thanks for your posts.

 

@luthier1729, can you clarify if this is happening if you start an album/ playlist as well, or only when you have added songs to the queue?

 

For anyone still experiencing this issue can you provide the followin info:

  • Web browser on which this is happening
  • Spotify Desktop app version
  • Device and OS version
  • Is it happening only at the end of albums or also playlists/ podcasts/ generally adding songs to the queue

This info will help us look further into the matter.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hey @Alex,

 

This seems to be solved now for me both in the desktop player and the Android app (thanks!), but in case it still helps, it happened basically when starting an album, either with the big "Play" button (on desktop) or by playing the first song (either in desktop or mobile).

 

Thank you!

Ok, no, it wasn't solved 😕

 

I tried with a couple of albums and it worked, but then, while listening to an album, I tried to start listening to another one (all this on the desktop app, Spotify for Windows - 1.1.71.560.gc21c3367), and then a lot of songs got added to the queue.

 

But, I think I have a suspect now: this only happens when connecting to my Echo Dot. In fact, even if I have no songs in the queue while one is playing in the computer speakers, as soon as I connect to the Echo Dot (from the Connect to a Device menu on the desktop app), the queue automatically fills up with similar songs.

 

Hope this helps!

Hey @luthier1729,


Thanks for the reply.

 

When playing songs on smart speakers powered by Alexa, there is no way to control the Autoplay function. The folks at Spotify are aware of this, however we don't have official info on whether or not there will be a setting made available, which allows you to choose whether the speaker starts Autoplay automatically or not.

 

Don't hesitate to give us a shout if you notice Autoplay switchin on even withough using your Echo Dot.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

It was working fine until last week, and it's happening even when I'm listening on headphones and not connected to Sonos. I've been very clear about what's, please don't just pick an interpretation that allows you to close the ticket, that doesn't help anyone

Hey folks,

 

We really appreciate you sharing this here in the Community!

 

We'd like to take a closer look at what's happening and need the exact steps to recreate as well as the devices affected. If you haven’t already, please provide the following details:

  • Device + OS version
  • Exact Spotify version
  • Are you listening through the internal device speakers or a connected device (Alexa, Sonos, etc.)?
  • Does it only happen when your PC or phone is connected to another device or is it also happening when listening natively on the desktop and phone apps?
  • Can you share a screenshot of the app settings and the Now Playing view?

Once we have that, we will pass it on to the relevant team, who will look further into it.

 

Thanks!

XeniaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Are you new to the Community? Take a moment to introduce yourself!

There's at least ten threads on this. The one I started includes a video of the behaviour (several, actually, I believe). It started two weeks ago. You changed something, change it back.

 

https://community.spotify.com/t5/Android/Connect-Autoplay-DISABLED-but-still-ACTIVE/td-p/5279608

"When playing songs on smart speakers powered by Alexa, there is no way to control the Autoplay function."

I'm sorry, what? You're the ones streaming music to the device through your servers, so I expect you to be able to tell the Echo device to stop playing as well. 

And this problem continues to occur! I have no idea why they can't fix this problem!

Hi folks,

 

Thank you for keeping in touch. 

 

To start, we'd like to let you know that after reviewing this with the right teams, we can confirm that (for now) this is the expected behavior of the Autoplay feature.

 

However, threads such as this one have gathered a lot of feedback, which resulted in the submission of this live idea that asks for the option to activate/disable Autoplay across all platforms. In that idea we've announced that the team is currently working on the implementation of the feature.

 

You can support the idea by adding your +VOTE, that'll make sure you stay up-to-date with any relevant updates about this. We always take new ideas and feedback into consideration to improve the app. Here you can read more on how ideas work.

 

Hope this helps. Let us know if you have any questions.  

MafeGModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Are you saying that the autoplay features is supposed to play random songs if it is enables; and still play random songs if it is disabled? Can you explain this logic?

Hi @Jernespand!

 

The interaction between Autoplay and Wifi speakers described in this thread has now been changed: you should see the Autoplay on other devices option in the app's Settings. Toggling it off will prevent Spotify from playing similar tracks when your music ends on all other devices.

 

Hope this clears things up. Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Still not working for me: spotify 1.1.93.898.g58f5ba0b on Windows.  Autoplay off for local for other devices (and shows same on Android spotify app).  Continues into next album regardless.  Really annoying and has been happening for some time, and, looking at this thread, for at least some of us for nearly a year now.

Suggested posts