Default Music Player for Windows 10

Solved!

Default Music Player for Windows 10

sorrenjackson

How do I make Spotify my default music player on windows 10

Reply

Accepted Solutions
Marked as solution

Davidpne1977

I did it.

WINDOWS 10 (not sure for other OS)

I removed the Windows App store version and downloaded the Windows Version from Spotify

(I searched all spotify files *spotify*.* in file explorer and deleted them, but you may not have to do this, I also ran cCleaner)

https://www.spotify.com/uk/download/windows/

sign in (very important to create the app link in appdata for later)
I got an MP3 file, Right clicked and open with. I then hovered over open with another program... Selected "Choose another app"
Click More Apps......

Scroll to the bottom... click...  "Look for another app on this PC"

then go to the folder containing Spotify (to get this, Right click the spotify Icon and then properties) Example - C://Users/usersname/Appdata/roaming/spotify/spotify.exe    Then Clicked open. Nothing happens (don't worry)

Now goto...  PCSettings,  Apps, default apps, Music Player (should be Groove or Windows) Click it, Select Spotify. Done. Now when I press the Music button on my Keyboard Spotify loads.

 

If you have a computer for multiple users, you may have to play around as it took ages to get to work on my partners. but on my PC worked first time.

Hope this helps those that just want to click 1 button and load Spotify from their Keyboard etc. feel free to share elsewhere.

 

View solution in original post

10 Replies

Sebasty

Hey @sorrenjackson!

 

I'm afraid it's not really an option, but there's another way:
Go to your music library, right-click on any mp3 file and select Open With, and find Spotify. The file then opens in Spotify. After this move all the MP3 files should open with Spotify as default.

I hope that helps!

SebastySpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

kwahlquist

This does address the real issue, as I think many are trying to set it as their media player for their keyboards and such.  I don't always have a file ready, and just need to open my media player (spotify).

specific215

there is no option to select spotify as the default media player, so when you press the music button on the kb, groove loads, instead of spotify... prefferably

Antarcticite

A good method is to just right click spotify in search or the spotify icon if its on your desktop and pin it to your task or start menu so its easy to access. Sadly theres no way to set as defualt or link to your keyboard for ease of access.

Marked as solution

Davidpne1977

I did it.

WINDOWS 10 (not sure for other OS)

I removed the Windows App store version and downloaded the Windows Version from Spotify

(I searched all spotify files *spotify*.* in file explorer and deleted them, but you may not have to do this, I also ran cCleaner)

https://www.spotify.com/uk/download/windows/

sign in (very important to create the app link in appdata for later)
I got an MP3 file, Right clicked and open with. I then hovered over open with another program... Selected "Choose another app"
Click More Apps......

Scroll to the bottom... click...  "Look for another app on this PC"

then go to the folder containing Spotify (to get this, Right click the spotify Icon and then properties) Example - C://Users/usersname/Appdata/roaming/spotify/spotify.exe    Then Clicked open. Nothing happens (don't worry)

Now goto...  PCSettings,  Apps, default apps, Music Player (should be Groove or Windows) Click it, Select Spotify. Done. Now when I press the Music button on my Keyboard Spotify loads.

 

If you have a computer for multiple users, you may have to play around as it took ages to get to work on my partners. but on my PC worked first time.

Hope this helps those that just want to click 1 button and load Spotify from their Keyboard etc. feel free to share elsewhere.

 

TMM1138
That worked for me. Now I'm able to start Spotify from a media key on on my keyboard. Thanks!

MoeSzyslak

Works just fine... 

Thanks for that...

k8seren

THANK YOU SO MUCH this worked perfectly!

casc95
It worked just fine! Thanks man!

macbwilson
Brilliant!! and Fantastic share, worked the first time!! Thanks @Davidpne1977! Now I can use the music shortcut button on my latop!!

Simplicity is bliss.

Suggested posts