[Desktop][Connect] Stop taking up screen real estate on desktop with Connect with Facebook

Reply

[Desktop][Connect] Stop taking up screen real estate on desktop with Connect with Facebook

logandarknyte
Visitor

The latest update now has a side panel on desktop with "Connect to Facebook".  There is no way to dismiss/remove this panel.  I don't have a facebook account.  I don't want a facebook account.  I'll never have a facebook account.  I'm not paying a subscription to have this annoying side panel staring at me when it could be used in so many better ways.  Please allow a way to dismiss/remove it.

spotify.jpg
11 Replies

coachktemp
Visitor

This times a thousand! I'm losing 20-25% of my full screen display with this worthless connect with Facebook tile. I can't even freaking minimize it. It makes zero sense that a quarter of my screen for a service I adore is taken up by a service I actively despise and I can't make it go away. It's like going to a restaurant for a wonderful meal but the server leaves a used kitty litter box on my table and won't remove it now matter how many times I ask. 

Novy
Moderator
Moderator

Hey folks, 

 

Thanks for reaching out here in the Community 🙂 Apologies for the delayed response, we just came across this thread.

 

Keep in mind that it's already possible to hide the Friend Activity bar, just make sure to follow the steps in this article in order to do so. 

 

If anything else comes up, the Community will be here. 

 

Take care.

NovyModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Music touches us emotionally, where words alone can't." -Henry Thoreau

fancy_lab
Regular
The article you linked to does not fix the problem. I don't want this panel on my spotify app. I don't want to be looking at this plea to connect to Facebook all day long.

fancy_lab
Regular

Here's a screen shot - after I followed the instructions in the article, and then closed and restarted the app.

Spotify.png

Alex
Moderator
Moderator

Hey there @fancy_lab,

 

Thanks for the reply.

 

We tried this on our end, and the Friend activity stays hidden after an app restart. 

 

There might be an issue with the cache on your desktop. We'd recommend running a clean reinstall, as described here, which should fix any cache related issues.

 

Keep us posted on how you get on.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde

fancy_lab
Regular

I followed your steps exactly, and the Facebook sidebar is still showing up.  I cannot believe I'm paying almost $20/month so I can see a huge ad for Facebook on my screen.  I despise Facebook and I am probably going to cancel my Spotify account if I have to keep looking at this every day.

Alex
Moderator
Moderator

Hi @fancy_lab,

 

Thanks for the reply.

 

Can you try the following:

 

1. Log into your account using Spotify website.

2. Go to your account settingsprivacy settings → and under 'Manage your data' opt out of processing Facebook data.

3. Log out of your spotify application, restart and log in again. 

 

Let us know if the field still shows after that.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde

fancy_lab
Regular

Unfortunately that didn't work either.  The option "process facebook data" was already unchecked.  But I logged out and logged back in, and I'm still getting this huge Facebook ad taking up space on my desktop.  I really despise Facebook and it's incredible that I'm paying so much money each month, just so I get to see this awful logo.  

 

I don't understand why we can't minimize that part of the window, or crop it out, sort of the way you can minimize the tools windows in Adobe Acrobat.

 

Do you have something else for me to try?  Otherwise, I'm going to cancel my family membership, which I have had for years.

Alex
Moderator
Moderator

Hey @fancy_lab,

 

Thanks for the reply.

 

Go to the 3-dot menu in the upper left corner of the app > View > make sure Friend Activity is not ticket. 

 

Also, in Settings > Display > See what your friends are playing should be switched off.

 

Let us know if that helped.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde

fancy_lab
Regular

That's what it was - the friend activity button!  Hooray, I just told my husband that I was getting rid of Spotify and he wasn't thrilled.  Now I don't have to.  

 

You should lead with this suggestion in the future, so that people don't have to de-install, do searches in all their folders, etc.

 

 

Alex
Moderator
Moderator

Hey @fancy_lab,


Thanks for the reply.


Glad to hear that worked for you 🙂

 

There should be a button right next to the Connect to Facebook option, to hide the prompt. We're getting reports that not everyone is seeing this, since it was introduced in a recent update, so we need to make sure anyone experiencing this is running the latest Spotify version.

 

We'll take you suggestion into account for future cases like this 🙂

 

Don't hesitate to reach out again if you have questions.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“With freedom, flowers, books, and the moon, who could not be perfectly happy?” ― Oscar Wilde
SUGGESTED POSTS