HOWTO: Spotify "party-mode" with trippy visuals from iTunes, WinAmp, MilkDrop, etc

Reply
7 people liked this

HOWTO: Spotify "party-mode" with trippy visuals from iTunes, WinAmp, MilkDrop, etc

agraham
Music Fan

This is not a question, I just wanted to share how I got this working so that I can use Spotify to play music on my laptop, while the secondary monitor plays visuals based on the Spotify output.

The key is looping the output of Spotify back to the input of your program that's doing the visualizations.

This used to be very easy to do in software, but these days it's become very difficult for dumb piracy prevention reasons and most drivers won't loop back.

So I'm not going to go in to the messing around with "loopback audio drivers" and whatnot, instead I'm going to assume you have your Spotify computer running into a stereo (if not, you can google "loopback audio driver" but you're on your own with that). I'll assume you have a secondary monitor, TV or projector plugged into the computer. I'm going to assume you want to use WinAmp with the default MilkDrop visualization plugin that it comes with. Some of this may not match your setup, but hopefully some of it will be useful anyway.

 

Most stereos have an output designed to send the audio output to a tape deck for recording. It's typically labled TAPE OUT or something on mine it's labled CD-R/TAPE.

Get a RCA-to-headphone-jack cable and run from there to the mic or line-in jack on your computer (line-in is preferable if you have both).

On my stereo it automatically directs the current input to the tape out, hopefully yours is the same - if not you need to turn on recording on your stereo and possibly direct the correct input to it.

Unplug the line in from the computer for a sec.

Play some Spotify, make sure you can hear it on the stereo - not too loud tho because...

Now we plug in the line-in. You may immediately hear some insane staticy feedback and echoing. That's because everything that comes in is being played out the stereo and then coming back to us again. Don't worry we'll fix this.

If you don't hear the feedback, it may still be working (just not echoing the input back to the output, which is exactly what we want). How to know? Run "Sound Recorder" (or the Mac equivalent) and check that the sound guage is bouncing up and down indicating that audio is coming in the line in.

If not, or if you've got the feedback, you now need to tweak your sound recording settings. On Windows right-click the volume icon on your start bar and choose "Recording Devices" and make sure that the input you're using has got some green bars indicating that there's sound coming in. Keep Sound Recorder running on the screen as well. If it's not working because your recording device is disabled, enable it. If you can't find your recording device you may need to "Show Disabled Devices". Select the recording input and choose Properties and go the "Listen" tab and UNcheck "Listen to this device". Yeah we want to listen to it, but we don't want to echo it out to the speakers which is what this setting does. This should kill the feedback. Go to the Levels tab, and adjust the recording level so that Sound Recorder doesn't peak out, but the bar is routinely getting almost completely full. MilkDrop needs to be able to detect the beat to the give sweet visuals.

Finally if your recording device has different drivers, you may have totally different options in this properties dialog, but hopefully not too different. If you're on a Mac good luck but I assume since it's a Mac it just works. That's what my dad always says about his Mac anyway.

Now download, install and run WinAmp. Right-click anywhere and choose Play -> Url... (or just hit Ctrl-L).

In the URL box type "linein://" without the quotes and hit OK.

Now you should see the EQ bars in WinAmp bouncing around just like the bar in Sound Recorder as it is sampling the input.

If you are hearing the feedback again, just turn the volume in WinAmp down to zero so it isn't playing out the speakers (I didn't have to do this tho).

Back to the menu and choose Visualization -> Select Plugin... and choose MilkDrop.

When we run MilkDrop we want it to run full screen on the projector, but leave spotify up on the main screen. That took some tweaking in my case. Go to Windows Screen Resolution and make sure Multiple Displays is set to "Extend These Displays" instead of "Duplicate These Displays" and take note of the resolution of the secondary display.

Now we need to make WinAmp/MilkDrop go fullscreen to the secondary display instead of the primary one as it will do by default.

Back to WinAmp menu, Visualization -> Configure Plugin... and you should see the MilkDrop settings since you've already selected MilkDrop for your viz. In the FULLSCREEN section, Display Adapter is most likely set to "1. NVidia Display" or the like. Change it to "2. NVidia Display" or whatever. Change the Display Mode drop down to the resolution closest to the native res of the secondary monitor unless your computer is too weak to drive that many pixels (you'll know because the viz will be choppy).

Now close this dialog and hit Ctrl-Shift-K to start the viz (Or find "Start" in the Viz menu) and then hit Alt-Enter to kick it full screen.

 

Now party your butt off.

SUGGESTED POSTS