How to clear the "Local Files" cache?

Solved!
Reply

How to clear the "Local Files" cache?

kidb
Casual Listener
Windows desktop version. In my preferences, I'm asking Spotify to only show local files from one folder (i.e., personal MP3 files stored on my hard drive). When I view the Local Files, however, it still shows all the files from the previously enabled local folders (subsequently disabled, now only asking to show files from one local folder). I've rebooted and restarted Spotify, but it still shows the local files in the disabled folders. Can I ask Spotify to delete the cache, or can I delete a particular file (or folder contents)? This is probably held in the AppData/Local/Spotify area, but I'd rather not delete files at random in hopes I can find the right ones. Thanks!
2 ACCEPTED SOLUTIONS
Solution!

MattSuda
Rock Star 24
Rock Star 24

Try a clean reinstall of Spotify


First uninstall Spotify and then delete this folder:

C:\Users\YOURUSERNAME\AppData\Roaming\Spotify

 

After that reinstall Spotify

 

If you can't find the folder, try this:

Uninstall Spotify: Start > Control Panel > Programs / Uninstall a Program > Spotify
Find your AppData folder and delete all Spotify data.
Start, run, type: %appdata% and hit enter
You probably see 4 folders; enter each and see if they contain a folder called Spotify. Delete the entire Spotify folder.
Restart your computer at this point.
Reinstall Spotify (download)

MattSudaRock Star 24
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

View solution in original post

Solution!

Omnipotentia
Newbie

If you're still having this issue, a solution is to:

  1. Close Spotify
  2. Navigate to "C:\Users\#USERNAME#\AppData\Roaming\Spotify\Users\" in your file browser.
  3. There should be a folder in the named similarly to "1111111111-user", the numbers will be different, however.
  4. Delete the file named "local-files.bnk"

That should clear out any files that no longer exist in the folders selected in your preferences. Hope this helps.

 

Alternatively, if you want it to auto-update when a file is removed; you can delete the "local-files-desktop.spa" file from the apps folder located at "C:\Users\#USERNAME#\AppData\Roaming\Spotify\Apps"

View solution in original post

13 Replies

kurotsuki
Newbie

Omnipotentia & d00p: Thanks. That's works.

Spotify devs: Why can't your app detect the changes automatically? Or at the very least, can't you provide a button to clear and regenerate local file list? Such basic operation and users need to hit command line? 🤔

Kebable
Newbie

If you use Spotify app from Store, then the file is here:
C:\Users\{your username}\AppData\Local\Packages\SpotifyAB.SpotifyMusic_zpdnekdrzrea0\LocalState\Spotify\Users\{spotifyusername}

N-H
Newbie

Be sure Spotify is not running and then delete the following file. Then launch Spotify again and your local files list should be 'refreshed', listing only the current files you have in the default locations. You will have to re-add any folders you had previously included in the local files directory.

Capture.PNG

d00p
Casual Listener

If you are using a Mac:

 

  • Stop Spotify
  • open the Terminal application
  • Execute mv "`mdfind local-files.bnk`" "`mdfind local-files.bnk`.old"
  • Start Spotify
  • Done!

kidb
Casual Listener
Omni -- Thank you very much!

kidb
Casual Listener
OK, thanks. I appreciate the suggestion. If reinstalling the application is the only way to clear the cache, then I don't think this is going to work for me. I need a quicker way to clear the cache (or have Spotify bring back drag-and-drop, which is the way I used to handle this until they downgraded). I make my own MP3 files and I keep adding and deleting them on a daily basis, so I don't want them accumulating forever in the Spotify interface.
Solution!

Omnipotentia
Newbie

If you're still having this issue, a solution is to:

  1. Close Spotify
  2. Navigate to "C:\Users\#USERNAME#\AppData\Roaming\Spotify\Users\" in your file browser.
  3. There should be a folder in the named similarly to "1111111111-user", the numbers will be different, however.
  4. Delete the file named "local-files.bnk"

That should clear out any files that no longer exist in the folders selected in your preferences. Hope this helps.

 

Alternatively, if you want it to auto-update when a file is removed; you can delete the "local-files-desktop.spa" file from the apps folder located at "C:\Users\#USERNAME#\AppData\Roaming\Spotify\Apps"

View solution in original post

ipengsmart
Newbie

I dont have spotify folders

jkeinonen
Gig Goer

Yes, the solution by Omnipotentia is correct. For me, it was also necessary to restart the PC.

 

Bartsainty
Newbie

Wow, thank you very much Thomas!

Solution!

MattSuda
Rock Star 24
Rock Star 24

Try a clean reinstall of Spotify


First uninstall Spotify and then delete this folder:

C:\Users\YOURUSERNAME\AppData\Roaming\Spotify

 

After that reinstall Spotify

 

If you can't find the folder, try this:

Uninstall Spotify: Start > Control Panel > Programs / Uninstall a Program > Spotify
Find your AppData folder and delete all Spotify data.
Start, run, type: %appdata% and hit enter
You probably see 4 folders; enter each and see if they contain a folder called Spotify. Delete the entire Spotify folder.
Restart your computer at this point.
Reinstall Spotify (download)

MattSudaRock Star 24
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

View solution in original post

pedronobrega
Newbie

hey, i made everything that you said to do... but instead of one roaming file i've got 2 files with the same content ... and i cant delete them 
what can i do ?!

kidb
Casual Listener
I'm using version 1.0.1.1060.gc75ebdfd, by the way. Thanks for any help!
SUGGESTED POSTS