Announcements

Help Wizard

Step 1

NEXT STEP

Local Files automatically link to Spotify Database

Solved!

Local Files automatically link to Spotify Database

Another issue that Spotify is REALLY grinding my gears with...


First of all, the album that I wanted to listen to was not on Spotify. So me being me, I gather up the album and artwork and change all of the settings on iTunes to make it proper. Then I import the files onto Spotify. 4/6 tracks have all of the proper info and artwork, while 2/6 only have the proper info. It turns out that 2 of the songs were already in the Spotify Database, however the tracks are not availible. Now the issue begins because my local files are automatically syncing with the database. The files they sync with DO NOT have any album artwork. I tried to 'unlink' the files but have no idea what that does cause it did nothing. 

 

WHY? Why is it that when you put local files, it automatically syncs to the database. This is ridiculous.

 

Can somebody help me? Thanks in advance.

Reply

Accepted Solutions
Marked as solution

I just did the unlink once again and NOW it decides to work. Odd. Thanks for your input though. 

View solution in original post

5 Replies

Hi, and welcome to the community!

Unfortunately, Spotify automatically links offline tracks and there is no option to change that.

A workaround would be to edit the metadata so that an element of it is slightly incorrect compared to the Spotify song so it doesn't link.

 

Good Idea though! Feel free to submit it to the Ideas section so Spotify are aware of it.

 

Anthony 🙂

This post was by Taylor - I do not work for Spotify!
If this solved your issue - Mark it as a solution! If you like my post - Please add Kudos!
||  Spotify Profile - Taylor   |  Feel free to PM me - Here  ||

Frequently my local files get synced with Spotify tracks when they are initially imported.  Sometimes the identical song, sometime a different version of the same song by the same artist.  However unlinking them has always corrected this for me, and they then show the correct artwork that I've tagged them with. 

 

I keep my entire local library unlinked.  Fewer problems that way.  Complete and proper tagging is imperative.

Marked as solution

I just did the unlink once again and NOW it decides to work. Odd. Thanks for your input though. 

What did you do exactly to get it to link? I'm trying to but it's not working for me. Where do you get the files so it links properly? Also, does the content of the file need to exactly match the content of the file in the spotify database, or only the metadata?

 

Edit: oops, sorry I didn't notice this thread was so old!

Hi there @fR1dj,

 

Thanks for posting in the Community!

 

This sure is an old thread and what is written here is not quite up to date.
Rest assured though, we can still try to help you out with this endeavor.
Would you mind telling us what you are trying to achieve?

We'll be on the lookout for your response.

Thanks!

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts