Announcements
We're aware that some of you are currently experiencing issues with redeeming your gift cards! We'll keep you posted here.

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Music doesn't continue after ads

Music doesn't continue after ads

Plan

Free

Country

Netherlands

Device

Desktop

Operating System

Windows 10

 

My Question or Issue

I am a free user, so I accept that there are sometimes ads between the songs.

But at least half of the times after an ad-break, the music doesn't resume.

Sometimes the ads don't load and then the music doesn't continue after that, eventhough my internet connection is fine.

But sometimes it loads 3 or 4 ads no problem and then stops and refuses to play the songs it is supposed to play.

And if I click on play after the ads are done, it gives the error message: the selected song will be played after the ads. (But no ad ever comes and the music cannot be played).

 

So it seems like spotify doesn't properly register when the ads are done.

 

And now every time I have to close Spotify after an add break to be able to continue listening to music. Which is very annoying.

Reply
15 Replies

Hey there @HowlingSnail,

 

Thank you for your post here in the Community. We're happy to help.

 

Can you perform a clean reinstall of the app? This step will clean the cache and corrupted files from previous installations that can cause issues.

 

If that doesn't do the trick - can you log in with another account - such as a friend's or a family member's to see if the issue persist?

 

Also - does this occur on one specific device or multiple devices?

 

We'll keep an eye out for your reply 🙂

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Clean install didn't change anything unfortunately.

Still having the same problems.

 

I almost always use Spotify on my Desktop, although sometimes I control what Spotify plays through my desktop from my phone.

But I don't think that should make a difference, because that is technically still playing through my desktop?

 

I will try and see if a different account could solve the problem, but I would be extremely surprised if it did.

 

Hey again @HowlingSnail,

 

Thank you for your reply.

 

We just want to make sure that it's not account related, which is the reason we'd like you to see what occurs if you're logged in with another account.

 

It can also be good to try with another internet connection to see if the issue persist.

 

Keep us posted 🙂

 

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Hey again,

 

Today I have tried it with a different account. (On the same desktop and the same internet connection). 

And there Spotify works just fine.

 

So it seems like my account is the problem...

Hey @HowlingSnail,

 

Thank you for getting back in touch.

 

Just to be sure - can you log in with your account on another device to see if the issue persist?

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Hello,

 

Yesterday I tried it with only my phone with my own account and no problems there.

 

And today I have tried it again on my desktop with my own account (the combination that had problems previously), but so far I haven't had any issues today...

 

So this whole thing is getting more interesting everyday...

Oh well, as long as the problem is really gone, then it doesn't really matter.

Hey @HowlingSnail,

 

Thanks for keeping us in the loop.

 

We're happy to hear that the problem seems to be going away. If it does come back, it might indeed be account related. In that case a possible workaround would be to create a new one. You can transfer your music collection using this guide so nothing gets lost.

 

Keep us posted! We'll be happy to lend a hand if you need more help. 

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Same, this has happened to me, but i use it on safari, and its just one ad, and it doesn’t play, so I end up reloading it, but then 4-6 songs later, an ad comes on, and the issue happens again.

Hey @LittleTrigger,

 

Thanks for your reply and for the info shared.

 

In this case, we'd like to gather some additional info. Would you mind sending us the make/model and OS of the affected device? 

 

On another note, and just to confirm, is this happening if you use a different browser than Safari? It'd be awesome if you could check. We'd recommend checking if your Safari browser has any pending updates. If yes, try updating it and check if this is still happening.

 

Lastly, just to confirm, has the app always been behaving like this or does it start to happen after a specific event such as an OS update? Please send us the details about it.
 

Keep us in the loop!

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

This has also been happening to me when listening to Spotify on my web browser. I listen to it through safari while using my iPad and previously, there had been no problems with that until recently. I’ll be listening to music and then when an ad comes up, it doesn’t even play any sound for the ad, and it says that it’s 30s long, but after 30s it will either keep adding seconds, or it will just freeze and it won’t move onto the next song. I think this started happening after the new iOS update. The only way to get rid of it is by reloading your browser, but this forces you to not be able to continue from the song that you were just listening to, which is quite annoying.

Hi there @ritzikay101,

 

Thanks for the post.

 

Can you let us know if this is happening if you play Spotify from another browser or from the mobile app? It's possible that this is caused by Safari itself, so check if there are any pending updates for the browser after the recent iOS update.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I’m having same problem. I listen through the app and when ad plays, if it plays, there is nothing after it. I have to push play/pause to get to start again. I listen on my iPad. I tried clean install but didn’t fix problem. 

Hey @Crazylola47,

 

Welcome to the Community!

 

Could you let us know if you've tried any other of the previously suggested troubleshooting steps in the thread? For example does it only happen on one device, is the issue only in the app? Give us as many details as possible so we can get a better understanding of the situation.

 

Cheers 🙂

IvelinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Thanks! And thanks for getting back to me so fast. I have tried everything in the thread. The issue is only in the app. I don’t have a computer so I have to use the app on my iPad. I don’t listen on my phone because there is no room for it. Up until a month ago I had no problem using the app. It worked fine. Here is what happens.

I set up the playlist I want to listen to and cast it to my Alexa (even if I don’t cast, it still doesn’t work). I will get an ad that plays, then the second one (ad), I have to push play/pause in order for it to play and I have to repeat this over and over again until a song plays. 

Thanks for the details, @Crazylola47.

 

We did some checking and it looks like we already have an OI thread about the issue you're experiencing where the teams are investigating further. You can check it out here for more updates and even try some other steps suggested by our team or other users. 

 

Make sure to also give it a like and Subscribe to the thread so you don't miss any news.

 

Cheers 🙂

IvelinaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts