Announcements

No gapless playback?

No gapless playback?

When listening to an album on desktop, there's an annoying half second skip - this doesn't seem to affect mobile.

 

This is really jarring on some albums that are designed for one song to lead into another. A quick google suggests that Spotify supports it, is there a setting I need to change?

Reply
18 Replies

Hey there!

 

Gapless playback is on by default on the app.

 

You can also use the crossfade option to ensure a more seamless transition between tracks.

 

We hope this helps 🙂

Is this planned to be implemented on the desktop version?

Sorry for the confusion. 

 

Gapless is on by default on the desktop version. 

 

We hope this clears things up. 

What setting may breake this? I run with crossfade set off, and have also tried with crossfade set to 0 seconds- but both gives me a gap when playing back on windows 10 desktop version - newest version.

Same here... played Vaudeville Villain (Victor Vaughn) and it's not gapless (small gap, maybe 300ms, at the start of every track). But most other albums on spotify play gapless.

I too am having this problem recently.  On Mac desktop app, albums are not playing gapless.  On mobile app (iPhone), there is no issue.

I've just noticed this problem which I cant recall having before

Gapless is not working on desktop or via Chrome Cast to Stereo

Gapless is working on the Android phone or Tablet directly.

Ok - this is weird

Fixed it earlier today  (On the PC, not on Chromecast) by upgrading spotify, and now it is back

Using version 1.0.59.395.ge6ca9946 there is no option of "gapless" in the Spotify desktop app on Windows 10.

 

And it clearly is not "on" by default. For example when istening to "Equinoxe" by Jean-Michel Jarre the gaps are pretty annoying. There are not supposed to be any gaps but there are, e.g. between track 3 and 4.

 

Looks as if "gapless" fell off the plate along the way. Any chance to make this work again?

Same problem here. 

Desktop app does not have gapless playback, mobile works fine. 

 

Please fix this. 

I'm running Spotify on Mac OS X version 1.0.68.407. There is no gapless playback option-nor does the application do gapless by default.

 

However, if I turn crossfade on and set it to 0, it does gapless. A gapless option would be more intuitive, but I guess this works.

Having the same on the latest mac app (macOS 10.13.2, Spotify desktop app version 1.0.70.388.g8e1ed5af). Crossfade with 0 seconds does resolve the issue, but it's not really the same, so quite confusing, to be honest.

Would like to know too, in the windows desktop version it's called now Crossfade songs in the advanced playback options. At 0 seconds it seems to work as intended. Not just concept albums, even listening to stand up comedy off all things.

 

Actual added artificial gaps only seem to happen with shuffle on and crossfade off.

 

On CDs the audiotrack was in fact just one continuous data stream, and tracks were mere cue points.

Gapless playback, if not exactly 0, is messing with the track length as normalization is messing with the intended relative volume in works that were mastered as one.

I have a MacBook and had the same problem. Turning on Crossfade and setting it to zero (0) works!

Love how the e-representative lowered self to type in a few careless answers to this issue then patenjtly lost interest. It's a query about MUSIC and ALBUMS: how these short term internet revenue models stay afloat... and they can't be bothered to even type something that LOOKS like they're concerned.

Shouldn't BE a problem though... albums are organic, and an artform that has existed for decades. Some have songs that flow into each other, as part of a holistic statement. This (vvvv short term) company just sees songs as chunks of internet data.

Hey, the issue is fixed  for me. It was a problem with the local files. I thought I had disabled the option to search for my own music on my computer but it was set to searching through the downloads folder. Disabling this setting forced spotify to stream everything and gapless works.

The same problem, it's really annoying and crossfade isn't the same than gapless. Very angry about that.

Suggested posts