Playback/skipping error - 'Spotify can't play this right now'


Playback/skipping error - 'Spotify can't play this right now'








Operating System

Windows 10 Home - 10.0.18362 Build 18362

Spotify Version

Audio Output

ASUS Xonar DX audio


My Question or Issue

Playback/skipping error - 'Spotify can't play this right now'


I've been using Spotify on this PC for several months with no issues, however today I've launched it and on trying to play a song the track details appears briefly on the left hand side and then vanishes within a second.  No sound is heard at all.  If I attempt to play something from the radio it does the same thing but quickly skips through all the songs in the playlist until it reaches the end.

I am able to play music fine using my mobile (Samsung S10), and my computer picks up that it is playing there.  If I tell my phone to instead play the track on my PC it transfers back to the PC but the issue remains.


I have tried the following:


  • Uninstalled - Reinstalled
  • Logged out/in
  • Rebooted PC
  • Tried different internet connections (wired/wifi/phone hotspot)
  • Deleted local cache files
  • Tried the W10 app instead of downloaded version.
  • Checked and reset app volume for Spotify.
  • Tried switching between audio outputs.
  • Disabled all sound output devices except for the primary.

Interestingly, I created a new account to test with and it works perfectly fine on the same PC with the same settings.  If I log out and back in as my main premium account the issue returns.  Log out, back in as free account and it is fine again and so on.  The issue appears to be both local and account related in some way.


No other sound issues on the PC, application audio, YouTube, webex's etc are all functioning normally.


7 Replies


Hey there @Amenthea and @OneByBoo


Thanks for reaching out to the Community about this. 

In case you've noticed random playback skips and the error message you get when trying to play with Asus Xonar DX it's possible that you're experiencing an issue that we're currently investigating in search for a solution.    


You can check out this Ongoing Issue and add your vote to it by clicking on the +VOTE button. Make sure you follow the steps provided under Status Update as well. 


It'll also be useful to subscribe via the three-dots menu in the top right corner next to the title. That'll make sure you stay up to date with any relevant updates about this.


Hope this helps. Let us know if you have any more questions. 

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music is the wine that fills the cup of silence.” - Robert Fripp

Casual Listener


Disabling "GX" and restarting Spotify afterwards fixed it for me. Not sure if applicable here, haven't tried with how it functions with other accounts.




Thanks a bunch, this fixed the issue immediately for me!

Update: The one thing I didn't try worked - Run as Administrator. Not sure why my main account needs to be run using this method but a free account is fine? Possibly something related to account/file permissions on account type.

So many things I've tried and not considered this, so glad I came across this post.

What is odd is that for me my Xonar D2X seemed to be the issue, I switched output device and it worked. I then saw your post about administrator, so switched back to the Xonar, ran as administrator and it works!

Rock Star 19
Rock Star 19

Hi there @Amenthea,

thanks for reaching out !


I see all the steps you've taken, however another thing you can do is to search for audio driver updates or to remove the drivers and reinstall it.


Let me know if that works for you 🙂

OneByBooRock Star 19
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.


The drivers I have are the latest available, and having been OK for some time.  I have an older sound card and they have not released any updated drivers for this model for some time.  I have just tried removing the reinstalling however and the issue remains.


I would say it is not driver related, as it works logged in under a different account.