Announcements
We're aware that some of you are currently experiencing issues with redeeming your gift cards! We'll keep you posted here.

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Proxy-Settings at LogIn after new Update

Solved!

Proxy-Settings at LogIn after new Update

Hello people,

 

I installed Spotify at work and wanted to log-in. I knew I need to configure the proxy settings
in order to get a connection with Spotify and I remember you can set them at the Login-Window,
but it seems like that Login-Window got strongly reconstructured after some Update and I can't
find the Proxy-options anymore.

I use Windows 7 Professional 64Bit and the newest downloadable Spotify-Client. 
I already did some stuff like: plugging out the network cable - etc.

So how can I change my proxy settings without logging in (which isn't possible at the moment)? 

Greetings Tenebrarum

Reply

Accepted Solutions
Marked as solution

HI,

 

I managed to solve the issue.

Edit the prefs file in D:\Profiles\<user>\AppData\Roaming\Spotify

Add or modify the following lines:
network.proxy.pass="YOUR PROXY PASSWORD HERE"
autologin.username="YOUR SPOTIFY USER NAME"
network.proxy.addr="YOUR PROXY ADDRESS@http"
network.proxy.mode=2
network.proxy.user="YOUR PROXY USER"
core.clock_delta=0

Launch Spotify, it works !!! 🙂

 

If you have a facebook login mode, you have to login on Spotify Website and add a standard login/password for all your devices, then use this login/pass in the prefs files as explained above.

 

Thanks you for nothing Spotify, for the user interface getting worse and worse each new version! 😠

View solution in original post

14 Replies

need to push it, sorry!

Same issue here.

Unable to use Spotify at work anymore.

Need the proxy settings to login, need to login to change proxy settings.

Thinking about cancelling my account because I mainly use Spotify at work. 😞

Moreover it is impossible to manually edit pref files if the proxy requires user and password entry.

😞 😞 😞

Marked as solution

HI,

 

I managed to solve the issue.

Edit the prefs file in D:\Profiles\<user>\AppData\Roaming\Spotify

Add or modify the following lines:
network.proxy.pass="YOUR PROXY PASSWORD HERE"
autologin.username="YOUR SPOTIFY USER NAME"
network.proxy.addr="YOUR PROXY ADDRESS@http"
network.proxy.mode=2
network.proxy.user="YOUR PROXY USER"
core.clock_delta=0

Launch Spotify, it works !!! 🙂

 

If you have a facebook login mode, you have to login on Spotify Website and add a standard login/password for all your devices, then use this login/pass in the prefs files as explained above.

 

Thanks you for nothing Spotify, for the user interface getting worse and worse each new version! 😠

Thanks for that solution, i will test it on monday, when I am back to work 
and tell wether it worked for me. I usually use the facebook login. 

Greetings 🙂

did it solve your problem? I am having similar difficulties but I need to set up spotify so it will accept my wpad.dat file. Do you have any ideas? thank you

Yes, you can edit the wpad.dat file in order to retrieve the proxy settings. Then use the proxy as I explained.
It is a bit complicated but it worked for me 🙂
In the wpad.dat file you have all the proxies for your company, depending on various criterions.
Hope this will work for you! 🙂

and how do I use it if I dont use any proxy user? 😄 thank you for your help 🙂

You can delete the line related to the user in the Prefs file. Should work

Thanks for the solution!

 

It's a major shortcoming from spotify: storing the password in clear in a file?!? Really?

Not being able to change it through the interface?

 

I'm wondering what features are more urgent than this really...

 

François

Sorry for the late reply:

I just tried it out today and updated the prefs-file with my proxy-settings.

Then I started Spotify and tried to log in and got that message:

 

proxy01.JPG

Which says in English: Probably your Windows firewall is blocking Spotify. Refresh your firewall, so Spotify is allowed by your firewall. You can also try to change your current proxy-settings.

 

So of course I choosed that last option:

proxy02.JPG

And now I can insert my proxy settings.

Sadly they don't work yet and I get the same notification as in the first picture.

I have a co-worker with the same proxy-settings as me and his Spotify (older version) is working fine.

 

I checked my firewall-rules. Spotify should not be blocked by it. What's wrong now?

Good news: proxy-settings at login-screen is back!

UPDATE:

It works now! I reinstalled Spotify completly and edited the prefs-file again

and here we go: I can use Spotify with proxy now.


Thanks for all the help!

 

And another thing to Spotify: Saving the proxy-password in a file in plain text is really uncool

what is my proxy i'm so confused help me like idk what a proxy is 

 Install Chrome browser, then go to chrome://net-internals/#proxy,

 

this will allow you to identify your proxy setting requirements. 

Suggested posts