Proxy settings for login

Proxy settings for login

storm666

Hello,

 

I've downloaded spotify on my windows computer at work. But we have a proxy here and spotify refuses to connect.

 

How can I change those **bleep** settings? The login screen gives me no settings, just mail + password for login.

 

 

Can anybody help? Please!

 

 

Kind regards,

storm666

Reply
26 Replies

jvanderb

I'm not sure how to get to the proxy settings from within the application without being able to log in.  However, there is a program that might help you.  An application called FreeCap allows you to force any application to go through a proxy server, and might be worth a try.  You can download it here:  http://www.freecap.ru/eng/?p=download

 

Hope that helps you!

q9

did you ever get this figured out?  I'm having the same issues.

Pottsy

I was having the same issue and found the solution.

 

* Unplug the the network cable


This prompts an error message which will allow you to change the proxy settings.
Remember to plug in your cable again!

 

Spotify Proxy


melissaRC

Hey there!

I have just the same problem. I can't login 'cos spotify thinks im offline. Re-installed the whole thing, checked my firewall (windows for windows 7) - does not work. Spotify tells me to log in via my Proxy-Details. And now my question (which is pretty basic, I guess): where the &%&/ do I find my proxy details?

 

There is one other thing that might be the reason for my spotify problems. I am just guessing here, but anyway:

I've got Avira running on my PC, might that be a problem? If yes - how can I fix it?

The whole problem stared after I ran a bunch of anti-virus, malware ect. programms. (avira, malware bytes and cc cleaner).

 

Thanks a lot for your help!

 

melissa

amiskin

Hi my computer won't let me log in due to proxy settings either I have tried to change them but nothing has helped.

 

Please help me!

Gurlina54

Hi there -

 

What do you mean by "unplug the network"?

I am having the same problem where first Spotify keeps saying its offline so nothing works. I uninstalled spotify (as it suggested), restarted my laptop, then installed it again. Now its saying something about the proxy settings. Its so frustrating, please help!

 

 

ribenaisgood

They mean:  unplug your network cable or switch off your wifi.  This will cause Spotify to give up logging in and show the option to change your proxy settings.  You seem to have got that far anyway.

 

It might be that you need to use a proxy server to log into Spotify.  If you do, then you will have had to use a proxy server to use your web browser etc...  so your proxy server will be configured on your system somewhere but Spotify is apparently not smart enough to know how to use it.  So find the proxy server settings your operating system is using and enter these in the dialog that comes up when you click on the "proxy server" link you see on the picture in the message above.

 

Of course, it might not be your proxy server settings that are the problem.

pentax

I am getting 'HTTP Reply 307". I am using ultrasurf, if that matters. I have tried logging in and out of last.fm app and retyping my password numerous times. Spotify on my other computer not using ultrasurf scrobbles fine. I cannot access the internet without ultrasurf on this computer.

Any help would be greatly appreciated.

 

EDIT: Just to clarify, I have the proxy settings in Spotify set to auto, and I can stream music fine.

pentax

Can anyone help me?

Sodium

Hello.

I am having the same issues because of an angry proxy at work. I have tried to copy the host and the port in the spotify preferences, also the address of the proxy, IP, etc. I'm not a geek and I do not understant if there's a way to fix this. And, by the way, it is not a ID / password proxy.

 

If it is a Sportify problem, I would very much appreciate to read a solution for this. If there's not, I'm afraid that I will feel obligued to cancel my monthly suscription to your service.

 

many thanks.

wachlibidi

I have exactly the same problem, but only since the new 0.9.xxx crappy updates : i can login, but then i get 117 or 112 errors and can't play any song. The 0.8.xxx versions have always worked fine.

So i was still using the 0.8.5.1333 client since it was still working fine until now.

But unfortunately not anymore... The 0.8.5.1333 client is now crashing each time about 20 seconds after the login, so i cant use it anymore at all. It looks like there is something new in the behaviour of the software.
Btw the 0.8.5.1333 client is still working fine at home (came home tonight, and it's not working anymore either), and i keep blocking the new useless and awful updates. I only have this problem at work, proxy interaction i guess.

Like Sodium i tried several times to copy host and port in the proxy preferences of spotify, but in vain.

Anyway i used to warmly recommend spotify to a lot of people and friends around me, but since the awful 0.9 experiments, oh god, i wish they will ever forgive me my mistake. Didn't see that pile of crap coming. Noone did. You had THE BEST streaming service that ever existed, and you just ruined it so bad... i'm so disapointed and angry now.

niallspotify

So you'd seriously download unknown SW from a Russian source?! Best of luck with your protecting your personal data!

andrelaszlo

Edit the prefs file (%APPDATA%/Spotify/prefs) and add a line like this:

 

network.proxy.addr="proxy.example.com:8080@socks4"

 

It might work. I was unable to get the proxy settings box to show up consistently on my machine, if you have the same problem this might help.

lyrical32

not sure if this will help but i kept getting same error and when box came up i selected no proxy worked perfect thanks

evilcount

For me worked!

Thanks for the tip


@Pottsy wrote:

I was having the same issue and found the solution.

 

* Unplug the the network cable


This prompts an error message which will allow you to change the proxy settings.
Remember to plug in your cable again!

 


Thanks so much. I had set a proxy up that was no longer available.

ffxx68

Thanks a lot for the suggestion.

I was struggling as well with the proxy setting, as I don't have any user/password defined for my proxy.

The preferences window has a mandatory user or password, so I hacked the 'prefs' file like below:

 

network.proxy.addr="myproxy.myorg.com:80"

 

and it worked!

sonnikaz

I just signed up and downloaded 1.0.4.90

 

I knew I was having a proxy issue.  I searched for the fix, and after reading a few found a suggestion to break the connection to induce a prompt to manually enter proxy information.


I then went off and search the registry and then the AppData folder, and found the prefs file.  I then noticed the "network.proxy.addr=" posts here to figure out what my setting should be.

 

I'm a little shocked that Spotify hasn't fixed this by now.  I was met with a message that stated "service temporarily not available", which would confuse many users.  

 

It's disappointing that even those who would be aware of a proxy consideration cannot access the portion of the UI to set proxy settings, prior to logging in.  

 

That is, it's essentially impossible for the (presumed) majority of users to change their "connection settings" unless you're "connected".  That's a good definition of a Catch-22 in my book, and it's probably a turn-off for people who want to try Spotify while at work.

 

In fact, will I have to manually edit a "prefs" file should I want to use this laptop at work, and then on my personal network?

 

I would hope Spotify prioritizes this fix in an upcoming update.

fishybones

 

If you are behind an HTTPS proxy you need an extra option in the prefs file -- 

 

network.proxy.addr="[proxy_url]:[port]@https"

network.proxy.mode=2

Suggested posts