Help Wizard

Step 1


Spotify holds open auto-hide taskbar in windows 10 after boot

Spotify holds open auto-hide taskbar in windows 10 after boot

As title - work around is to manually open and minimize spotify.

4 Replies

Hey @ab12345y456456!


Welcome to the Spotify Community.


In this case, can you check if the "Open Spotify automatically after you log into the computer" is set to minimized? Just head to Preferences > Advanced settings > Startup and Window Behavior.


Keep us posted.

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“The music is not in the notes, but in the silence in between.” – Wolfgang Amadeus Mozart

I have the same problem when Windows 10 boots up and Spotify is set to auto start, the taskbar will no longer auto-hide as it is set to do. The only way I can fix this is to either restart explorer.exe or to close Spotify, nothing else seems to work.


P.S. My Spotify startup settings are set to minimise and it still gives undesired behaviour.

I got a problem somekind similar with the taskbar, and it's like this since one of the last updates. On my Windows 10, my taskbar is configured like this : "Main taskbar and taskbar where window is open", then whenever I open Spotify, the Spotify's taskbar button won't show on the right screen until I minimize and reopen it.


This thread let me think Spotify did some rework with the way to deal with the taskbar in Windows 10 (maybe with other Windows).

If this is still happening on your PC, type Start Up in your search bar, it should show "StartUp Apps", open it up, you should see Spotify set to On, simply slide to Off, this should correct it.

Suggested posts