Announcements

Spotify installer does nothing when started

Solved!

Spotify installer does nothing when started

Plan

Premium

 

Device

PC

Operating System

Windows 10

 

My Question or Issue

Hi, I would like to get help from the community. Recently I had some update issues with the Spotify app, so I decided to reinstall it.

 

Once I uninstalled the original app, I downloaded the installer file from the official Spotify page. But when I start it, it only asks for permissions which I allow and stops working. No new window opened, or process in the manager. Just nothing.

 

I tried the offline installer but it installs some weird version of Spotify with weird look. I guess it's some old version but there is no way to update it. I scanned both install files with antivirus and nothing was found.

 

Also I tried to move the installer to C:\ and start it. Window appeared with download progress and than again nothing else happened. 

 

Web player works though, but I prefer to use the app.

 

Edit: I tried to run the CCleaner to remove old registry, tried to go to /local/ and /roaming/ spotify folders, deleted what was left, nothing. My username thought contains special letter from non english alphabet.

Reply

Accepted Solutions
Marked as solution

Well nobody got me any notification but it looks like they have fixed it.

 

I just tried to download the regular online installer from their page and Spotify got downloaded and installed normally. No admin permission, no C:/ folder. Looks normal, I tried to play and download some music. Will update you about the update once some arrives.

 

Just click and install. As easy as before.

View solution in original post

20 Replies

I have exactly the same probem. I'm posting for any helping suggestion!

Have same problem on my PC

I have the same problem with Windows 8. In additon to this I can't use Spotify Web too. I just wanted to reinstall Spotify. I uninstalled it and download the setup. I tried to run the setup but nothing is happening. I rebooted my pc a few times, turned off my antivirus, tried to run as administrator. I can't solve yet

Try to "RUN AS ADMINISTRATOR" by clicking right mouse on installation file, It might help

Already tried, no change

" I have the same problem with Windows 8. In additon to this I can't use Spotify Web too. I just wanted to reinstall Spotify. I uninstalled it and download the setup. I tried to run the setup but nothing is happening. I rebooted my pc a few times, turned off my antivirus, tried to run as administrator. I can't solve yet"

 

Exactly the same here, only my webplayer is fine! Also the run as administrator or the restarting of the computer is not working.

I've noticed this happening more recently, it can be down to security permissions? If you right-click on the installer app and click on the first tab I think and look at the bottom of the list, if it has an UNBLOCK option click on it, then run as a administrator, hopefully that's it!

I have same problem. searched for solutions and nothing worked

Just tried to unblock and no change. When I unblock the exe and run as administrator it only asks to install the program as a common user and not administrator. When doing so, it shows the same message and nothing happens

Ok it must be a different issue then, I still have a hunch it's a compatibility issue? Have you tried an older version? 

 

https://spotify.en.uptodown.com/windows/old

 

Worth a try, and obviously make sure you've been using the correct installer for your device?

Downloaded 1.0.36.124 installer, same issue. Nothing happens after start. I moved it to C:\, ran as administrator and unblocked it.

Thank you for sharing this - I too have the exact same problem! Almost started to pull hair while trying to fix it in any way last night. Very frustating, any kind of solution would be great.

 

Just as a ntice, also tried to download the Microsoft Store version vwhich worked temporaraly, but honostly that version is no good compared to the original desktop-app, in my opinion.

I have contacted Spotify support. Looks like it's caused by special characters in the username. They said they are working on it, will update asap as they get back to me with the result

Same problem here (windows 7 tho), notify us if you have any news :3

Hi, here's a solution that worked for me (windows 7).

 

I downloaded this old spotify installer (found on this topic).

The .exe did execute (good news), spotify looked old and was all buggy.

Almost every time I closed/re-opened the application, it suggested me an update, which I accepted. I did about 4 updates and finally spotify is back to the up to date version.

 

Hope it will work for you !

This installer works for me as you said, thanks! 🙂

(I have Win10)

Doesn't work for me. Yes, the installer executes and it updates two times, but after third update Spotify doesn't work again. Looks like the newest version(s) include the same error that causes this problem.

Okay, I did it 2 times yet, it looks like the version I had before but it might not be... I may try not to update for some time if you have this experience.. I hope some very new update will fix it soon 😕

Still waiting - this is what I got from support after asking about the progress

 

Hey, thanks for checking in! Our tech folks are currently working on a fix for this and it should be done soon. Stay tuned and thanks for bearing with us



Suggested posts