Help Wizard

Step 1


cant play songs on my windows but on my phone i can

cant play songs on my windows but on my phone i can






window desktop

Operating System

Windows 10


My Question or Issue

 so my spotify has been acting up and whenever i add a new song on my phone it never shows up on my desktop spotify ,same acount by the way .so i delete spotify on my desktop wondering that it will fix it but now i open spotify on my desktop and i go to my playlist and there no songs there but all my playlist are there and says "start adding songs' but on my phone all my songs are there and they can play but on my desktop i cant play no songs at all and my songs on my plylist are gone but not on my phone help me plz i use spotify like everyday and i sleep with it i dont wana use soundcloud i wanna use spotify help me plz.

4 Replies

Hey @cv20!


This a known bug with the desktop app and Spotify is investigating the issue. There is a workaround which seems to be working for some users. Can you try the following steps:


  1. Open Notepad as an administrator (right-click - Open as Administrator)
  2. go to File - Open and navigate to C:\Windows\System32\drivers\etc
  3. Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open
  4. When the file is open, you will see a block of text with # in front of each line and might see entries like website.com127.0.0.1
  5. Check for any entries with Spotify in the address. Examples may look like: weblb-wg.gslb.spotify.com0.0.0.0
  6. If you do find any lines with Spotify, please remove them.
  7. Save your changes and restart Spotify.

Hope that solves the issue! Let me know if you have further questions. There is also an open issue about this here where you can track it and vote for it so it catches more attention. I hope this will get fixed on Spotify's end soon.


Have a nice day 🙂

ive done evrything u told me and i looked it up on youtube but still no luck

Tried that, flushing my DNS, and clean installs. Still nothing.

Suggested posts