[All Platforms][Playlists] Making collaborative playlist private

As the title suggests, can you make a collaborative playlist private? I had one I made between one other person and I assumed we'd be the only ones with access to it, but I awkardly found out that everyone can see the playlist. Why is there no option to make it private between the collaborators?

Updated: 2016-12-07

Hi @12102227245 collaborative playlists are currently private. They won't show up in your Spotify Profile and they can't be marked as "Make Public". The only way other users can find the playlist is if you share the Spotify Playlist Link with them. Let us know if you've got any questions, thanks!



 - Make sure all Users have the "Automatically make new playlists public" setting disabled;

 - Have any collaborative user Unfollow, then Follow the playlist again.


This should remove the Private Playlist from showing up on their profile's followed playlists


Why so many problems and issue about a setting that should be so simple.

its a secret/hidden playlist and thats it.

(on whatever user.. playlist creator or colaborator)

no need to work around.


why complicate something that should be easy and simple.


Spotify > correct the coding on this one.

where can we submit this issue???

Its really annoying...


thank you




What about if I create a playlist collaborative and a person starts to follow it because I sent him the link....and what if, after that, I change the status to private? This person is still following no matter if it is private?


And to let him listen it once again, should I change the status once again to collaborative and the follower continue listening this list?


Thanks a lot for your comments.

Casual Listener

That's how it works for me. If I send a friend a link to the private playlist, they can then follow it.  Then when I make the playlist collaborative, it goes public. Then when I once again make the playlist private, it remains collaborative for my friend, but is no longer listed in my public playlists. I DID have an issue nine months ago with those collaborative playlists showing as public in the old web player in Edge, but I don't think that player is accessible on any browser anymore.

Music Fan


I have the same problem. My playlist is private collaborative, in my profile is not visible with other people. But the problem is that in the profile of the person I'm sharing with, the playlist is shown, so it's not private as it says. Change that please 😞

Rock Star 24
Rock Star 24



Tell the person to disable the Automatically make new playlists public setting, and then ask him / her to Unfollow, then Follow the playlist again.


Hope it helps. 🙂

Music Fan


Ok, but I have a question. If the person unfollows my playlist and follows it again, he is still a member of the playlist? or I have to send him an invitation again?

Thanks for answering. 🙂

Rock Star 24
Rock Star 24



No need to reinvite him again. When he follows the playlist again, he'll have full control to add music to it. 🙂

Music Fan


Ok, so

1. Disable the Automatically make new playlists public setting.

2. Unfollow our playlist.

3. Follow again.


I'm gonna ask him to do that and I'll let you know if it worked. Thank you very much!


The problem that private collaborative playlists suddenly become public occured to me when I used the Spotify application on my laptop! The playlist cannot be seen in my profile, but in the news feed on the right side. So people who follow me can see the playlist and theoretically add songs. Even though I always disabled Automatically make new playlists public. Really weird...