Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Login issues on iOS

We're getting reports from iOS users that are unable to login via the mobile app with the error message "You're offline. Check your connection and try again".

Hey folks,


Thanks for your patience while we looked into this issue.


We’re happy to say that this should now be fixed for everyone, just make sure that your app is updated to the latest version. You should also be able to use your VPNs as usual.


If you're still having trouble, make sure to post a new thread in the relevant help board here.


Thanks 🙂


I deleted my Spotify app on my iPad Pro 2nd Gen when troubleshooting something else, went to re-download the app and was told there was an error with my connection, I’m “offline” and to “check my connection later”. I have a stable wifi connection and I’ve updated and restarted my iPad multiple times, as well as deleting and reinstalling the app twice, please help if you have any idea of what could be the problem.



I was wondering if you ever figured out a fix for this, as I am encountering the same issue. It is very frustrating. 


Hey @RaylaDraws, thanks for reaching out to the Community!


Can you try a clean reinstall of the app following these steps? Those steps are more thorough than a simple reinstall and could resolve some more complex issues with the app.


If you're still having trouble, can you let me know if the same issue happens when you create a new test account? You can also send me a screenshot of any error messages you're seeing and I'll take a closer look. Make sure to hide sensitive information when posting to the Community.


Hello, I have tried logging it through other accounts and still get the same error messages I linked below.


EDIT:  I spent an hour on support with Spotify and they had no idea what was going on. They even got me to try to sign into test accounts which proceeded to say it was my device, however...Based on the replies this is not just my device - if anyone has a solution that is NOT uninstall/reinstall, reset phone, clear cache, reset password, please let me know!  


I am using an apple device and I can sign in on my desktop/web but not the app. I have tried with my apple account, my email I signed up with, and the "login without password" which tells me that the link expired or doesn't send the link via email. - My connections are good, no VPN, and my country is correct.

I have tried just about everything I found online to fix this, and it will not work. 

But it does not work, saying that the server is not available and I should try later.

Hey @RaylaDraws


Thanks for the info and for the screenshots. Does this happen after you reset your password? What happens when you try to log into your account here?

Keep me posted.


It works fine when logging in through the website, and I haven’t tried to reset my password because I am successfully logged in to my account on my iPhone, and am worried that resetting my password might force me out of my account on my iPhone too 


Hello again. So I just figured out that the reason i was not able to log in was because of a malfunction in the parental control app my parents installed, I have fixed the issue. Thank you for your time though 🙂 


Hey @ 


You should try deleting and reinstalling the app. Hopefully that'll fix the issue.


Also, try using a different network (WiFi) to see if it's not a connectivity problem.


Hope it helps. 🙂