How do I force Spotify to open links in the webplayer rather than the desktop player?

Solved!
Reply

How do I force Spotify to open links in the webplayer rather than the desktop player?

zzzsleepingas
Regular

I find it extremely irritating that it keeps trying to open the desktop client every time I click on an open.spotify link. There used to be an option to force the links to open the music in the webplayer, why has this vanished?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

Dreadlord
Community Legend

Hello @zzzsleepingas,

 

That's odd.

Can you open up your Desktop client press ctrl + P 

Click "SHOW ADVANCED SETTINGS"

Navigate to Startup and Window Behaviour 

Disable "Allow Spotify to be opened from web"

Spotify browser

 

View solution in original post

Solution!

rednblu
Roadie

@zzzsleepingas,

 

Have you tried, please, the following?

 

* Uninstall Spotify.  (Later you can Reinstall Spotify 1.0.14 from >> this link. << )

 

Now in a FireFox browser, please try this link >> https://play.spotify.com/user/rednblu/playlist/5i44MpqdV8Oi3rjy9S4DAq << which should display my playlist of Ocean sounds.

 

In the lower left corner, please click on the Gears icon which should open the Web player "Settings".

 

In the screen that comes up, you will see a line "Play open spotify.com URLs in desktop app".  If you hover your MousePointer over the CheckMark at the end of this line, you will see that the CheckMark is very barely green-- rather than gray.  If you Click on that CheckMark slowly a few times, you will see that it alternates between Gray and VeryBarelyGreen.

 

* Click on that CheckMark at the end of the "Play open spotify.com URLs in desktop app" line so that the CheckMark turns the Grayest gray that you can get-- without any green.  (laughing)  Can you see it?

 

* Then Logout of all of your sessions with the "Sign out Everywhere" button under "View Account".

 

Now play any "HTML link" of a Spotify track, such as >> Turbo Fruits – The Way I Want You <<.  Does that track now play in the WebPlayer as you wanted?  (If the WebPlayer stalls in a "Spinning circle"-- just kill that FireFox TabSession and restart by clicking on the >> Turbo Fruits – The Way I Want You << link again.  (smile and smile for every Spinning circle)

 

 

Screen shot follows-- of the WebPlayer "settings" that you want to use I think.

 

WebPlayerSettings.jpg

View solution in original post

8 Replies

Dreadlord
Community Legend

Hello @zzzsleepingas and welcome to the Spotify Community,

 

You can disable it by going to this page.

Make sure to uncheck Play open.spotify.com URLs in desktop app 

Links

zzzsleepingas
Regular

Hi Dreadlord I can't find any switch whatsoever on the page. There used to be a switch but I can't find it anymore and by default it keeps trying to open in the desktop app which is quite annoying especially if I'm on a computer with no admin access to install the desktop client on. 

 

 

There is no longer any switch there!

Dreadlord
Community Legend

Hello @zzzsleepingas,

 

This screenshot is taken from Desktop application, not from the webpage I linked to you.

Please visit this web page https://play.spotify.com/settings and change the settings there, accordingly. 🙂

zzzsleepingas
Regular

It's from the web page x___x I'm in Australia if it makes any difference 

I think they removed it/phased it out because everyone else was complaining about the webplayer rather than the other way round!

 

I've spent a couple of hours trying to rewrite every single last fm link to convert open.spotify links into player.spotify links using Switcherooo and looked at the URLs in my debugger, but no dice - no matter what I do it still stubbornly tries to open last fm links in the desktop rather than the webplayer. I've also looked up assigned protocols and things but that doesn't work either and I've tried to figure out what's causing the desktop player to come up but because I'm not very good with technology I can't figure out how to stop it.  It's just a little disconcerting to be browsing the web and have it come up in a desktop application especially as sometimes it takes a while to load.

 

I totally understand why they'd discontinue a feature that nobody uses though. 😞 I miss the webplayer links...

 

Solution!

Dreadlord
Community Legend

Hello @zzzsleepingas,

 

That's odd.

Can you open up your Desktop client press ctrl + P 

Click "SHOW ADVANCED SETTINGS"

Navigate to Startup and Window Behaviour 

Disable "Allow Spotify to be opened from web"

Spotify browser

 

zzzsleepingas
Regular

@Dreadlord That's weird... Maybe I just have a messed up spotify or something. 

/>

Version information Operating system= Windows 8
Solution!

rednblu
Roadie

@zzzsleepingas,

 

Have you tried, please, the following?

 

* Uninstall Spotify.  (Later you can Reinstall Spotify 1.0.14 from >> this link. << )

 

Now in a FireFox browser, please try this link >> https://play.spotify.com/user/rednblu/playlist/5i44MpqdV8Oi3rjy9S4DAq << which should display my playlist of Ocean sounds.

 

In the lower left corner, please click on the Gears icon which should open the Web player "Settings".

 

In the screen that comes up, you will see a line "Play open spotify.com URLs in desktop app".  If you hover your MousePointer over the CheckMark at the end of this line, you will see that the CheckMark is very barely green-- rather than gray.  If you Click on that CheckMark slowly a few times, you will see that it alternates between Gray and VeryBarelyGreen.

 

* Click on that CheckMark at the end of the "Play open spotify.com URLs in desktop app" line so that the CheckMark turns the Grayest gray that you can get-- without any green.  (laughing)  Can you see it?

 

* Then Logout of all of your sessions with the "Sign out Everywhere" button under "View Account".

 

Now play any "HTML link" of a Spotify track, such as >> Turbo Fruits – The Way I Want You <<.  Does that track now play in the WebPlayer as you wanted?  (If the WebPlayer stalls in a "Spinning circle"-- just kill that FireFox TabSession and restart by clicking on the >> Turbo Fruits – The Way I Want You << link again.  (smile and smile for every Spinning circle)

 

 

Screen shot follows-- of the WebPlayer "settings" that you want to use I think.

 

WebPlayerSettings.jpg

zzzsleepingas
Regular
Thanks! Easy as pie 🙂
SUGGESTED POSTS