Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


[Podcasts] Podcast stuck on "unable to submit"

[Podcasts] Podcast stuck on "unable to submit"




United States


Dell XPS 15

Operating System

Windows 10


My Question or Issue
Spotify is stuck on "unable to submit your podcast - please wait and try again after a few minutes." I've tried intermittently over a two-hour period to see if I could submit my podcast, but unfortunately I keep getting that error message. I'm not submitting through a hosting provider, but rather through a third-party RSS feed (feedburner) - could this be affecting my registration? 



12 Replies

Same here, trying to submit my podcast (not hosted in any of the services associated with spotify). Looking forward to a problem solution

I'm having the same issue and I have the Premium plan

Screenshot 2019-06-28 at 10.16.31.png

I have the same problem. I've been trying for two days and I have not succeeded.

I sent them email yesterday with a screenshot.

I just received info that everything should be fine with the format and it looks to be fine for the submission.

They said in the email that I should try to submit again in a private window with the browser. That didn't help.

The suggested trying with other browsers, but didn't help (Firefox, Chrome, Edge). However, the picture appearing on the right is animated on the Edge, so some part of the code is not working on the other browsers?

I'm next trying to update the browser and flash and whatnot add-on or codec might make the problem, but seeing as all of the people here in this thread have had this during last two days, like me, is interesting.

The also suggested trying a different connection, but that is not that easy to try really and I don't want to submit from the phone. Although, I might try that!


Which hosts are you using? Mine is at SoundCloud, you with added screenshots have also chosen "other / don't know" as the service provider.


Keep us updated on this matter as it seems others have the exact same thing.

Hm, have you tried today? I just tried it with Edge and it worked for me. Previously, I was using Chrome. 


Hopefully your podcast gets successfully uploaded! For reference, I'm just using an RSS feed with a Feedburner interface (the posts are through Wordpress). 

I am having this same issue. I have been trying to get around it for 2 days now. Does anyone have a fix or a cause for this?


Has anyone been able to upload a podcast AT ALL since Friday June 28th? 

Does anyone know anyone else that has uploaded since Friday? 

Please lmk so that I know if I am doing something wrong or not. 



After your post, I tried with different browser as well ( Chrome, Firefox, Safari on Mac ) Microsoft Edge from Windows machine, but with the same sad result

I am having the same problem. I am using a LibSyn RSS feed, and everything checkedd out until it came time to submit. 

I tried all the ways that have been said here and they did not work for me, the only way I could do it was to change host. Then what I did was to look at the hosts that have Spotify default and I uploaded my audio in one of them. The one that worked for me was Anchor. With that host my podcast was immediately linked.

Which makes a bit of sense since Anchor was recently picked up by Spotify.

The only problem that I had found in doing so was that I was afraid of not being able to access the Spotify analytics but actually if it is possible, after uploading my podcast in Anchor I tried again to get into the Spotify podcasters page, and without problems he let me in.

So that was the solution I found. I hope it serves those who are having problems.

Captura de Pantalla 2019-07-01 a la(s) 1.34.05 p. m..png
Captura de Pantalla 2019-07-01 a la(s) 1.34.20 p. m..png

Still not working...


Changing hosts is not an option for everyone, I don't want to do that for example, as I am otherwise happy with mine and the service they provide. Thus it doesn't really fix the problem.


I'm having the same issue trying to submit podcasts,


I'm using feedburner RSS links and have tried multiple browsers with no success,


I'm also trying to submit multiple podcasts and none of them work with the same error message

I am using Anchor but I am unable to claim my podcast anyway, no matter what browser (safari and chrome). I sent an email and waiting for a response 😞

Suggested posts