Help Wizard

Step 1

NEXT STEP

Spotify connect feed dropping out

Solved!

Spotify connect feed dropping out

Plan

Premium

Country

Netherlands

Device

Yamaha MusicCast wxad-10

Operating System

Windows 10, Android

 

My Question or Issue

For the last 2 months I have experienced random stuttering/buffering/dropouts with Spotify connect. The song playing will cut and resume with the pause between cut and resume shortening each time until the music resumes. It seems to be worse in the evening hours. It's absolutely killing my music enjoyment and not what I expect from a paid service.

- I have tried all of the "fixes" suggested

- My audio streamer is hard wired, so not a wi-fi issue

- This happens both with a mobile phone and desktop app connected controller.

- It does not happen with internet radio

- My ISP (Ziggo) has confirmed that the line is functioning perfectly. No dropouts on other (higher demand) services such as Netflix.

- I can see the download speed choke when the stutter occurs. Drops from 500-600Kbps to 10-40 Kbps and back up after the stutter stops.

- It is not time related. Not the same time interval between stutter occurrences.

- DNS is via Google as recommended

- Prior to this I have had 2 years of problem free Spotify music streaming

 

Nobody at Spotify seems to picking this up despite numerous posts on this forum.

Please, please, please Spotify take this seriously and get this fixed. You say "Listening is everything" so please live up to your tagline and get this fixed! Mobile streaming via Bluetooth at compressed quality is not what I bought or want.

 

Hope to hear something from Spotify really soon for all of the customers who are severely disappointed.

Reply
79 Replies

good news, Yamaha is sending the orevious version firmware to roll back and test. I'll do that before making any further changes to isolate the effect. Keep you posted!

Hey guys, I have been following this chat, as I have a similar issue: the audio of my Samsung hw q950a soundbar drops out for the split of a second, when I stream from my android Phone or the Windows PC App. It does not happen, when I start streaming from my girlfriend's iPhone. She also uses another Spotify account than I do. Could the drop out issue be account related? If so, what could I do, despite clearing the cache of the app or a clean re-install?

Thanks guys!

hi there, not sure if we have the same issue because, for me at least, it is specifically related to Yamaha streaming devices with Spotify connect

Hi, thanks for the reply and sorry for the confusion. Do you have an idea tho?

Hi all, after emailing with Yamaha today I found out something new. You can log into your Yamaha using a web browser and typing the IP address when you are connected to the same network. On the first page is adrop down that lets you select the mode. I never knew this and it's not in any manual.

My wxad-10 was on Extend_1 instead of Wired LAN in the settings. I've  changed this now and will test if it solves the problem. Hope this helps you too!!!! Finally something that makes sense!!

I'll have think with you but your setup is unfamiliar to me. Keep checking back here,
regards

Thanks mate. I think it has to be some account/device incompatitibility, as it works for my girlfriend. I will try to find an answer though.:)

didn't solve the stutter with the LAN setting. uggggh

I confirm. Same problem here since November with 2 Yamaha MusicCast devices that used to work properly before : MusicCast WXAD-10 and MusicCast CD-NT670D
This issue is so annoying I switched to Tidal last month !

Hello,
So this is the solution ?? Spotify ?? The solution is to leave you for Tidal ? Do you confirm ? Spotify ? Allô ??
Marked as solution

Hi all, before you get too desperate, I canconfirm that the fix is in the download and buffer config of the firmware. The previous version Yamaha firmware has been running faultlessly for nearly 25 hrs. Also in the peak 8-10 evening hours.

I'll update Yamaha on monady morning and try to get info regarding an official fix and update.

10/10 for Yamaha on customer service.

0/10 for Spotify for no service.

I'm assuming that the firmware is device specific but I'll post my fix instructions on monday having aligned with Yamaha. 

In the meantime you will need to find some info about your own device. You can find these by going to diagnostics in the MusicCast app.

Select your room and select the cogwheel top right.

Select App settings >Information>Diagnostics (at the bottom of the page)

You can find the IP address, Firmware version and Connection method there. (see screenshot)

 
Screenshot_20220115-173324_MusicCast.jpg

Hello,

Having same issues on my devices. Can we update the firmware by the web interface? Should we each contact Yamaha to get the old firmware or will they rollback their for all users? I have 4 different devices, isx80, isx18d, wx030 and musiccast 20, all get the same issue.

Either Spotify or Yamaha should take action.

Thanks a lot for the investigation Zedman.

 

BR

Hopefully Yamaha will issue an update but you can contact them directly for rollback firmware and to confirm that it works for your device.

You can log in to your Yamaha device to select the connection mode, update the firmware and select a few other options. Just type the IP address into a web browser when you are on the same network.

Yamaha sent me a "rolled back" firmware version via download link so, if you want the fix now, contact them at  **bleep**

 

best of luck!

Good grief! Spotify won't let me publish the customer service email address. Losers!

anyway, you can find it on the Yamaha Music Europe web site.

I updated my RN803 from wifi. I'am testing... no problem for the moment after half an our.
I'll keep you informed

@Alcyon, did you upload a previous version of the firmware from Yamaha?

I have the 3.0 version firmware. So the most recent. No cuts after one hour.

ok, only worked for me with the previous firmware from before 8 november with a different (higher) packet size and download rate. Hope this works for you!! 🤞

Suggested posts