Spotify doesn’t play on Bose SoundTouch anymore

Solved!
Reply

Spotify doesn’t play on Bose SoundTouch anymore

Shaderlees
Visitor

Plan
Premium

Country

USA

Device

(iPhone 11, iPad Air)

Operating System

(iOS latest update.)

 

My Question or Issue

I have a Bose SoundTouch which I can control from my iPhone or iPad using its SoundTouch app. I’ve never had an issue until a few days ago. Whenever I select a song, it just stays on the blue screen and nothing happens. No sounds, no information of the song or artist. Just blue. It’s the only music service that doesn’t work and Bose customer service says it’s 100% a Spotify issue. I’ve done most of the obvious troubleshooting so far (reset, sign out/in, reinstall, etc...). Does anyone have any suggestions? Thank you in advance!

 

 

jmellander
Casual Listener

As I have all my SoundTouch devices (SoundTouch 130, SA-5 and a SoundTouch Wireless adapter) in my cottage, I'm not able to test with the SoundTouch app since it doesn't present the services until it has contact with at least one compatible speaker.

 

BUT, after the fix to the bug I reported back in May got fixed (and it seems it's fixed in your version on the iPad as well) I've not had any problems.

As a wireless networking professional I can imagine that many of the problems reported in this thread are down to the network. There's often a lot of focus on the two peers in the playing: the app on the phone/table and the speaker. But the fact of the matter is that the networking infrastructure has a significant role in this as well. And though you would think that a wifi network is a wifi network, they can differ quite a bit as well.

It's not too uncommon by wifi vendors (whether it's access points (bridging devices) or routers/gateways (combined routing/NAT:ing and bridging)) to try to optimize traffic by filtering out traffic that is considered potential network hogs, and this often includes multicast traffic and/or broadcast traffic.

Since I can't look at how the SoundTouch device does discovery for the other services (the Spotify discovery is Spotify specific) I can't give the answer right now. But it could be that it uses broadcast traffic either to the global broadcast or local broadcast address (255.255.255.255 or 192.168.1.255 (if your network is 192.168.1.0/24)), and that the router/AP filters traffic for multicast but not for broadcast. What I do notice is that when using the Deezer app itself, it uses regular AirPlay discovery with mDNS. But Bose's app could use something else. (And theoretically there could be other things that affect the method chosen.)

Ideally one would do wireless packet captures to record the traffic and see what's actually sent and received. But this of course requires more skills than operating the Spotify app.

 

But until I get around to doing a more comprehensive guide  on how to record wireless traffic (not promising one, but I'm tempted to do one based on all the problems people have, and the fact that wireless packet captures are really the best way to troubleshoot things like this) I would look in the wireless router or access point admin interface and look for any kind of broadcast or multicast suppression. You can also check if different radio interfaces(2.4GHz (802.11b/g/n/(and maybe even 802.11ax, since that supports 2.4GHz as well) and 5GHz (802.11a/n/ac/ax) are not segregated/isolated. If you have the same SSID (network name) on both radios there's no real way of controlling which channel your phone and speaker connect to. Of course, the segregation scenario is not likely to apply if other music services do work from the app. (But could be applicable for those struggling to get connection at all.)

2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution!

santeri
Music Fan
Hey, thanks for the education! We've changed it to 255.

View solution in original post

Solution!

MoRiley50
Casual Listener
We FINALLY fixed ours by taking our pool O/S off of WiFi and hardwiring it
to the router. The pool O/S (Hayward OmniLogic) seemed to be interfering
with the other systems trying to use WiFi.

View solution in original post

80 Replies

Martins1815
Visitor

This also happened to me this past weekend. Soundtouch/Bose tried to problem solve and it is definitely not that system. It has to do with spotify. Looking for answers  too!

Rutg
Newbie
Same problem.

OnePlus 6
Premium plan

stepper2020
Visitor
Same here tried resetting everything including WiFi and it’s not working

Lenskie
Regular
Same here.. In the SoundTouch app.. when I try to play Spotify. It keeps saying..
We can't access you music service account right now. Try entering your username and password again (6157)

If found solution.. Pls help.. Ty

gerardbtmoore
Casual Listener
I've had the exactly the same problem with my SoundTouch 20 and it doesn't appear with Spotify Connect in the Spotify app either. Very strange and frustrating, given that my SoundTouch 10 is working fine with Spotify connect...

Veemaxt
Regular

I recently created a thread with exactly the same problem, soundtouch has dissapeared from the connect list. Now I read you have a 10 and a 20, the 20 is missing but the 10 is still there? Interesting, as my problem concerns the 2 soundtouch 10's I have. Am considering removing them from my WLAN/WIFI and reintroducing hem to the network. This is a recent problem, about a week ago i noticed they were missing. 

Have you tried anything to fix this yet?

Veemaxt
Regular
Sorted. I just had to unplug my bose speakers from the main electrics. Once rebooted they were in the list. I am sure my router is messing about and doing something to mess up the wifi settings.

Chris83
Visitor

I have the same problem!

Muhlyssa
Casual Listener

Same. I've reconnected Spotify to my Bose, thinking I just needed to login again. No go. Same blue screen of silence everyone else is reporting.

 

My guess is this has nothing to do with Spotify and everything to do with Bose. I've had my soundtouch for seven years now and it's been a source of endless problems. I've even named my device "Soundtouch Blows"

DavidHallett
Visitor
Ditto. Spotify mustve **bleep** up. Time they fixed it.

Peter
Spotify Legend

Hey folks,

 

Thanks for reaching out to us about this.

 

For users who are experiencing this issue and have access to other streaming services, could you confirm that this is only happening for you on Spotify?

If so, can you also confirm that you've tried the following:

  • logging into a different account
  • using Connect from a different device
  • connecting to a different network?

If none of the above steps work, let us know and we'll see what we can suggest next.

 

Thanks - keep us posted!

jazz_n1
Visitor

I had the same problem! The SoundTouch appeared in the "Connect to a device" list successfully for around 3 or 4 years, without fail. In fact the SoundTouch was the device that was always available when other devices like my Rocki play (so unreliable) or OnePlus6 (excessive power saver) were flakey as.

 

Then one day, my faithful SoundTouch speakers just stopped appearing. Disaster! With no notice, no error. I only knew it had dropped because all of a sudden Spotify was showing no devices on the list and instead offering me patronising 1-2-3 guides on how to connect a speaker! SERIOUSLY! I had to listen to music on my laptop speakers for almost half an hour!!!!!

 

I tried everything. Installing latest firmware. Reconnecting the Spotify account. Restarting my mac book and phone. Even rebooted my router. Nothing fixed it. Then, in a fit of frustration, I did a cold restart on speaker. Ripped the cord out the mains. Let it reboot. And low and behold, the old faithful speakers re-appeared.

 

And again, after 45 minutes of tinny music and two Ecosia searches, all was again well in the world.

Muhlyssa
Casual Listener

Glad to hear you got it solved!

Would you mind explaining a little bit more about how you did the "cold restart on the speaker"?  What do you mean by "Ripped the cord out the mains"

 

Thanks!

Muhlyssa
Casual Listener

 I did a factory reset on my Bose Soundtouch and it did the trick.

https://www.bose.com/en_us/support/article/resetting-your-system-to-factory-defaults-st10.html

Veemaxt
Regular

By ripping the cord, he means simply pulling the electrical cable out of the back of the soundtouch, waiting a few seconds until all lights are out and plugging it back in. Alternatively you can pull the plug out of the wall socket, but not all of us had access to it.  Main thing is, leave it unplugged until all the lights go out. 

Henrik
Casual Listener

My av130 gives the same problem with spotify. I can play the radio or my from my nas, but spotify won't work on this single speaker. Spotify works great on my 10ens and 20ies. 

When trying to use the worst app in history, Soundtouch just gives a bluescreen or says that it cant log into spotify right now.

♂️🤦‍♂️

Suz4disney
Visitor
Spotify will not work through my Bose system anymore. Pandora works fine. I’m suspecting has nothing to do with those but with Spotify. Please fix the problem since I am paying a monthly premium due for Spotify!

Lenskie
Regular
It still didn't work for me

mrhl247
Visitor

I removed the spotify account from the device, added it again and things were working again.

SUGGESTED POSTS