Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


"Your addresses didn't match" on the family plan.

"Your addresses didn't match" on the family plan.

I accepted an invitation to join a family plan. I obviously live at the same address and I was trying to do this while staying there too actually. When I typed the address it said it didn´t match. I decided to literally copy the address from the master account and paste, didn´t work. I tried several devices, phones, desktop, laptops. Doesn´t work. Please help, it´s really not a cheap service to be this ridiculously buggy as I´ve seen it´s an extremely common issue.


The email address for the account I am trying to join from is **bleep**, the master account is at **bleep**

Screenshot 2022-02-19 at 10.23.39.png



33 Replies

Did you by any chance move countries recently?

I had the exact same issue. I moved between countries and even after I changed my address to my current address my family members could not join. 

When i went to the "Manage Profile" section in Setting I noticed that although my Address and country where shown correctly in the landing page of the spotify settings. In Manage Profiles it was still given the old country. The reason for this was that I used a Credit Card from the old country and you can only change the country of residence once you enter a local method of payment.  

Hey folks,


Thank you for reaching out to the Community and welcome. 


As @ManaSecure mentioned, it's important to make sure that both accounts are registered in the same country to meet the plan requirements.


In case you've already checked this info and the country in both accounts matches, we'd recommend reaching out to our Support team here, who'd be happy to review your individual account and help you further. 


Lastly, keep in mind that posts in the Community are public and personal information should not be shared here. The web page will mask it with a "Bleep", but it's better to not include this type of info for security reasons.


​​​​​​​Hope this helps. If anything else comes up, the Community will be here for you.

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hello, I am having trouble to add a member to my family plan. The right address has been entered, but Spotify warned about a mismatch. I have double checked them and we have tried once more but it didn't work. What should I do?

Hello I'm having the same issue regarding my Family Plan. I got a premium Family account and sent the link invites to my family members but my dad cannot complete the process as the addresses aren't matching. We have tried it a thousand times already and we have made sure that the addresses entered are the same. There should really be another way to join Premium plans other than matching the addresses. Please look into the matter and suggest a solution.

P.S. I am the plan manager and I opened the account on my android phone and my dad has an apple phone, could that be a reason? I'm grasping at straws here. 

Hey there,


Thanks for posting in the Community.


If you've made sure your accounts have matching country settings as described here and still can't invite members due to the addresses not matching, you can forego the entering of the house number and use only the street name. Make sure to amend the Family manager's account address first as well.


Let us know how that went,



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

I joined spotify family today. I can't enter address, it never approve.

Why I can't find my address. all are correct


I try so many times. please fix

Hey @SaraMaxPro


Thanks for getting in touch about this. 


First up, make sure that your and the owner's account have the same country set and that this matches with the address given. Then, make sure the address is entered exactly as it is on the owner's account.


If all the info is correct, we suggest that you try accepting the invite again from an incognito window and a different device. 


Let us know how it goes. 

Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

I am the account manager of my family plan, and I have been trying to add my dad to the plan for hours now. It keeps saying the address doesn't match when I know it does, because I copied and pasted the address from my account and sent it to my dad's phone and copied it from his texts and pasted it onto the prompt, and it still doesn't work. I have tried everything the moderators on this board mentioned and they have yet to work. The only one I have not tried is changing the address only to street name because this is going to later ask every single member to reenter the address and I don't want the other member to run through same issue. PLEASE FIX THIS!

Hey @1251103653,


Welcome to the Community and thank you for joining the conversation.


If you've already verified that the address is the exact same one, and if you make sure the countries match as mentioned previously by @Eni, it's possible that your dad's account could have a restriction. If the account has changed group plans (Duo or Family) more than once in the last 12 months, they'll not be able to join another plan.


However, since we don't have access to users' accounts from the Community, we'd recommend contacting our Customer Support directly, so they can check your account and help you further.


Hope this helps. If anything else comes up, don't hesitate to ask.

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!


were you ever able to find a solution? Having same issue right now with my dad. 

Hey @Lizabe859,


Thank you for your reply in this thread.


If you've tried all troubleshooting listed here and you're still having this issue -  we'd suggest that you reach out to our teams directly. As @Oscar mentioned - they should be able to provide personal private assistance and give you more details in your specific case.


As much as we'd like to help you further - we can't make any account related actions here in the Community since the necessary tools for looking into this are not available for us(Moderatos).  


Hope this helps. Take care 🙂

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

I'm unable to join the family account after adding the exact same address. I've tried logging in through all other devices and via an incognito route. Still not able to log in. Kindly 

Also having the same problem again years later after upgrading account, even though all addresses match exactly and all country settings are the same. 


Spotify why have you never fixed the problem 

Hey @Ericksontx!


What you can try is asking the plan owner to update the address on their Family page. Once they do that, they can send you a new invite where you can enter the newly updated address to see if that does the trick.



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a "Like".
Are you new to the Community? Take a moment to introduce yourself!

It said that we don't have the same address

It is saying that we don't have the same address.

I have Family Premium and I am trying to invite my son who lives with me, but Spotify says that the address is not the same


You’d think after almost two years this would be solved. I’ve tried everything suggested here and nothing works. The only thing I haven’t done is change the address on my premium account because then I have to send an updated address to 5 separate people.

I’m having this issue today. I tried incognito, a desktop, a cellphone, and you also can’t just type half an address. It auto populates the full address as soon as you press enter. And you can’t not hit enter because then the address that Google suggests is blocking the “Find Address” button when you type in the street address. So it’s either click the full suggested address, or press enter and still select the full suggested address… So suggesting to change the address to just the street name wouldn’t even work either now that I think about it.

I need help and hopefully I’m just looking at this wrong???  

Even typing in just the street address and tabbing to “Find Address” doesn’t work, it still auto populates the full Google address. City, state and zip. 

Suggested posts