Can't remove downloaded podcasts from device or delete cache

Can't remove downloaded podcasts from device or delete cache






iPhone 11 Pro

Operating System

iOS 13.3.1

Spotify Version


My Question or Issue

I cannot remove downloaded podcast tracks from my device unless I reboot my device. And even this only works ~50% of the time. In most cases when I tap the green down arrow icon (which indicates a file is stored locally), nothing happens. I also try using the three-dot menu and tapping 'remove download', but this also does not work.


I also cannot delete the cache when this happens. Tapping the 'Delete Cache' button provides no message or change in storage consumed.


I thought that maybe the messages/icons were just not working properly, but the files still play offline and the storage used by Spotify does not decrease.


Sometimes if I restart my device, removing downloads will work for a few minutes.


Thanks for any help!

11 Replies

Hey @abbazabba52, welcome to the Community.

Hope you're doing great!

You are just disabling the offline availability, the songs/podcasts are still downloaded on your device.


Check this Spotify Answer on how to claim back that storage.


Thanks and take care 🙂

LoxerSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Thanks for the response. I have tried reinstalling the app per the instructions at the link below, but removing downloads still only works for a few mins.


Can you clarify what you mean by this?

You are just disabling the offline availability, the songs/podcasts are still downloaded on your device.

Surely, tapping 'remove download' is supposed to remove the file from my device?



Hey @abbazabba52,


If you tap to remove the download you just switched that things state, as it doesn't remove the cache. To do so go to Settings > Storage > Clear Cache and now you have totally removed the downloaded songs from your device.


Hope that helps 🙂

LoxerSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Tapping 'remove download' should be removing the file from the device including the cache. Sometimes, that does work, but not consistently.


When it's working properly, tapping the 'remove download' button causes the storage consumed by 'downloads' and 'cache' to reduce (note, this category of storage space is distinct from 'cache' in the settings menu for 'storage') because presumably the file is being deleted from local storage including any copy of it stored in the cache for quick playback.


However, the issue I'm having is that when I tap the 'remove download' button like 90% of the time nothing is happening. The download is not removed, and the icon does not change color/status. The amount of storage consumed does not change.


A separate, but related issue is that tapping the 'delete cache' button also does not function most of the time. Only after a reboot, and even then only sometimes.


I hope that clarifies the bug that I'm running into.


Unfortunately the answer about just disabling the offline availability and clearing the cache is incorrect.  This problem exists for me exactly as it does for you.  I tried to remove several played downloads yesterday, and as you described, nothing happened. This morning all those podcasts were still on the device.  I tried again this morning and for some reason it decided to work, giving me the "are you sure" choice.  So I went ahead and individually deleted about 20 downloaded podcasts and it worked as it should with all the deleted podcasts disappearing from my downloaded list.  I did not have to clear the cache or restart the phone or anything else.  It just decided to work and they are really removed.  I found several other threads describing this problem so it has been known about for a few years and still not fixed.


On a related note, Spotify does not have a method to mass delete podcasts.  There is also no setting, like in most other podcast apps, to delete downloads after playing.  Both of these options have been asked for many times over the years, even posted in the Spotify ideas or requested features section.  But like most of the user generated suggestions and ideas, these two have never been implemented by Spotify. 


Hope this helps.  For now there is nothing to do except try individually deleting each downloaded podcast.  If it does not work, I just try again at another time.  Eventually my Spotify app will do it.

Thanks Will. Yeah I noticed oddly for me when I do restart my phone, and can delete them. As soon as I connect a Bluetooth device it then stops working. It really seems like this is a reasonable issue to be patched.

Wow! Great observation on the Bluetooth. That seems like it could be the issue for sure. I will keep track, but definitely when I try to do it, I usually have bluetooth headphones connected. This morning when it worked those headphones were off. Thanks!

Yup it seems to be the Bluetooth connection preventing the remove button from working. I’ve had this problem for over a year now and Spotify’s support told me the same **bleep** about reinstalling and deleting the app cache and it never worked. But I just tried turning off the Bluetooth on my device then restarting Spotify and the remove button worked...

This problem has nothing to do with Bluetooth, it's a known issue and they still haven't fixed it. Sometimes it works for me sometimes it doesn't. Sometimes they'll remove themselves from my list and sometimes they won't. 


Spotify fix this! It's the absolute worst.

Thank you! It definitely looks related to Bluetooth.


I couldn't delete a few played podcasts last night while connected to Airpods, nor this morning while connected to my car's Bluetooth. I read these comments while sitting in the car, turned off Bluetooth on my iPhone, and... was able to delete the downloaded episodes right away. Didn't restart phone, didn't even close Spotify.


In theory, the ability to delete downloaded episodes should have nothing to do with Bluetooth. But it's hard to argue with the evidence.

Oh my! It really is related to bluetooth!


I can't believe this bug hasn't been fixed by Spotify yet and their support staff on these forums seem to be completely oblivious and misunderstand the problem every time it's posted.


FFS, Spotify. 🤦‍

Suggested posts