Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Dragging items in queue is buggy

Dragging items in queue is buggy






iPhone 11 Pro

Operating System

iOS 13.1.1


My Question or Issue

With the lastest update (downloaded today), reordering items in the queue is very difficult.


To reproduce:


  • Play a song/playlist/etc.
  • Open the queue
  • Scroll the queue downwards (i.e. to browse songs that appear offscreen initially) — this seems to be the key step
  • Now grab the "handle" next to a song and try to drag it up or down, you'll notice that the song and the queue both move, so it gets very unwieldy

I can capture a screen recording if need be.

15 Replies

Hi there!

I know it sounds simple, but it's often overlooked. Could you try restarting your device? If that doesn't help, try a quick clean reinstall of the app. Just follow these steps.


Also, a screen recording would be helpfult too 🙂

If you're still having trouble, could you let me know the exact version of Spotify and the exact version of the operating system you're running?

I'll see what I can suggest next!

See attached screen recording (taken after force-close + reboot), showing:


  • Normal scrolling behaviour when queue is first opened
  • Buggy scrolling after queue is "scrolled down" a little bit

The attached screenshot also shows the app version (this is the latest version, installed on a new iPhone 11 Pro with the latest iOS 13.1.1).


I'm still experiencing this issue, even after the recent app updates. Can anyone shed any light on this?

This is still happening. Now at version

Same issue for me. I am in Italy, with iPhone 6s, iOS 13.2.3 Spotify
I have this issue from a few months. I tried to re-download the app, to soft reset the phone, but nothing.

This is still happening. Now at version

I also have this problem. When you go further down the queue and try to drag it to the top, both the song and the list move causing a glitch. Sometimes it even crashes the app.

iPhone X
iOS 13.3

Hi @Stjimi & @user-removed,

Please see the update from the Spotify teams here regarding this issue.


They are aware of this problem but they can't action this right away the last update stated 'We don't have a timeframe for a fix, but hopefully we'll have an update soon.'


I'll see if I can get a update on that thread that I have linked above but I cannot guarantee anything. 




@EthanS1, these issues aren’t related in any way (apart from the fact that they both involve the queue).


The bug described in this thread has to do with reordering the queue, whereas the bug you’ve linked to involves a single invisible / transparent song title in the queue.


View my screen capture if still not clear (see original post above for more info):

Hi @user-removed,
I've had an update today from the appropriate team interally about this, I have been asked that you +VOTE the previous on-going issues that I linked you to and also add your comments there about this issue as it seems that they are potenitally both related and this is the best way to get the issues you are having reported across to the right folks so they can take a look at this behind the scenes in further detail!


Thanks for your continued paitence on this issue, any further updates will be made in that on-going issue regarding this.


Take Care for now


Done and done:


Thanks for following this one up @EthanS1, fingers-crossed it (finally) gets on their radar.

Hey there folks,


Thanks for posting about this here in the Community!


To add to what has been shared here, there's a different Ongoing Issue that sounds like the issue you're experiencing. 


If this sounds more like what you're experiencing, we'd recommend adding your details there so we can report it with the right teams. 


Hope this is useful but don't hesitate to give us a shout if there's anything else we can help with - we'll be happy to lend a hand! 


Have a lovely day 🙂

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself! 

It certainly sounds similar, however I don’t believe it’s the exact same issue. The full/clean install steps didn’t help.


It’s been 5 months now, other users have confirmed they’re getting the same issue, however this bug still hasn’t been formally acknowledged, so I’ve given up hope that it’s going to get fixed...

6 months and counting. Still not fixed.

Hey folks,


Thanks for reaching out to us about this issue.


This is something that we've been looking into here, but we don't currently have a timeline for a fix.


We suggest that you keep your app updated at all times to get any future fixes for this and other issues.



Suggested posts