Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Smart shuffle bug

Smart shuffle bug







iPhone 13 mini


Operating System

iOS 16.3.1


My Question or Issue

Smart shuffle messes up the order of the playlist of Liked Songs even after being turned off. The following behaviour explains this:

- play the playlist of Liked Songs on normal shuffle
- say that it randomly plays the 123th song in this list
- now I want to turn off shuffle BUT the button has this weird counterintuitive behaviour that it toggles to smart shuffle first and only then can you toggle shuffle off completely 
- when the 123th song finishes (shuffle is off right now) not the 124th song is played but a random other song
- this is either a bug or in my option not expected behaviour by the app 
11 Replies

Hey @Aikewoody ,

Thanks for reaching out.

We've tested this on our end, however, we couldn't reproduce the behavior you're describing. Would it be possible to send us a short screen recording and check if this happens on another device using the same account?

Looking forward to your reply.

Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hey @MihailY,


Thanks for the fast reply!


The screen recording was more than 5MB so it couldn't be uploaded on this forum, that's why it's uploaded to youtube:


The bug seems to only happen when the song is fully played without being skipped, that's why the recording is almost 4 minutes long.


Following the recording the steps to reproduce are:

  1. play the "Liked Songs" playlist
  2. enable shuffle
  3. click on the "next song" button
  4. click on the "shuffle" button, smart shuffle is enabled
  5. click on the "shuffle" button, shuffle is disabled completely
  6. wait until the song is finished and the app goes to the next song
  7. observe that the next song that's played isn't the correct one

- in the recording you can see that the song that is played is: That's Me from ABBA

- in the playlist the previous song of that one is: Me And I from ABBA

- while the song that was playing before this was: Sexy **bleep** from David Guetta, Akon

- shuffle was completely off so this should not happen


ps: I have tested this on an iPad Pro (12.9-inch) (3rd generation) running on iPadOS 16.2

Hey @Aikewoody,


Thanks for getting back to us and providing the screen recording.


We appreciate you taking the time to report this and share your feedback with us.

The Smart shuffle as a feature is still new and we're working on finetuning it and this report will help with us. We'll make sure to pass the info onto the right team and we'll work on improving it's functionality, as Spotify constantly strives to refine the user experience.

However, we can't promise that this specific issue will be addressed. In the meantime, we advise that you keep your Spotify up to date with the latest version so that you don't miss out on any fixes.



Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hey, I've got the same issue. It's really annoying. Heres a screen recording


Please fix this


Voici la solution, veuillez désactiver le smart shuffle depuis la playlist et non l’overlay de la musique. A noter que si vous réactivez l’aléatoire puis que vous le désactivez depuis l’overlay de la musique ce bug surviendra à nouveau, à désactiver de la même manière) 


I have had the same issue as the original poster, except for mine has this issue no matter what. I press shuffle on my likes songs, I switch to smart shuffle, it works, I switch to no shuffle mode and it always takes me back to the same song in my liked songs. This has been an issue for me for months, it is very very annoying, PLEASE fix.

still having this issue. Liked Songs playlist on shuffle, then i come to a song where i want to hear the next song right after it in Liked Songs, not continue shuffling Liked Songs, so i hit the shuffle button to turn off shuffle, which of course brings up smart shuffle after a one second loading time, then i click again because i didn’t want smart shuffle i wanted to turn off shuffle, but after i do this and the shuffle button is unpressed, the playback goes to a random song in my Liked Songs playlist. and it goes to the same random song every time. crazy that you guys haven’t fixed this yet 😅

The issue still persists even in 2024. I'm really considering YouTube Music now, lol.

I managed to "fixed" it by clearing the queue. Not sure if this is permanent or just temporary though.

Hello, I have the same issue, even tho shuffle is off or is in normal shuffle (meaning that it should not add recommended songs) it still ends up adding recommended songs, I look at queue, turn off smart shuffle, and I get a pop up message saying “recommended songs have been removed”, the queue changes and there are recommended songs everywhere.

Suggested posts