Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify error-01 with a car stereo (Alpine CDE-111RM)


Spotify error-01 with a car stereo (Alpine CDE-111RM)



My Iphone 4S IOS5.0.1 works fine with my car stereo, except spotify doesn`t.


My ipod feature, navigation system and other programs works fine with my car stereo. And when I start the spotify premium app, it plays a track like 0,5 second and after that the connection crashes. Car stereo tries to search the connection and after that it gives (ERROR-01) message. The error message is only removed if I reboot the Iphone...


I am closing the premium account if theres no fix for this. I hope there is...


There are hundreds of users that have the same problem with spotify and car stereo (atleast Pioneer and Alpine), I`ve read them from other forums. There has to be something wrong with the spotify because other programs work.


Any help and suggestions ? or shall I put my account to hold ?


Accepted Solutions
Marked as solution

Same issue too.... iOS5.1 Apline.... it worked the first time I tested it but now it doesnt :'-( please fix it!!! 

View solution in original post

Marked as solution

Marked as solution

here it is:




let me know when you've got it and I can then remove from the post. Frustrating you can't send PM's on here 😞



View solution in original post

Marked as solution

@dexterhart wrote:

I cant believe Spotify has deemed this issue solved because some user put up instructions to hack a "old version" of their application, so it will play on their alpine head unit.

Any user on the community can mark a post as a solution.

Airhorn Enthusiast

View solution in original post

Marked as solution

darn it, keep getting the message:


Spotify was not installed on the iPhone "xxxxxxiPhone" because you are not authorized for it on this computer 😞


I've authorized it by entering my password for my apple id but it won't accept it. I wonder if this is because I didn't install Spotify from the app store until a later version 😞


Now very disappointed in Spotify 😞

View solution in original post

108 Replies

I actually have the same problem with my Alpine head unit.  I am not personally aware of any fix for it, but I would also like an answer to this question.  I've worked around it by using an FM transmitter when I listen to Spotify, so it's not the end of the world for me if it turns out there is no fix, but it would be nice to use the direct connection.

I am also having the same issue. The app was working fine with my alpine car stereo until this newest update. Now I'm getting an error-01 message every time I try to use it.

Quit working for me about 4 updates ago last year around September. I use a OEM Acura Navigation system with iPod functionality. A few other reviews on iTunes have listed this same issue.

Same issue...this is a huge inconvienience. Can't pin point which tracks do it either. Happens to ones I've imported from iTunes, added from Spotify, local tracks as well as streaming.


Please fix this!

Hello having too the "error-01" on my alpine stereo


BUT i've found why !

it's related to the number of the song in the playlist


- ios5 comes with track metadata display, and, i think, track number of the song trough the total number of the playlist

- apple music app transmit right all the metadatas

- to use spotify we need to "pause" the music app.

For the example in the apple music app we says we are in a playlist of 25 songs

- so we switch to spotify, and plays songs BUT if the song number is greater than 25..... ERROR-01 !


Spotify devs, could you take a look ?


Edit: i've the same bug on 2 different alpine stereo...

Marked as solution

Same issue too.... iOS5.1 Apline.... it worked the first time I tested it but now it doesnt :'-( please fix it!!! 

I also encounted the same issue, need either find a way to roll back to a previous version without meta data support or cancel the account. Hope a fix comes soon

I got the exact same problem with my car stereo after the update.

My friend however also using an iphone with an much older version of spotify has no problem at all, and that goes for both mine and his stereo's (both alpine but his is a bit newer)


I aswell never had a problem until the metadata update thingy.

Just add a function in spotify that allows us to turn it off manually? that might fix the problem

I've got a partial solution to this issue.

If I get an error-01 in song 26 for example,
I disconnect my iphone for a while, then look for this particular
song, play it and finally plug in my iphone again. That works,
but It's a pain in the neck having to do this every time I get an
error message.

Please, Fix this soon!

100% same issue, bumping this as a fix really should be put in place.


It's the difference between me keeping my spotify premium subscription or cancelling..


When it's working, it's great.



Me too same issue, would like a fix.

Spotify...where the heck are you???? PLEASE FIX THIS!!!!!!!

jargspotify - tried your solution but didn't work for me 😞


i can't seem to get passed track #38. This seriously sucks. Spotify...where are you??

Strange, for me i can't pass track #51...
Thought this was linked with itune playlist so i've created a 499 track list but... No, no link at all...
Can somebody could confirm this issue with really recent alpine stereo ?

FYI - I'm sure everyone is a bit faster than I am but I just figured out how to submit a bug report. Wouldn't hurt if everyone took the time to do this in the hopes that the more who complain the quicker this gets flagged to be fixed.

NNois - I've tried that as well. Also tried starting my device up and without starting the native player, starting luck there either. I think it has something to do with the number of tracks added before the one update that sent everything into a tizzy. For me, it was the update after I joined Spotify that did it, so I didn't get many tracks added...

if i remember correctly there was a hack related on cydia for disabling the new metadata stuff... But personaly i don't want jaibreaking my iPhone because of a bug !

soo.. no real response to this thread? no "we're working on it" "we are aware of the issue" ? or do spotify just dont give a **bleep**?

this issue is getting old.

ha i just got a repsonse from support....


Hi there! 

Thanks for getting int ouch with us here at Spotify! 

I'm afraid we don't actually support any car head units officially so there's not much we can do about this, I'm really sorry =( 

The next best thing I would be able to suggest would be to try using a regular 3.5mm cable and plugging your iPhone into the aux port of it if it happens. 

Kind Regards, 

what a freaking their fix is for me to invest more money into a new headunit to have a sub par solution in place? brilliant. maybe i'll just invest that money back into Apple iTunes and work with a company who wants to provide a good customer experience...

Suggested posts