Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify error-01 with a car stereo (Alpine CDE-111RM)


Spotify error-01 with a car stereo (Alpine CDE-111RM)



My Iphone 4S IOS5.0.1 works fine with my car stereo, except spotify doesn`t.


My ipod feature, navigation system and other programs works fine with my car stereo. And when I start the spotify premium app, it plays a track like 0,5 second and after that the connection crashes. Car stereo tries to search the connection and after that it gives (ERROR-01) message. The error message is only removed if I reboot the Iphone...


I am closing the premium account if theres no fix for this. I hope there is...


There are hundreds of users that have the same problem with spotify and car stereo (atleast Pioneer and Alpine), I`ve read them from other forums. There has to be something wrong with the spotify because other programs work.


Any help and suggestions ? or shall I put my account to hold ?

108 Replies

I think 4.24 is unlikely to work. I did try that one without success. I had to regress to 4.20 to get a working version.

This is sad

So far 4.24 is working, and I say so far with everything crossed, see how long it lasts 🙂

Could you share it ?

I can try, do you have dropbox or google drive?

yep !

Hi NNois,


I'm just uploading it now, you should get an email with details 🙂



Any chance I could get a hold of that aswell? I'm having the same problem.

After 3 days of it being ok I got the error-01 last night 😞


So, anyone have the 4.20 version out there?

send me your mail address and I can send it to you

Marked as solution


Marked as solution

here it is:




let me know when you've got it and I can then remove from the post. Frustrating you can't send PM's on here 😞



Marked as solution

@dexterhart wrote:

I cant believe Spotify has deemed this issue solved because some user put up instructions to hack a "old version" of their application, so it will play on their alpine head unit.

Any user on the community can mark a post as a solution.

Airhorn Enthusiast
Marked as solution

darn it, keep getting the message:


Spotify was not installed on the iPhone "xxxxxxiPhone" because you are not authorized for it on this computer 😞


I've authorized it by entering my password for my apple id but it won't accept it. I wonder if this is because I didn't install Spotify from the app store until a later version 😞


Now very disappointed in Spotify 😞

Can you please Pm me the iOS 4.2 sw version?? Or perhaps share it online?? Really want to sort this out so I can use Spotify in the car...which is the main feature for me Many thanks in advance

Baased on Specialk72's experience I am not sure this is going to work. Perhaps iTunes makes the app machine specific so you can't just share the executable between accounts. Makes sense.


I suppose then this would mean that you can only recover your version of 0.4.20 if you have it in your archive and can recover it off your system. I did this using Time Machine on Mac. It worked for me but it seems as though it does not work between systems.


If this is indeed the case, it puts more onus on Spotify to try and resolve the issue of what ever changed between 0.4.20 and 0.4.21 that broke the Spoitify head unit compatability (and breaks iTunes in the car as well, when Spotify is running in background, I have found)

Yes it seems davewhughes is right, there is something linked to/in the .ipa file that associates it to the Apple ID that it was downloaded with so no syncing versions to your phone sent to you by others 😞


I am unable to retrieve a version earlier than 0.4.24 as that was the version available when I first downloaded Spotify in May this year.


So, yes, Spotify, please sort this out, tell us you are listening and do what you can to help or I will be cancelling my subscription 😞

Okay thanks


I find it really sad that WE the paying customers are searching for fixes harder than spotify is....


Please Spotify, step it up.

(Alpine CDA-9886)


I had installed the 4.2 version, which worked, but then I went ahead and updated to the latest because I wanted to try out the new radio functionality.  Coincidentally, I had a problem with my internet connection at home so I disabled Wi-Fi on my iPhone 4S.  After a few days in the car, I noticed that I wasn't getting the error-01 anymore. I remembered that I still had Wi-Fi disabled in my settings.  I re-enabled it and started getting the error again.


I'm really skeptical that this would be a solution, but so far I don't get the Error-01 message anymore when I turn off Wi-Fi on my iPhone 4S.  I was getting it very frequently.  Easy thing to try, so I would recommend seeing what your results are.

Suggested posts