Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify error-01 with a car stereo (Alpine CDE-111RM)


Spotify error-01 with a car stereo (Alpine CDE-111RM)



My Iphone 4S IOS5.0.1 works fine with my car stereo, except spotify doesn`t.


My ipod feature, navigation system and other programs works fine with my car stereo. And when I start the spotify premium app, it plays a track like 0,5 second and after that the connection crashes. Car stereo tries to search the connection and after that it gives (ERROR-01) message. The error message is only removed if I reboot the Iphone...


I am closing the premium account if theres no fix for this. I hope there is...


There are hundreds of users that have the same problem with spotify and car stereo (atleast Pioneer and Alpine), I`ve read them from other forums. There has to be something wrong with the spotify because other programs work.


Any help and suggestions ? or shall I put my account to hold ?

108 Replies

Probably the worst support answer to date.
How can they care so little about their premium customers.
It's clear this worked fine until they went ahead with the metadata update, is it so hard to add a debugmode Of some kind to disable the metadata again? Or just let us downgrade our spotify version on iOS in order to get rid Of this frickin meta crap

couldn't agree more...


is there really an app for jailbroken iphones that disables metadata? if so, maybe someone could try it as a proof of concept? then we'd have more info to give them...? sucks that we're even at this point and that spotify doesn't care about their premium subscribers...but i'd like to see this resolved. 

Please, could you post the way to disable the metadata via jailbreak. I think is the only way for use spotify in our alpine units. Thanks a lot

Anybody try out the new update?


I did and it seems now that any songs I had stored offline before running the update now work without the ERROR-01 annoyingness. I tried to play a streaming song and got ERROR-01. I then tried to store that same song offline, then play it, and got an ERROR-01. The pre-update offline tracks still worked however. Some weird times are showing up on the screen though. I would start a song and the track timer would start at something crazy like 7:59 or something. Sometimes it would start at 1:34 or something random like that. Whenever I use the headunit controls to change songs, it reverts back to the native iTunes player.


Baby steps in the right direction I suppose. It  is still bull**bleep** that they won't fix this. I'm literally burning CDs so I can listen to music in my car. Completley defeats the purpose of having a Spotify subscription.


Anyone else have any feedback after the update?

What an appalling support response by Spotify. It is clear that a recent update has done something to break this and it is not unreasonable for people to want to use the system in the car, especially if they prodide a mobile app.


Using the 3.5mm jack is not an option. The difference in quality levels is immense and makes it not worth the bother. It is worth considering putting all the Spotify licence money for premium into buying the music you like to listen to and go back to iTunes. I am not sure this is a trend that Spotify intends.


Come on Spotify, show a bit more of that entrepreneural spirit that started the company and listen to your user base. I doubt that this hard to fix and would be greatly appreciated by a whole sector of your community!


A little more about these USB connections. Generally, they are only set up to run with the built in music application on a device. While we try and be as compatible where possible, but sadly sometimes these things do not work as planned. We have an FAQ about Docking Stations and the like right here.

One such thing you could try is seeing if you an update the firmware of such docking devices - this may get things running correctly.

Airhorn Enthusiast

Thanks for chiming in and thanks for the link but there is nothing on that page that speaks to Apline head units which is what this thread is about. 


The thing that is especially annoying about this scenario is that Spotify worked perfectly with the Alpine head units until an update occured I beleive in the fall. So, its clearly something that Spotify changed, not Apple, and not Apline. Have you read through this entire thread? There is some good speculation as to what the issues may be. Perhaps bringing these to your techs will help them identify whats wrong and a fix can be incorporated in the next realese.


We would all aprpeciate more attention to this issue. The fact that we are paying customers and have recevied such poor customer service is really maddening. I don't buy the "we code to standards" excuse since it worked at one time. Please contintue to update us on the progress of this issue.

Thanks for the reply. Unfortunately I did not find anything helpful on that page. 


The key thing here is that everything has been working fine since I originally downloaded the app. It is only recently that things have gone awry and the only thing that has changed is the Spotify app has been updated. So something in the app has broken this capability.


To say it was useful was an understatement. It is the best and only way to listen to music in the car, fully synchronised and great quality. It is really frustrating to lose this crucial way to listen to music.  I see there are many others in the same boat. 


We would all really appreciate you taking a closer look into this. We would all like our music back in our cars!

Really would like this fixed ASAP also. This was one of the main reasons I went for spotify premium. Get it sorted Spotify, or I will take my money elsewhere.

I am in the same boat as everyone else here.  I wonder how many people are like me and have this problem but just haven't reported it on this board.  Spotify used to work wonderfully on the Alpine.  You did an upgrade and now the Error-01 problem occurs.  This is on you guys.  Please fix this b/c I have actually gone back to iTunes to play in the car and really have no reason to continue paying for something that doesn't work anymore!  I have recommended the premium version of Spotify to friends but this issue and its lack of attention is certainly frustrating.  Thank you!

I have found a solution that works. (on the Alpine CDE-103BT anyway).


I wanted to see if I could test a previous older version of the Spotify app, because it used to work and I figured something had changed to stop it working.


I have found that you need to go back to 0.4.20 to get the last working version.


I was able to do this because I am using a Mac with Time Machine. No idea how you would do this with Windows, but on a Mac it is very easy if you have been using Time Machine backup since October 2011.


- With this you can find the executable in the ~/Music/iTunes/Mobile Applications directory. I had to go back to 13 October 2011 to find mine. It will be called 'Spotify 0.4.20.ipa'


- Connect your device to iTunes (I was connected with a cable)


- Remove Spotify app from your device in the normal way.


- Copy the executable into the Apps page accessed from the left column iTunes and select 'replace'. 


- Reinstall app on device as normal. 


I now have Spotify music working in my car again - hooray! It's running an older version, but all I want to do is play music and it seems to do that.


I havefed all this back to Spotify support, so perhaps they will figure out where the issue crept in between versions 0.4.20 and 0.4.21 and fix it in the next version, who knows. We keep our fingers crossed.Smiley Very Happy


Let me know if you are able to replicate this, anyone.



Awesome feedback!


Spotify - where are you on this??!? This thred has a wealth of info that should help you pinpoint what is wrong and get the latest version of Spotify to play nice for your paying customers so we don't have to institue our own hacks.

I know this is a late thread, but I am having this exact problem. Spotify hasn't been much help, and like most of you, this will make or break my premium account. I am paying monthly for this service for the very reason to listen to it in my car, and I can't.  When I play music on any other app (Pandora), Alpine is fine, but when I try to open with Spotify... Alpine gives me ERROR.. and I can't even play ANY music until I force close the Spotify app. Very frustrating. Hoping for an update to fix this issue!

Also having this very problem. Where you at Spotify?

WHOUAAAAAHHHHH SPOTIFY NOW HAS AN "IOS 4" version on the app store

Tanks spotify Team

PS: With That one you don't have radios etc... But hey it works !

No it doesn't works ... Too bad

alpine deck issue same as the rest error 01, constantly without native music app running and even with it running unless..... and this has resolved my issue almost entirely and only annoys me when I have albums where the tracks are meant to run consecutively.  With 500 tracks of music on my ipod you probably don't need that much but i listen to way more and that is really minimalistic for me but put the native music app in random with all songs and then put spotify to random and voila for me issue resolved entirely outside of random issues when i change my settings and forget to put them back. hope this helps those struggling and this is with the latest update and worked for the one before that as well.



same problème here with an alpine ida X301 (error 01).

With spotify for iOS 4 does it work??



I cant believe Spotify has deemed this issue solved because some user put up instructions to hack a "old version" of their application, so it will play on their alpine head unit.


Spotify, I am going to cancell your service. This is complete BS. This issuse is not solved. Do not brush this under the table.




In a subscription buisness model, CHURN is a huge deal, +1% can destroy SaaS buisnesses. FIX THIS ISSUE and your churn rate will not explode.

I've got the same problem too 😞


I've just tried davewhughes solution that worked for him but unfortunately I first downloaded spotify at version 0.4.24 but will see if this fixes the problem for me.


If not then I will seriously need to consider canceling my premium subscription as this is one of the main reasons I got it and if it won't work and Spotify won't sort out then - bye bye 😞

Suggested posts