Help Wizard

Step 1


Discord connection with Spotify isn't working

Discord connection with Spotify isn't working







PC & Moto G8 Play

Operating System

Windows 10 1909 & Android 9.0


My Question or Issue

I factory resetted my PC and now Discord connect isn't working. Before it worked without any problem! I can't join parties, or when I join them, the music plays on my smartphone. And Discord doesn't show Spotify is open or show any music playing on my PC in my status. I also can't invite friends to parties because it doesn't show in Discord status, like I said. I already tried to un-link and link them, and reinstall bot apps, it didn't worked. What should I do? Creating a new Spotify account isn't an option.

9 Replies

Hi @ichigueira

thanks for reaching out to the community !


Can you please verify if you're experiencing this issue on your PC only? have you tried checking it on other devices ? 


A small trick I can suggest is to have your PC restarted, then to use this Spotify Answer and run a clean reinstall of the app (leads to the Microsoft version and it's a bit of a different install).


Last but not least, any screenshot describing what you see on your screen might help indication where the issue's located.


Thanks for your cooperation 🙂


Oh, and I restarted my PC multiple times 😞 Didn't worked!

Edit-  I clean installed it and still not working. And I don't have any other computer to check if it is only here 😞


Still nothing 😞

Hey! I answered you, but I forgot to mention you!

Hi @ichigueira,

thanks for the update !


I would take an educated guess here as I think there might be some issue with your drivers (based on the factory reset you've done).


Please check for any available updates for your OS and drivers, particularly for the network adapter.


If that doesn't do the trick, please visit this Spotify Answer on how to check your hosts file for Spotify entries. 


Let me know how it goes 🙂

All drivers are updated. First thing to do when I reset my PC is to download Driver Booster. And I don't have any of those in hosts, take a look:

Hi @ichigueira,

thanks for your patience !


You can find some more useful steps in this thread.


Let me know how it goes 🙂

Nope, tried everything in the topic, nothing worked.

Hi @ichigueira,


I strongly recommend trying the connection of the two on a newly created account to see if that does the trick.


If that does not solve the issue, I would refer you to Discord's support team here to have them take another look on their end.


Hope this'll help out:)

Suggested posts