Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

[Android] Disable autostart in android

[Android] Disable autostart in android

I would like to stop Spotify playing automatically whenever I get in my car. I've already turned off "allow to run in background" and it's still autostart img. What can I do? 

Reply
10 Replies

I have thé same problem

Hi folks!

 

Thanks for reaching out about this in the Community. 

 

First up, we recommend running a clean reinstall by following these steps to see if that helps.

 

If this doesn't do the trick, could you let us know how you're using the app in your car? We'd like to know if you use Bluetooth or if you have the Spotify app in your car stereo, etc.

 

On another note, we suggest that you check this article about Spotify in the car. 

 

Cheers - keep us in the loop 🙂

EniModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 
“Music acts like a magic key, to which the most tightly closed heart opens.”– Maria von Trapp

I already reinstalled the Spotify app several times with no luck.

I am using it through Bluetooth in my car.

This problem used to occur all the time for years until I fixed it myself
by turning off "allow app to run in background" through Android settings.

Then Spotify finally added its own setting for this in their app and it
worked as intended for a month. Now on the past few weeks it's back again.
I've turned off all the settings and it still plays automatically when
connecting to my cars bluetooth

Hey @gsus619,

 

Thanks for getting back to us and for the troubleshooting you've done.

 

We recommend that you turn Autoplay off (gray). This option can be found in the settings menu under the Playback section. Give your device a quick restart after the change.

 

If that doesn't fix things, we'd appreciate the version of the app you're running a screenshot of the setting you mention. You can attach it to your reply via the post editor, just make sure to hide any private info.

 

Hope this helps, keep us posted!

 

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I have turned off autoplay and it has not made a difference. I have turned
off almost all options in Spotify and it still connects automatically to my
Bluetooth.

I have turned off autoplay and it has not made a difference. I have turned off almost all options in Spotify and it still connect automatically to my Bluetooth. 

 

 

Screenshot_20201229-120011_Settings.jpg
Screenshot_20201229-120059_Spotify.jpg

I am seriously thinking of deleting the app altogether and using YouTube music. Here is the version of Spotify I'm using 

Screenshot_20201229-120405_Settings.jpg

Please let me know when you fix this hug as I really like using this app

Hi there @gsus619,

 

Thanks for the info.


Can you try logging in with a different account? You can ask a friend to log in with theirs on your device or create a free test account.

 

This way we can check whether this is an account related issue.

 

Keep us posted!

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Completely unrelated solution by Spotify. They keep ignoring the issue by wheeling out this old chesnut. C'mon Spotify.. focus please

Suggested posts