Autoplay not working properly

Solved!

Autoplay not working properly

ryan103

Plan

Premium

Country

Singapore

 

Device

Samsung Note 20 Ultra 5G

Operating System

Android 10

 

My Question or Issue

Autoplay doesn't work when on an album or individual single. After song finished it stops. I have tried a fresh install, clearing cache, clearing data, toggling option button within spotify. All with no result. On my previous phone Samsung S9 no issues, can choose to listen to a Single and after the single finished it will auto play songs similar. 

Could help with this issue? 

 

Reply

Accepted Solutions
Marked as solution

Alex

Hi there @ryan103,

 

Thanks for reaching out about this in the Community!

 

Could you try running a clean reinstall of the app. Follow the steps from this guide exactly. This will assure that all corrupted cache, which may be causing issues is cleared.

 

Make sure the Autoplay setting is also enabled in the app.

 

If that doesn't work could you try to start a Song Radio and let us know if that functions normally?

 

We'll be on the lookout for your reply 🙂

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

View solution in original post

Marked as solution

ryan103

Hi, 

 

I had tried a full reinstall and the setting made sure it was enabled, but the function wasn't consistent. 

 

I have sorted this auto play function out by going to Apps> battery usage > optimise battery usage > don't optimise app.

 

After this the function works fine, if the issue occurs again will follow the above. 

 

Thanks for the response! 

View solution in original post

4 Replies
Marked as solution

Alex

Hi there @ryan103,

 

Thanks for reaching out about this in the Community!

 

Could you try running a clean reinstall of the app. Follow the steps from this guide exactly. This will assure that all corrupted cache, which may be causing issues is cleared.

 

Make sure the Autoplay setting is also enabled in the app.

 

If that doesn't work could you try to start a Song Radio and let us know if that functions normally?

 

We'll be on the lookout for your reply 🙂

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!
Marked as solution

ryan103

Hi, 

 

I had tried a full reinstall and the setting made sure it was enabled, but the function wasn't consistent. 

 

I have sorted this auto play function out by going to Apps> battery usage > optimise battery usage > don't optimise app.

 

After this the function works fine, if the issue occurs again will follow the above. 

 

Thanks for the response! 

Jaimegm

Hi,

 

Im experiencing the same issue except none of the mentioned solutions have worked. I attempted them all multiple times and in different orders. Nothing seems to work and its incredibly frustrating... I tried to Start a Song Radio as mentioned in another post. The app opens the page for the Radio but doesn't start playing. When on a playlist, The app loads the Playlist Radio but doesn't play it unless i hit play or next track. It would be great if this could be fixed. It's seriously effecting my user experience in a negative way.

Device: Samsung Not 20 Ultra: Android 10

Clean install: step by step exactly like in the referenced guide

Clear Cache Log back in
Turned the Autoplay Feature off and on

I also turned off the optimise battery feature mentioned by another user

Jeremy

Hey there @Jaimegm,

 

Thank you for your reply and confirmation.

 

Can you try with another internet connection to see if the issue persist?

 

Also - If you have an SD card we suggest that you uninstall the app > turn off your phone > take out your SD card > turn on the phone again (without the SD card) > reinstall the app.

 

Keep us posted. We're always one reply away 🙂

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Suggested posts