Home page won't load

Reply

Home page won't load

Slcrowe
Music Fan

Since Spotify updated on my Pixel XL this morning, the home page won't load.  I have tried to uninstall/reinstall, as well as restarting my phone but still not working. I get a message that, "something went wrong....please have another go."  I've been trying off and on all morning.  This is just the home page.  My library still loads and the radio still loads and I can still browse and search, but I just don't have a home page.  Does anyone know how to fix this or have this issue as well?

Screenshot_20180321-085753.png
14 Replies

mchiang624
Casual Listener

Yeah, I also have a Pixel and if I try to open Spotify from the homepage, it'll open for 2 seconds or less and then close/crash. But if I open the Spotify by pressing and holding and selecting a playlist, it works. This issue has been happening since last night.

I've tried clean reinstalls, turning off my phone, restarting my phone, etc. Hopefully it'll resolve in 48 hrs too....

Ivan
Moderator
Moderator

Hey there @mchiang624

 

Thanks for reaching out to the Community about this. 
 

Just to confirm, have you tried restarting the network connection? This basic step is very simple, but often overlooked. This way you can check if the issue is connection-related. 

 

It's also a good idea to try how the Spotify app behaves under a different Internet connection, if you have this possibility. 

 

Hope this helps. Keep us posted. 

IvanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music is the wine that fills the cup of silence.” - Robert Fripp

mchiang624
Casual Listener
Hi Ivan,

Thank you for the suggestion. I did try it, but eventually the page started
working after 2 days.

Loreniw
Casual Listener

@ivan - thanks for the instructions about posting a link! Though it was so obvious once you described that it made me cringe, it I'm glad I asked, cause I had no clue!

 

I see the link was already posted, so I won't bother.

 

For reasons unknown, I have no problems now. It stopped working by itself. 24 hours later it's working. I did nothing. Puzzling. Wish all life's issues got fixed that way.

Kasprowy
Casual Listener
I have the same issue since yesterday. I can use the app by starting the playlist directly. But going to Home page crashes the app.

mchiang624
Casual Listener
Hello! It took about 2 days, but it finally now works. I think maybe the
update was just more than the phone was prepared for.
Thanks everyone for the suggestions!

Ivan
Moderator
Moderator

Hey there @Kasprowy

 

Welcome to the Spotify Community and thanks for posting here.
 

Just to confirm, have you tried some of the troubleshooting steps provided in the thread so far? How did it go for you?

 

Let us also know what device and Spotify-version you're using when experiencing this behavior. This way we can take a closer look. 

 

We'll look out for your reply.

IvanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music is the wine that fills the cup of silence.” - Robert Fripp

Kasprowy
Casual Listener
I'm using Spotify for Android, v 8.5.44.941
I updated the app 6 days ago and it worked great. Then it just happened. I was using the app as always, I was looking at my home screen and then it crashed. Didn't recover since.

I tried reinstalling it. I tried different wi-fi networks as well as mobile data.

Loreniw
Casual Listener

Hi, @kasprowy and @ivan

Several of us reported this on a post about 7 hours before @ivan responded.  I don't know how to link that post, forgive me. It's titled "App crashes at startup." Anybody want to teach me how to insert a link?

 

Anywho, that post has many suggestions. Unfortunately, all have failed so far.

Kasprowy
Casual Listener

Ivan
Moderator
Moderator

Hey there @Loreniw

 

Thanks for reaching out - help’s here!

 

As we managed to find several threads with a similar title, we suggest you post the exact link to the thread yourself. Here's how you do that:

  1. Open the thread in your browser.
  2. Double-click on the link in the address bar. The link will become blue. 
  3. Press Ctrl + X on your keyboard for Windows OS, or Command + X for iOS. The link disappears from the address bar. 
  4. Start writing your response to us here on the Community. When you want to insert the thread link, just press Ctrl + V (Windows) or Command + V (iOS). The link will be pasted in the field where you're writing. 

Once you have posted the link to the thread, we'll take a closer look at the issue.

 

Stay tuned! 

IvanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
“Music is the wine that fills the cup of silence.” - Robert Fripp

ReggaeDad
Newbie

I'm having the same issue. But I'm on a Note 5

Slcrowe
Music Fan

I was told to roll back prior to the March 1 update.  8.4.42.722. I haven't yet so I don't know if it will work, but will try later when I'm not working.

Slcrowe
Music Fan

So just to follow-up on this issue.... this problem just corrected itself about 48 hrs later and my homepage was back and working as normal.  So I can't really say what the solution is.

SUGGESTED POSTS