Announcements

Help Wizard

Step 1

NEXT STEP

Option to disable autoplay on bluetooth connect

Option to disable autoplay on bluetooth connect

Spotify automatically opens and starts playing music whenever I connect my phone to a bluetooth device. I really need an option to disable this!

 

This occurs on all devices I've tested and has been an issue for a while.

Reply
Top Answer
Mihail
Spotify Legend

Hey everyone,

 

Thanks for reaching out and reporting this behavior to us.

We'll make sure to take it into account while moving forward, however we can't set an exact timeframe for when this will be fixed. The reason is that the autolaunch &autostart  functions are dependent on the way a device is configurated to interact with the app API. We recommend that you reach out to the manufacturer to report the issue with them as well.

 

That being said, some users report that they managed to fix this by altering certain settings on their device. We've compiled a list of possible solutions for you to try bellow:

 

Hope this helps!

58 Replies

I tried the suggestion for a month. I did keep Spotify from opening on my Note 9, however, it stopped Spotify each time my screen timed out. It resumed playing as soon as I opened my device. I set the screen to always on while charging (dev setting) and that works but not a good solution. I un-subscribed from paid Spotify, put my settings back to my normal and it didn't open automatically going forward. Trying many things to achieve what I believe the developers at Spotify could fix in ten minutes. Frustrating 

I saw your suggested solution and I definitely tried it. But even while sitting in my car with Bluetooth turned on and the Spotify app open, that setting doesn't appear. There is also no setting in my car's stereo system to prevent this and certainly not one on any of the other bluetooth devices I've used. Many of us in this thread have different phones with settings that cannot seem to prevent Spotify from being the ONLY app to behave this way, which is why I believe the underlying issue is with the app itself. 

I just looked for the battery choice in settings on my tablet which I also use Spotify on (though not in my car or connected to my BT speakers automatically) and the tablet system doesn't have the ability to limit usage the way my Note 9 does. This is a Spotify issue and as I've said before, frustratingly simple fix. I am in the process of buying out my phone lease and anxiously waiting to unlock the phone so I can look into changing the app if possible.

That suggestion doesn’t work! Turning on or off “autoplay”  in Spotify does nothing 

Worked for me also. Note 10+

Phone settings>apps>spotify>battery>turn "allow background activity" off

Unpair from car bluetooth and uninstall spotify. Then pair car bluetooth and reinstall spotify. It will ask if you want to auto launch or something like that. Decline the auto thing. It worked for me 2016 Hyundai sonata.

Hey everyone,

 

Thanks for reaching out and reporting this behavior to us.

We'll make sure to take it into account while moving forward, however we can't set an exact timeframe for when this will be fixed. The reason is that the autolaunch &autostart  functions are dependent on the way a device is configurated to interact with the app API. We recommend that you reach out to the manufacturer to report the issue with them as well.

 

That being said, some users report that they managed to fix this by altering certain settings on their device. We've compiled a list of possible solutions for you to try bellow:

 

Hope this helps!

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Create a disable auto launch feature in settings. I should be able to get in my car and have my blue tooth connect to my car without Spotify turning on automatically every time.  (If I want to hear something on Spotify I want to make that decision myself.) This has been increasingly irritating as I like the quiet in the morning sometimes or I want to listen to something else on my drive, such as a book, or message from another source other than Spotify. Even when I do get set to listen to something else Spotify overrides what I am listening to, and I have to shut down Spotify and reactivate the other app. Obviously this is annoying and not safe to do while driving and this happens every time I get in my car. 

Hi Ivan, 

I've tried the steps you've suggested, but the issue has persisted. I've got a Samsung s23. 

Hello dear community. There's been a lot of frustration on my behalf (and many others as expressed here in the  Option to disable autoplay on bluetooth connect thread ) regarding Spotify playing music automatically as soon as I connect my bluetooth headphones.

 

I tried every solution mentioned and none worked... and just now, I finally cracked a solution that is working for me:

 

I searched "Music" in the Samsung Android Settings and saw that I had a "Driving" routine set up for when the bluetooth earbuds get connected.

The routine included "Spotify" as the "Music" action.

 

I deleted the routine, and the problem is gone!
Spotify no longer auto-plays when I connect my bluetooth earbuds!

How do I disable Handsfreelink Bluetooth from automatically starting?

Any other Honda drivers out there frustrated that music automatically plays upon Bluetooth connection? 

This happens in a 2013 Honda Civic and in 2019 Honda Clarity

 

Plan

Free/Premium

Country

USA

Device

Samsung Galaxy s21 and Samsung Galaxy note 8

 

Android Oreo

 

 

Plan

Free

Country

Australia

Device

Samsung Galaxy S22

Operating System

Android version 13

 

My Question or Issue

No matter what I do, Spotify always starts playing via Bluetooth when I switch my car on. This is a safety hazard. I just want it to stop.

 

Some notes:

- To be clear, this is not about autoplay within the app. This is about the app starting when my car starts

- This happens even if I have closed the app before switching my car on

- I have searched this topic throughly and disabled all the necessary settings in Android Auto. Please do not give me suggestions about this

- This is not an issue with my car. I upgraded my phone a few days ago and never had this issue with my previous phone

 

I have uninstalled the app purely due to this and am not going to reinstall it unless I find a resolution.

Hi Jazz, I'm Mark from Liverpool UK. I had the same problem..I guess everyone does. I went into settings and found 'Spotify connect in background' .. I set to OFF. This stops Spotify from automatically using your battery in the background which it needs to auto start. It did the trick for me. It will complain because it wants to have full control. However I have noticed a side effect in that sometimes Spotify will appear to cut out, only to spring back into life... so I think the buffering gets affected. It doesn't happen often. So you could switch this setting to off before you get in the car, and switch it to on when you're in the house. Anyway Spotify doesn't make this easy, and they should because I agree it's dangerous to autoplay in the car. Hope this helps.

Thanks so much!!! I have currently uninstalled the app out of frustration because of this issue. When I redownload the app in a few days, I'll try this out.

Pleasure Jazz... I hope someone at Spotify does something about this is... its not an individual 1 to 1 support issue to he taken off line ... its bad generic design that is creating danger for drivers. 

Hey Mark, no luck unfortunately! I tried your suggestion this morning and
the moment I got in my car, my audio came on from Spotify. I am so
disappointed with the Spotify developers and I am now uninstalling the app
for good. Thanks for your help, though!

Hi Jazz, I'm Luciano from Argentina. I have the same problem, I connect to my car through bluetooth and the app starts by itself even though it is turned off. It is very annoying because many times I need to use the phone's audio but not spotify, for example, listen to a voice message or other radio apps; which makes it very annoying and dangerous. Unfortunately I cannot uninstall the app because it would leave my family without service.

When opening the app, playback starts automatically and the Now Playing pane is shown. This is not desired behavior.

This should be fixed so that after opening the app, playback does not begin until explicitly requested.

Maybe some people like this behavior and a toggle switch to enable it should be added. As it is now, it's incredibly frustrating.

Suggested posts