Announcements

Playback stops after 9 seconds

Playback stops after 9 seconds

Plan

Premium

Country

Egypt

Device

Huawei P30 Lite

Operating System

Android 9

 

My Question or Issue

Playback frequently stops after 9 seconds. Internet speed is always good. I perform internet speed tests when happens and I always get good speed avove 10 Mbps, plus browsing and streaming from other apps works perfectly. Force stopping the Spotify app and trying to play the song again fixes the problem for the current song, but it happens again after a couple of songs if not the song right after. Clearing the cache, logging out then in, clearing application data abd cache and uninstalling then reinstalling the app didn't fix the problem.

Reply
57 Replies

Hi there!

I know it sounds simple, but it's often overlooked. Could you try restarting your device? If that doesn't help, try a clean reinstall of the app. Just follow these steps.

 

If the issue persists try using Sign Out Everywhere and Remove Offline devices options from your Spotify account.

 

Hope it helps 🙂

LoxerSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Hello Loxer

I've tried all these before. Didn't help.

I keep having this problem too.  Playing on Samsung S8 in Texas (United States).

Hey @iahvector,

Thanks for reaching out.

Please follow these steps in the exact order as given here:

1. Click on Remove All Devices here.
2. Do a clean reinstall. Note: After reinstalling, you will have to download your music for offline listening again.
3. Restart device. 
4. Log out and log in again.


Let us know how that worked out 🙂

PetyaModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

In my case it stops at around 5-6 sec into the song. It doesn't appear to be the internet as it happens both when in wifi or data.

-happens with not saved songs/not liked

-updated to current version

-reinstalled the app

-checked powersaving mode settings 

all to no avail

I am having the exact same problem! Every song stops at the 9th second.. unless I donwload it first. This is annoying as **bleep**. Try and go jogging with an app like this. I never had this problem before. Could it have been a new update?

 

How 'bout the guys who posted above.. is your problem now gone?

Ok. I did everything the moderator suggested we'd do and I ran a quick test. It seems to have worked. I've tried 3 different songs and all of them kept playing after 9 seconds. Thanks mate!

This may be unnecessarily overkill and would result in GBs of downloaded offline content needing to be reloaded.

I resolved by clearing the cache, note not data, just cache, force stop of application then restart. 

Definitely worth a try rather than reinstall.

Thanks! It worked immediately after I did these steps.

Hi @Petya, I've tried what you suggested plus disabling battery saver/optimization and it still does not work. I pay for a premium account and use it in my classes, so this is definitely not an acceptable issue. Do you know of a better solution?

Hey @angiez86,

 

Thanks for getting in touch with us 🙂

 

The troubleshooting steps you've tried so far are very good. Can you also give it a go and try with another account? That way we can see if it's an account-related issue. 

 

@ghob_05 If you still experience this issue, we'd suggest you try with another device. Does the issue persist?

 

Keep us in the loop! If you have questions, you know where to find us.



 

 

 

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

I am still having this problem in 2020, very consistently.

Hey hey @nickystee!

 

Thanks for getting in touch with us on the Community about this.

 

Could you let us know if you have already tried any of the troubleshooting steps mentioned above.

 

If you have, we'll need to know what you've tried, so that we won't be repeating steps.

 

It'll also help our troubleshooting if you let us know your device's model and OS version.

 

Keep us posted!

ElenaModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Hey,

I recently had a similar issue where whenever I'd start my playlist, it would show a song, then after one second, skip to the next until an ad comes. Once the ad is over, it would play a song, then stop it at 9 seconds, and I couldn't play it anymore. I've tried doing the steps two times, and it has done the same thing multiple times.

Hey there @decruvio,   

 

Thanks for posting here and confirming the troubleshooting steps you've tried.   

 

Do you mind letting us know which version of the Spotify app is currently installed on your device? Also, make sure you check if this occurs across multiple devices or only on a single one.

 

Another thing worth trying is if you still experience this when using a different Internet connection. If it works with another connection, it's best to contact the service provider of the original network for more information.    

 

Keep us posted! We'll look out for your reply. 

Thanks for responding, @Ivan

I tried using a different network, but the same thing happens. However, when I use another device, it runs smoothly.

 

I'm not too sure how to check what version I have installed, could you help me with how to figure that out?

 

Thanks!

It seems to have fixed itself now. Thanks for the help! (:

Hey there @decruvio

 

Thanks for keeping us in the loop. 

 

We're happy to hear this is fixed for you now.

 

Enjoy your music!  

Sorry, just saw that you replied! All I've tried thus far is deleting and reinstalling the app, and deleting the cookies. The issue is occurring on an Acer Chromebook laptop..

Suggested posts