Saved Playlists - Stuttering playback, App is Laggy, Samsung S3.

Solved!

Saved Playlists - Stuttering playback, App is Laggy, Samsung S3.

danchorley

Hello,

 

I've been having issues with offline playback from my Samsung Galaxy S3 for a long while now, but as I am driving while the playback (or lack of!) occurs from my device, I have been yet to report it. I have been unable to find any specific solution for this problem while searching, so I do apologise in advance if this has already been solved/answered elsewhere.

 

The Problems:

 

  1. Playback stutters at random points during a song - it's not song specific or time specific. These are all offline playlists.
  2. The app is exceptionally laggy, and on occasion will ignore my request to skip a song or start a specific song. It can take up to 3-4 minutes to react.

The Environment:

 

  1. Spotify is often the only app running when this occurs, thus there is plenty of RAM available.
  2. I have plenty of free space both on the SD card and Internal Memory.
  3. I am operating with the latest stable version of Spotify for Android.

What I have noticed:

 

  1. The stuttering seems to occur most when the screen is turned off (has timed out for inactivity)
  2. Often the stuttering will occur regardless of whether the screen is on or off.

 

I was wondering if there were any solutions, or whether anyone else has had similar issues and what they did to resolve them.

Additionally, it's worth noting that I have already tried to clear all of the application data, and do a full uninstall and reinstall of the app. This didn't fix the problem.

 

Thanks in advance.

Reply

Accepted Solutions
Marked as solution

danchorley

For me the problems have largely now disappeared.

I cannot 100% pinpoint what the solution was, but the following seemed to fix the problem:

 

  1. Download the playlists and then activate "Offline Mode" - it seemed that spotify was trying desparately to update song information via 2G/3G, and playback was suffering due to this.
  2. Ensure that there is enough system memory available - I didn't realise how much memory was being taken up by downloaded music until I checked this, and I noticed other apps were being slowed down due to lack of memory.

Hope this helps anyone else who is experiencing similar problems.

View solution in original post

21 Replies

danchorley

Any thoughts?

Joe

Hi. Could you just confirm the following fo me, thanks.

 

  • Android version
  • Spotify version (from the settings screen at the bottom).
  • Do you have collection and, if so, are you on tthe beta test programme?

Manar

I'm having the exact same problem. on my HTC desire.  It's alright when the screen is unlocked and awake, but the moment the screen locks it stutters.  I've gone through the troubleshooting steps with reinstalling several times, and got all the latest updates, but this issue has been going on for several months and is quite frankly unacceptable.  

When is this going to be fixed?

danchorley

Android Version: 4.1.2

Spotify Version: 0.7.4.608.g206da179

 

No I don't have collection - hadn't even heard about it until I just googled it.

No I'm not on the Beta testing programme.

 

The app in general is just awful on my Samsung S3. Generally laggy, unresponsive,.... awful. Especially when I am paying for premium...

Peter__

Do you guys have a large number of playlists? 

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

danchorley

I have two playlists saved for offline playback:

  • Starred - 287 tracks
  • Classics - 412 tracks

I have 66 playlists which are not saved.

 

I don't consider these numbers to be particularly large though. Are they?

Peter__
Nope shouldn't be!

Peter
Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014


If this post was helpful, please add kudos below!

danchorley

Haha great. Any ideas on a solution/fix? It's really getting annoying and there are no solutions anywhere!

Joe

Hey. Do you have "Auto haptic" turned on in your phone settings by any chance? If so, try turning it off to see if that helps. How are you listening in your car by the way - I assume not through earphones?

Manar

No, and to check if that were the problem i tried undownloading everything and only downloading one short playlist.  it still stuttered.

Joe

Are you listening over bluetooth? Does this still happen if you use wired earphones?

danchorley

I hate auto haptic, I have had it turned off since I had the phone.

I listen to spotify through attaching a 3.5mm cable into the headphone jack, and attaching the other end into my car's stereo system. The idea then is to put a playlist on shuffle, and let it do its thing. Instead, it stutters, is unresponsive in changing songs, and generally awful.

 

I was sitting in a McD's car park about 20 minutes ago with some mates and it did it when we were listening to music then.

So frustrating!

danchorley

Are there any alternative means of non-community based support that spotify provides?

I have been searching for a fix for this for at least two or three weeks now and have found nothing, and this problem doesn't seem to be one I alone am faced with.

Joe

Sure, you can get in touch direct with spotify support using the online contact form. If you get an automated response directing you back to the community or to the help pages, make sure to reply to it directly to speed things along.

danchorley

Cheers, will get on it tomorrow.

 

Anyone found any solutions/have any ideas for debugging the problem?

Sebster

Ignore me. It seems to be an Android issue. 

Manar
Yes im pretty sure the problem was with my phone (lack of memory) as i noticed it started to lag qith other apps too. I got a new phone and the playback has been seamless. Spotify wasnt the problem.

Joe

Could you post the information requested in the template in this post.

Sebster

I'm using cyanogenmode and it seems that changing the CPU governor has solved the problem. Brief instructions:

 

Enable developer options:

http://wiki.cyanogenmod.org/w/Doc:_developer_options

 

Then:

The go to Settings -> performance -> processor

 

Change the CPU governor to "ondemand"

 

I eventually got the information from the CM forums. I have closed the tab so no link.

Suggested posts