Announcements

Shuffle turns on by itself

Solved!

Shuffle turns on by itself

moseph88

Plan

Premium

Country

United States of America

Device

(Moto Z4)

Operating System

(Android 10)

 

My Question or Issue

Every time I start up my Spotify app and select a song to play, shuffle automatically turns on. This is especially annoying when I am trying to listen to an album all the way through or listen to a playlist I have created. I do not like having to fumble with my phone while I am driving as it is dangerous. Any help with this issue will be greatly appreciated.

Reply

Accepted Solutions
Marked as solution

FoxException

I wonder if it may be related to alarm clock using Spotify (I mean, I configured my alarm to play song from Spotify). I turned all those off now, switching to standard Android alarm tunes, I'll see.

View solution in original post

Marked as solution

Sppechnester
After I turned off the alarm/deleted them, it stopped doing the shuffle thing for me.

View solution in original post

24 Replies

Ivan

Hey there @moseph88

 

Help’s here!

 

If you're having trouble turning off the Shuffle play mode on Spotify you might need to perform a clean reinstall of the app on the device where you experience the issue. This ensures you a fresh start with Spotify by getting the latest app version with all necessary updates.  

 

If this persists, check if any power saving or data cleaning settings run active on your device. Make sure you disable these since such features can often prevent the app from operating at full capacity.

 

Keep us posted! We'll be happy to lend a hand if you need more help.   

frigaut

Hi there,

I have a similar problem and it is a bit aggravating. It happens both on my phone (android) and my desktop (linux) version. I can turn shuffle on and off with no issue. The problem is that it appears to come back at random (without me selecting it - I  hate shuffle, I think an album should be listened at in the order initially designed by the artist).

I have actually just re-installed on both my phone and my desktop, as suggested. Will let you know if that solves the issue.

Cheers,

Francois

moseph88

Unfortunately this did not solve the problem. I do see that this is an ongoing issue among other users. Are there any other possible solutions? Thank you for your response!

frigaut
Yes, same here, it did not solve the problem.

Ivan

Hey @moseph88 and @frigaut

 

Thanks for keeping us in the loop. 

 

In case you experience the issue across different devices it's a good idea to check if you observe the same when using a different network. If it works with another connection, it's best to contact the service provider of the original network for more information.

 

Another thing worth trying is how this goes when logging in to a different Spotify account on the affected device. If it works with another account, follow the steps in this Spotify Answer on how to start a new account without losing your saved music.  

 

Let us know how you get on! We'll be here in case you need any further help with this.

Marked as solution

FoxException

I wonder if it may be related to alarm clock using Spotify (I mean, I configured my alarm to play song from Spotify). I turned all those off now, switching to standard Android alarm tunes, I'll see.

Alex

Hey @FoxException,

 

Keep us posted once you finish troubleshooting.

 

Whatever helped you might help other users affected by this issue too.

 

Cheers.

AlexModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!
Marked as solution

Sppechnester
After I turned off the alarm/deleted them, it stopped doing the shuffle thing for me.

FoxException

Your reply reminded me to share the results as well 🙂

 

It worked for me too. I stopped using Spotify song as the alarm sound and the shuffle did not turn on even once. Some time later I set a song as alarm sound back again and yup, shuffle magically turned on again, so I permanently stopped using Spotify for alarm and I am no longer bothered by the issue.

Novy

Hey folks, 

 

Thanks for your replies, and welcome 🙂

 

We're glad to hear that this worked for you too. 

 

If anything else comes up, the Community will always be here.

 

Take care!

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

moseph88
You genius! That's what it was! Thank you so much!

salicide

Is there any chance that Spotify would confirm that this is related to alarm clock, and if so to fix it?

 

As a paying user, I like using the alarm clock and also not having shuffle turned on behind my back.

 

This type of issue (one feature affecting the state of another) is bad UX.

kvn27

Hello, 

i am having still the same shuffle issue even after trying all the possible solutions e.g. clean reinstall, no alarm is linked to spotify, new account created. still shuffle mode is on. i can't turn it off. on desktop app is working good.

AndresM

Hi @kvn27,

 

Thanks for posting on the Community and welcome.

 

Would you mind sending us a screen recording of the behavior you're describing (Shuffle turning back on)? You can attach it to your next response by using the Insert Video option in the post editor or upload it to a different platform and send us the link to it.

 

Changing tunes, keep in mind that similar songs will be automatically played if you have the option "Autoplay" on. You can check more info here

 

We'll be on the lookout for your reply.

AndresMModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Music touches us emotionally, where words alone can't." -Henry Thoreau

NickOhoiko

Hi, here is screen recording on how to reproduce this. Note that shuffle is off before alarm is turned on. After alarm is triggered shuffle switched to on.

salicide

Thank you so much for taking the effort to do the recording!  This is the exact issue I have. 

 

Hoping for a solution from Spotify,  Salicide

Vasil

Hey @salicide & @NickOhoiko,

 

If the song selected for the Alarm has had Shuffle enabled, this will automatically carry over to your app after the Alarm rings.
Try disabling Shuffle when selecting the Alarm song 🙂
Thanks!

VasilModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

NickOhoiko

Hi @Vasil, thanks for reply!

But if I select a playlist for alarm, it will play a random song from that playlist when alarm happens.
And after that, shuffle is enabled at a global level in Spotify, and I have to turn it off every time after alarm.
Is this intended behavior?

Also, I don't really know how to disable shuffle in alarm view here

photo_2022-07-11_11-05-36.jpg

salicide

Hi Vasil,

Thank you for your reply. Unfortunately, I don't think it helps.

> Try disabling Shuffle when selecting the Alarm song 🙂

 

  1. When configuring the alarm, you can't select songs. Only playlists or albums
  2. There is no option to enable or disable shuffle when configuring the alarm

To my understanding, the alarm integration IS DOING the following when the alarm is triggered:

  1. Turn on Shuffle (persistent setting)
  2. Play selected playlist.

The problem is that step 1 overwrites the user's preference. Every single morning. It is not good, and Spotify should not just ask users to fix up after their bugs.

What the alarm SHOULD BE doing:

  1. Retrieve the user's shuffle setting
  2. Turn on Shuffle
  3. Play selected playlist
  4. Restore Shuffle setting saved in step 1

This way, the alarm feature would be a "good citizen" and not overwrite the user's explicit intended setting.

Regards,

Salicide

Suggested posts

Env: prod