Announcements

Sleep timer not working with podcasts

Sleep timer not working with podcasts

I use some podcasts to help me get to sleep, but I've noticed that the sleep timer doesn't work with them, episodes keep playing even though I set the timer to stop playing after the episode or an hour. 

Is this a known issue? 

 

Plan

Premium

Country

UK 

Device

Google Pixel 4a 

Operating System

Android 11

 

 

Reply
47 Replies

Hey @deeeeekun,

 

Thanks for posting.

 

Keep in mind that we're always testing new thing out in order to provide you with the best listening experience. So it's possible that you might see something on the app your friend doesn’t, or get a brand-new feature for only a temporary period. Click here to learn more about Spotify tests.

 

If you post an idea we can track the popularity of the feature request more easily and there will be a central space for other users engage in the discussion.

 

We appreciate your understanding. Keep us posted if anything else comes up!

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

This is also happening to me. Sleep timer and speed adjustments don't work when using a podcast and Spotify connect (music is fine).

I would recommend implementing clearly disirable features that all your competitors have without users having to suggest them as features, but hey, that's just me. Amazed a feature this simple doesn't work.

Simply download the podcast episode and play/cast it from the library. Spotify stops after the playlist is exhausted. 

Used to be able to do this now I cant, very frustrating. One of the the main uses I had for the nest mini I'm the bedroom way playing a podcast as I'd wind down for sleep

Yes there's always a workaround, but if an app has a feature it should work! No point having a sleep timer option of it's useless.

I'm finding that the sleep timer is even becoming unreliable with music now when casting to a Nest Mini, and I pay for premium! 😠😠

Hi there folks,

 

Thank you for your replies and feedback.

 

We understand that things can feel frustrating when things don't work as you'd like them to. Rest assured that we're always trying to improve as we always strive to improve our features.

 

We hope for your understanding and that you continue using Spotify and find it gets better in the future.

 

Once again - thanks for the feedback, we appreciate it. Let us know if we can help you with anything else. 

 

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

I have the same issue. Playing podcasts on the phone with Bluetooth headphones. Sleep timer is completely ignored and the podcasts keep playing when I set it to End of episode

It's 2022 and this problem is still occuring. I'm being woken up at night after falling asleep because my podcasts keep playing past the sleep timer.

I have the same issue with the Android app and Sonos speakers. As soon as I connect to the speakers, the moon icon is greyed out. My girlfriend with an iPhone doesn't have this issue. It's extremely annoying...

Nearly 18 months later still no fix, I gave up on Spotify for podcasts months ago and is use Google Podcasts which works perfectly, would suggest anyone else stumbling across this thread does the same. 

I'm having the same issue using Bluetooth headphones. I've done a clean install because I was also trying to fix the bug where the pause button disappeared. Neither issue was fixed.

Oh look Spotify clearly couldn’t be bothered to listen to feedback from almost 2 years ago and multiple accounts are still experiencing the problem. This is how companies go bankrupt! 

Well, it works on iOS and it already worked on Android. 

For me the moon is greyed out, nothing happen when you press it. There's no sleep timer option at all in the meatball menu. I'm streaming via Bluetooth to a speaker. This has worked until very recently. What happened? Why did Spotify remove this functionality? It has clearly been a problem for many since 2020...

Please fix this issue! I'm begging you. It's driving me crazy. I have premium, done clean reinstall, nothing helps.

Hey @Kritkatten,

 

Thanks for your reply in this thread.


We understand what you're mentioning; let's work on this together. Do you notice if this is just happening when you're listening to podcasts via Bluetooth to a speaker, or does it happen whether your device is connected to a speaker or not?

 

On another note, were you able to use the Sleep Timer with your Speaker before? If so, let us know when this started to happen and if this happened after a particular update/event. 

 

Is this happening with a particular podcast episode or does it happen with all podcasts you're trying to listen to?

 

Lastly, can you share with us the exact make/model and OS of your device and speaker along with the Spotify version you use?
 

We'll keep an eye on your response!

AlejaRModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.

Hi!

Yes, I use an audio pro A10 which has been working before to listen to
podcasts via Spotify with the sleep function. Neither the speed nor the
sleep (moon) buttons work (greyed out). I only listen to podcasts with
sleeping meditation and only when I have to go to work the next day and I
haven't done this over the summer so only noticing the issue now.

Spotify version 8.7.54.403

Listening to podcasts without the speakers work (speed and sleep function).

Thank you! Let me know if you need any further information, sorry if I
missed something, I'm in a bit of a hurry right now.

Best regards,
Frida

This remains a defect which seems pretty easy to replicate on the current versions.

 

  1. On latest Android app 
  2. Play a podcast via Spotify connect (eg casting to a speaker)
  3. Observe the sleep and speed controls are disabled.

Hi folks!

 

What you're describing is expected behavior - the Sleep timer icon will be greyed out if you're listening to another device using Spotify Connect. However, looks like an idea about changing this has already been submitted here so feel free to check it out and add your +VOTE to show your support.

 

In the meantime, you can use the following workaround:

  1. Open Spotify on your phone and without connecting to another device set your Sleep timer.
  2. Once the Sleep timer is set, you can switch playback to another device. The playback would then stop as soon as the duration of the sleep timer expires.

Hope this info was useful. Cheers!

YordanModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Suggested posts