Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Spotify continuously skips songs on linux

Spotify continuously skips songs on linux




Country: US



Generic PC

Operating System

Linux (Ubuntu 18.04 LTS)


My Question or Issue

Whenever I go to my linux workstation to fix a problem, sit down for coding or what else I may do I end up having this problem. This problem is persistent over many many installs of ubuntu 18.04 LTS and is honestly kinda frustrating. The issue makes it so I don't a chance to even hear any audio and instead just skips through my playlists or just refuses to play the songs and tells me to import... every time. So,  If any debugging information is required then tell me how to get that to you. I'm more than happy to help and get my jam on. FYI This I have encounted from spotify by installing from snap "stable" and the debian package aswell. The bugs are present on both. For demonstration see video below


58 Replies

I just suddenly got the same issue today. Literally I was listening fine to all my songs then this message kept coming up. Now it will let me listen to just a few seconds and then skip the song with the same message. After that happens I can't play the song any more.


Basically no spotify installations work any more: The regular .deb crashes on launch (Segmentation fault), and the flatpak and snap packages both face the above problem.


I tested on two differents computers, Ubuntu, Arch, WiFi, Ethernet, tethered mobile data, two different Spotify accounts. Nothing fixes it.


Please help us out Spotify...

Before today my Spotify was fine.. Now I'm having the same issue described on the post. This issue happens with snap and apt Spotify.



playbackError: playback_error_audio_decode (11)



Same issue here with Arch linux w/ KDE using Spotify from AUR.

Same issue here.


Worked fine yesterday.


Cleared both the ~/.cache/spotify and ~/.config/spotify folders, logged in again and it is still not working.


Please fix, the application is useless in its current state.


Linux pc 4.15.0-52-generic #56-Ubuntu SMP Tue Jun 4 22:49:08 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

latest linux mint

spotify-client package installed through apt


My installation is acting weird too, ubuntu 18.04 it was installed with snap, but i installed with the deb package and the problem still remais!!!

After some seconds of almost every song, it just skips and show this message:


Please fix this

Same here, since this evening all I get is first couple of seconds of songs. On same machine on win10 Spotify works, web player works (in LM), but not desktop app. Reisntalled, purged, cleaned, tried snap and apt... not working. It's a bummer.

Can reproduce.

Am very angry.


Quite frankly, as much as the service itself is worth every penny, the desktop app is a dumpster fire even when it works correctly (it's not exactly very integrated with the UX of my desktop, for starters - whatever OS I'm running at any given time).


If it starts skipping, well...

Please fix it.


Ubuntu LTS, snap package here.

Same issue, as a workaround I have a browser tab playing the song while controlling it using the desktop app. Good times.

"Workaround", you say.

This springs to mind.









Lenovo Yoga 2 Pro

Operating System

Linux 4.9.0-9-amd64 #1 SMP Debian 4.9.168-1+deb9u3 (2019-06-16) x86_64 GNU/Linux + KDE


My Question or Issue

My Spotify stoped working few days after installation. At first, I wasn't able to pleay only the new songs. When I started it, it played for about 4 seconds, than it started making strange noise and finally Spotify wrote notifification "Spotify can't play this right now..."


So I deleted all cache, config and shared files and started all over again. The situation was even worse. Now, not only the new songs doesn't work, but even downloaded songs can't be played for the same reason.


I "fixed" the problem by installing Spotifyd and using the Spotify client just as GUI, but I would be glad, if the backend started working again. Could you help me please?



I get the same playbackError: playback_error_audio_decode (11) when I run spotify with the --show-console flag either with the package from AUR or the snap package

Literally unplayable, plz fix

Same here, please fix it.

Ubuntu 18.04




Same problem here!

Dear Spotify, I know we're few, but we Linux users deserve better care from you.



Same here. Tried snap, apt and clearing cache. Nothing works.



OS: KDE neon User Edition 5.16 x86_64

Same problem here on Ubuntu 18.04. I can't play any song using the client, it works for the first 5 or 6 seconds and then the audio stops and the "Spotify can't play this right now" error is displayed.

Same problem on Linux Mint 19, kernel 4.15.  I tried rebooting, logging out and back in, deleting and re-installing the app.  Some files and albums will play all the way through with only minor hiccups and glitches (which are still annoying), but others just won't play at all. 

Is this perferable to just using the web player?  Is it lower bit rate?

I don't think this is the place to question the usefulness of the app.


Nevertheless, besides having a sort-of-usable interface (particularly having working notifications and media keys and not having your music buried under a gazillion browser tabs), the ability to download songs locally seems like a pretty huge deal to me and is a major reason why I subscribed.

Suggested posts