Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Bluetooth headset buttons


Bluetooth headset buttons

Recently I've been listening to music on spotify on my Mac through my Bluetooth headset with no problems but last week spotify stopped responding the the buttons on my headset (play/pause, forward, back) and instead they trigger itunes, even when I am listening to spotify at the time! Does anyone know how I can fix this?

Thank You

65 Replies

The answer there seems to link to the same lifehacker post...

Ok, I wasn't very clear. What I meant was to use the first step,
"You are looking for the Remote Control Daemon located in: /System/Library/CoreServices/
It can be disabled with the command "sudo chmod a-x /System/Library/CoreServices/ killall -9 rcd"

To re-enable it, "sudo chmod a+x /System/Library/CoreServices/" Then log out and back in."

If this doesn't work, I'm all out of ideas. Sorry.

☆✩✪ Want to help out? Become a Spotify Rock Star today! ✪✩☆
Jag svarar på svenska via pm eller via twitter

Binaural track - listen with headphones with good volume!

Tried that and heres what I got:


[comp-name]:~ [username]$ sudo chmod a-x /System/Library/CoreServices/ killall -9 rcd
chmod: killall: No such file or directory
chmod: -9: No such file or directory
chmod: rcd: No such file or directory

Gbenj: to bad it didn't work. Did you try the tool I linked to in my first reply in this thread? It's at the end, after the edit.
☆✩✪ Want to help out? Become a Spotify Rock Star today! ✪✩☆
Jag svarar på svenska via pm eller via twitter

Binaural track - listen with headphones with good volume!

Tried that but when running the MMfix file i get an error for "bad file"


dunno what the issue is here but seems like one dead end after another. 

Ok, lets try something different.
1: turn off your bluetooth device, i.e. the headset.
2: turn off iTunes if it is still running.
3: start up quick time
4: start up Spotify
5: turn on your bluetooth device.
6: try the buttons...

This really is my last shot in the dark... Btw are you using mountain lion? Could be why the suggestions don't knowledge is from the older os 10.7.
☆✩✪ Want to help out? Become a Spotify Rock Star today! ✪✩☆
Jag svarar på svenska via pm eller via twitter

Binaural track - listen with headphones with good volume!

Yes, I am using Mountain Lion so thats definitely possible.


I doubt that will work either but will give it a try in a little while and report back.



The reson the command didn't work is because it's actually 2 separate commands.


sudo chmod a-x /System/Library/CoreServices/


^This command prevents Mac OS from running the remote control deamon, or restarting it once you kill it


killall -9 rcd


^Kills the rcd process


Make sure you press enter after each command.


Good luck!


i have a Parrot Zik Bluetooth headphones, and a Samsung S3 Mini (also a Samasung Galaxy 2 8") and i can use track forward/backwards, Volume up/down, and i can start the music if already paused. BUT spotify will not take the pause command when playing(either by manual pause touch, or removing headset(sensor pausing)) this use to work flawless for 3 months.

tha pause workes on the local media player and youtube, but not Spotify.

ANYONE know if there is a conflict, or a setting that needs to be changed?

Solution have been posted for those who have iOS, but i have such thing as an apple in my house.



Thanks SPOTIFY for your excellent support.

SPOTIFY! How can you leave this thread unreplied for over a year?
It's not like Bluetooth was invented yesterday, surely you've thought of this feature. 
And if you haven't, or if you've thought of it and haven't come up with a solution, that's ok.
What's not ok is to go all air line company on us by giving us the absolute silent treatment. 
I'm a paying customer, show some respect.

I actually got a pair of bluetooth headphones for Christmas and all of the buttons work on both my Desktop and iOS devices.

What platform are you guys having issues on?

Spotify Community Mentor and Troubleshooter

Spotify Last.FM Twitter LinkedIn Meet Peter Rock Star Jam 2014

If this post was helpful, please add kudos below!

At least on a Mac, it's not working. Whenever the headset buttons gets pressed, it launches iTunes and/or fire the action on iTunes.

I made a small and dirty app that redirect buttons events to Spotify. There are currently no way to quit the app, and once the app is launched, events wont work with iTunes.

I only tested that on my computer for few minutes, and it's a bit hacky, so I would not be surprised if it does not work everywhere.

Also, the app is not signed, so you will need to perform a right click > Open, then click on Open when the security dialog is displayed.

Finally, the apps is not displayed on the dock.

Source is also attached for refererence. This is only a quick a dirty fix, so please forgive if you find it ugly.

Marked as solution

This works incredibly well, thank you.


To be clear, I first needed to apply this patch to prevent iTunes from launching...

iTunes Patch Source/Download

iTunes Patch Instructions


Then I ran your application...

Spotify Bluetooth Headset Listener Download

Spotify Bluetooth Headset Listener Source


Now media buttons on my bluetooth device control Spotify and do not launch iTunes. With just your app, iTunes still launches, so the patch was also necessary.


I also decided to put th app in the Applications directory and have it autolaunch at login.


It's not a perfect solution, but leads me to believe the issue might be with the bluetooth manufacturers. I have a 3rd party keyboard which had the same media key issues everyone is having with their bluetooth devices. When I called the keyboard manufacturer and told them, they had me send the keyboard back and flashed new firmware which sent a different signal code. Now it works perfeclty. I'm guessing the bluetooth devices are also sending an older code and need to be updated.

For some reason, my headphones still can't control spotify. 

Works like a charm! I'm on OSX 10.9.1 and using parrot zik headphones 🙂




I have the same problem with windows 7 and my Sennheiser MM 450 X

 ITunes doesn't start but Spotify does not react.


Would be happy for help


FYI, I only tested this with the Parrot Zik. It's possible that events id are different for each headset.

Just signed up to thank you for this little app. I was looking for a way to get this to work with my Philips 150 BT headphones and with your "app" it just works. Thanks for your work. I owe you a beer 😉



Awesome!  Works for me too.  Would you mind putting this on github or similar (or can I)?


Would be great to get it working in general for other media players too 😉



Suggested posts