Help Wizard

Step 1

NEXT STEP

Auto starting even when disabled

Auto starting even when disabled

Spotify is opening on startup. I have never had it set to auto start and auto-start is set to "No". I am using Windows 10.

I have already gone to Edit > Preferences > [Show Advanced Settings] > Startup and Window Behavior > Open Spotify automatically after you log into the computer > No.
I have checked this, turned the computer off and back on, and checked again. It is disabled but Spotify is still opening on startup.


This solution https://community.spotify.com/t5/Desktop-Windows/Auto-starting-even-when-disabled/td-p/1735287 is not valid anymore as the option

> Advanced Settings, under Startup and Windows Behavior, turn off or diable "Allow Spotify to be opened from the web"  

does no longer exist.

 

Plan

Premium

Device

Desktop/laptop

Operating System

Windows 10

 

Reply
18 Replies

Hey @Jim61 

 

That's odd! That should ensure Spotify does not open at startup.

 

Another way to disable Spotify's autostart is by going to Task Manager's startup section, finding Spotify in the list and  right-clicking on it to disable it. Click Apply/OK to save the changes and it should work. 🙂

 

Let me know how you get on!

try this folder and see if something looks worth tinkering with. C:\Program Files\WindowsApps\SpotifyAB.SpotifyMusic_1.120.510.0_x86__zpdnekdrzrea0

 

Or 

Task Manager > Details > Spotify > right click > open folder > find a file that says something like StartupSpotify 

 

idk if it will work for you guys but i tinkered with it and spotify no longer starts with booting up, doesn't run in the background, the taskbar that i can find UNLESS >I< launch the app. Doesn't seem to have hurt the functionality so far. 

I finally stopped Spotify on Windows 10 from auto-starting despite having all the settings disabled. I had to make a manual edit to this file:

 

C:\Users\mauri\AppData\Roaming\Spotify\prefs

 

Note that mauri is my Windows 10 user name - yours will differ. The file has no extension. Also, the AppData folder might be hidden so you might have to change a Windows setting to make it visible, or use an alternate file manager (I use Directory Opus).

 

I edited the file by changing true to false in this line:

 

app.autostart-configured=false

 

I then did a full shutdown and startup and Spotify did not auto-start. I also did a restart and Spotify did not auto-start.

 

I hope this helps.

 

Maurice Frank

 

 

 

I tried everything and every way suggested and Spotify still opens on Windows 10. Ugh! Any newer suggestions? Thanks

To solve this problem please try this.

 

https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-groove/how-to-stop-spotify-opening...

 

hope you happy with this method.

I'll start by saying I tried the Ctrl + Shift + Esc Startup method and didn't see Spotify in my list but did find a solution for me.  I don't know what your other settings are in Spotify but if the "Close button should minimize the Spotify window to the tray" setting is toggled on and the application isn't closed from the tray before shutting down, it will still open on startup.  When I close the app from the tray it no longer launches on reboot.  Hopefully this helps someone.

I'm having the same problem. I've deleted webhelper files, spotify start up files, obviously I've disabled it in the spotify preferences, and I've used the task manager to disable auto start up, but the f*cker keeps opening on start up and it's really f*cking annoying

This doesn't work for me

I've found a solution that works.

Before you do, here's the disclaimer: The Windows Registry Editor is a very powerful tool, and if used inappropriately, can cause significant damage to your operating system. It is not a bad idea to back up your system (or at least create a restore point) before editing the registry. You follow these steps at your own risk.

1. Click Start, and type 'regedit' in the search box, and press enter.
2. In the registry editor, expand the branch labeled HKEY_CLASSES_ROOT and scroll down (a long way) until you see "spotify" (Note: there may be several others, such as spotify.m4a, but we want the one that just says spotify).
3. Right click on the key on the left labeled spotify (Registry keys look like folders, but they are called keys), and left click on export. You can place the file whereever you will be able to find it later if you need it. Call it something like spotify-backup.reg.
4. After you have saved that key in the previous step, right click on the spotify key again, but this time select "Delete." On the confirmation dialog, click yes.
5. At this point, we are done with the registry editor, so you can close it.
6. Open the notepad application. Avoid using any other text editor you may have, as they may not save the file we are going to create properly. Notepad can be launched the same way regedit was launched in step 1, replacing 'regedit' with 'notepad'.
7. In the empty document, paste the below text 8. Locate the Spotify.exe file on your hard drive. The default location is C:\Users\<USERNAME>\AppData\Roaming\Spotify\Spotify.exe. If this is where it is installed on your computer, simply replace <USERNAME> with your actual username in the notepad document you have open. There are two instances of <USERNAME> to replace. If Spotify is installed someplace else, you will have to edit the path manually - remembering to use double backslashes.
9. Once you have finished editing the text, save the file to your desktop, and call it "Spotify.reg". Be sure, in the "Save As" dialog box, that you switch the drop down labeled "Save as type:" to display "All Files (*.*)" instead of the .txt that is in there by default. If you do not do this, you'll end up with a file called Spotify.reg.txt which will not work.
10. Once you have saved the file, close notepad.
11. Find the Spotify.reg file on your desktop, and double click on it. When you do this, you will get a warning message that will ask you if you want to add the information to the registry. Click Yes.

After you've followed these steps, it would probably be best to reboot the computer. After the computer comes back up, try going to a Spotify link again, and hopefully it will work.

Step 7 says "In the empty document, paste the below text", but I can't see the text to be copied... what do I need to paste into the text document?

Didn't work for me.

I found something on Reddit that seems to apply for me, might help others...

When you shut down your PC with Spotify running in the background, it'll automatically start again when your PC is booted up
.

To prevent this on Windows 10:
Go to Settings > Accounts > Sign-In Options > Scroll down to "Privacy" and disable "Use my sign-in info to automatically finish setting up my device and reopen my apps after an update or restart." setting at the bottom.

Link to Reddit comment

Restarted my laptop after turning that off in privacy in settings and it seems to have worked for me. I'm relieved that I probably won't have to try any of the technical fixes with Spotify's files or the registry editor. Thanks!

If you're referring to the UWP app, I've been able to solve this by editing the "prefs" file located in "%LOCALAPPDATA%\Packages\SpotifyAB.SpotifyMusic_*\LocalState\Spotify". Look for a line containing "app.autostart-configured=true" and change it to "app.autostart-configured=false".

 

Note: In the path mentioned, there should be a string of characters in place of *, so just copying and pasting the path into explorer won't work. Go to %LOCALAPPDATA%\Packages and manually navigate to the folder.

Hey Spotify, why do we even have to do this? 

Try reinstall the app. I also had this problem before and visited this site for solution. But the solutions is either not working or too complicated. and then I just simply reinstall to see if it worked or not. after I reinstalled, I disabled the setting and restart my computer 3 times to check. and after this the problems is solved so I hoped this help others!

Idk how many people are still not able to shut down the auto start for spotify, but I found this:

go to settings

click apps

click apps and features 

search up spotify

click the three dots at the right of the app info

click advanced options

look for “Runs at log-in”

mine was turned on and it autostarted so I turned it off and now it does not open at startup anymore.

How is it even legal to have this as a problem for 3+ years?

Suggested posts