Can't play music on desktop

Reply

Can't play music on desktop

kenchu
Music Fan

Plan

Premium

Country

Sweden

Device

PC

Operating System

Windows 10

 

My Question or Issue

The desktop app doesn't work anymore for me. Whenever I try to play a song, it just says "Spotify can't play this right now".

 

It works fine to use the webplayer, and they even connect so I can control webplayer through desktop app, but the actual desktop app itself can't play any songs!

I've tried logging in and logging out, restarting PC, reinstalling app, but the problem persists.

18 Replies

Sciapodous
Visitor
Having the exact same issue here. Same plan, device type, operating system - but located in the UK. Have tried all the same steps, webplayer works fine but the desktop windows 10 app does not.

denon76
Newbie

Same issue here in Norway

zind
Visitor

Same issue, USA.

 

Tried clean reinstall, checked hosts file, cleared local files.  Works on web player and android app, both on 4g and on the same network as my desktop.

wolstanus
Casual Listener

Same problem in Poland.

Android app works perfectly fine, web player too, but the desktop application keeps skipping tracks and informs me that they can' t be played.

I tried logging out/in, reinstalling the app and nothing helps.

 

It also seems that Spotify team don't give a damn about the problem, so maybe it's time for me to subscribe Tidal instead...

Amenthea
Regular

I'm having this exact issue from today.  I've been running it on this device almost every day for months now with no issues (W10 64bit)  Premium account.

 

Works on my phone.

Tried rebooting.

Tried uninstalling/reinstalling.

Turned off hardware acceleration

Adjusted quality.

Deleted local cache.

Tried selecting different playback devices, and switching between then also

Every other form of media plays fine on this PC.

It's all tracks and radio, which if I try to choose that will skip through each track in the radio playlist in quick succession.

 

Version No. 1.1.35.458.g891674f3

 

Amenthea
Regular

Update to this:  I just created and logged in with a new account (standard non premium) and surprise surprise, it works perfectly fine with a free account.

 

Logged out, back in as my main and it has the exact same problem again, so it does appear to be account related, with a local issue tied in (as it works on my phone OK).

wolstanus
Casual Listener

It seems there's a partial solution. Try opening Spotify app as administrator - it works for me and for other people (I found the solution in this thread: https://community.spotify.com/t5/Desktop-Windows/Spotify-App-won-t-play-unless-I-start-it-with-admin...).

Amenthea
Regular

Thanks, I made my own thread after seeing this one and found that out myself a few hours ago during my own testing.  Interestingly enough, I made a new free account at the time and logged in with that and it was fine.  Logged out, in with premium, issue returns, back out and log in with free account, its fine again. 

 

 

There looks to be some kind of local and account related issue, possibly with file permissions or run level.  Using admin is OK, but tbh I don't want a 3rd party app having admin rights to my PC whilst it's running.  

wolstanus
Casual Listener
I guess there's no particular danger in running Spotify app in admin mode, but better safe than sorry... Anyway, we probably need to wait until they fix the issue (and hope they do it soon!).

Sebasty
Rock Star 18
Rock Star 18

Hey!

 

It's kind of weird that it seems to only affect Premium users or old accounts...

 

However, I also noticed many users facing the issue have soundcards with S/DPIF, such as Asus Xonar STX.

Someone else found that enabling the S/DPIF passthrough device (disabling others) and then enabling speakers/headphones, disabling the passthrough fixed sound until next time Spotify was opened.

 

Another user found that disabling DSP-Mode in the Xonar Audio worked for them.

If you have a Xonar or some other soundcard with S/DPIF, you should try the aforementioned methods out!

 

I also recommend going to this Issue thread, add your vote to this and comment your findings and information required in Status Update. 

Doing so will help the relevant Spotify team to troubleshoot this. 🙂

 

Let me know how you get on!

SebastyRock Star 18
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

wolstanus
Casual Listener

Thanks a lot!

I have Asus Xonar DG card and simply disabling the DSP GX mode in the control panel solved the problem.

Thanks again!

anjjovis
Newbie

I've been dealing with this issue on multiple devices which was getting frustrating because I don't like the web player. But opening as admin solved it for me, thanks wolstanus! 

 

FYI for others reading this thread, you can add admin privileges to shortcuts, so you don't have to manually do that every time you open it. Good luck 🙂

 

  1. Open Start.
  2. Search for the app that you want to run elevated.
  3. Right-click the top result, and select Open file location. ...
  4. Right-click the app shortcut and select Properties.
  5. Click on the Shortcut tab.
  6. Click the Advanced button.
  7. Check the Run as administrator option.

Source: https://www.windowscentral.com/how-set-apps-always-run-administrator-windows-10

 

@Sebasty I also have ASUS Xonar (DSX)! But I think in this case the admin fix is easier. I still voted for your solution in hopes that Spotify will fix the issue. Thanks!

AomoriWp
Regular

same issue here for the past 4/5 months or so being paying this thing to not use it at all cause i cant, it is laggy as **bleep** enabling shuffle takes forever sometimes it is at max volume and when i turned it down it takes like solid 30-45 seconds to actually change the volume, skipping songs its the same takes arund 30-45 seconds sometimes it doesnt even open the song and a message appears saying " can't play this song " and is not the song cause it works fine in my phone, browswer version works fine, but is really bad since can't sort my music the way i want to by artist and stuff like that, some times i would even close the software and i would keep listening to a song for 30 seconds straight before it actually stops playing same happend by pausing or resuming, 

 

got an i7 7700k and a 1070 ti 16 gb ram trust me is not the computer 

 

 

and i already tried all of the troubleshooting clean reinstall, delete cache clean disk everything, and i just cant get in touch with tech support regarding this issue cause is f*ing impossible to do that

 

Version: 1.1.60.672.g6ad9c215-a

 

 

Ver
Moderator
Moderator

Hey @AomoriWp,

 

Thanks for posting here.

 

The troubleshooting steps that you've tried so far are very good. We'd like to suggest a few more.

 

In case you're using the app from our website, it's a good idea to try downloading it from the Microsoft store to see if anything changes.

 

If the issue persists, you could try installing the app in a safe mode. Does it make a difference? 

 

Keep us in the loop! We'll be right here if you have any questions.

 

 

VerModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Difficult roads often lead to beautiful destinations." ―Zig Ziglar

AomoriWp
Regular

yeah already tried both apps from microsoft store and the official website no difference at all, also tried safe mode didn't work 

Ver
Moderator
Moderator

Hey @AomoriWp,
 

Thanks for getting back to us and providing us with these details 🙂

 

Could you share with us the following info? We'll investigate this further.

  • The type of Antivirus/Internet Security suite you're using.
  • Is Spotify installed on an SSD?
  • Do you have any data encryption in place?
  • Are you using a VPN?

Keep us posted.

VerModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Difficult roads often lead to beautiful destinations." ―Zig Ziglar

AomoriWp
Regular

im using the default windows defender antivirus, and i already white listed spotify with no luck,

 

yes it is installed on an ssd 

 

no i dont have any encryption data

 

and no i hardly ever used vpns.  

 

Ver
Moderator
Moderator

Hey @AomoriWp,

 

Thanks for keeping us in the loop 🙂

 

In this case we'd suggest you head here and contact our support team. You can also share the link to this thread with the folks so they can check which troubleshooting steps you've tried so far and that we recommend that this be escalated to our top support tier. 

 

We'll be right here if you have any questions.
 

VerModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
"Difficult roads often lead to beautiful destinations." ―Zig Ziglar
SUGGESTED POSTS