Help Wizard

Step 1


Spotify App won't play unless I start it with administrator rights

Spotify App won't play unless I start it with administrator rights







Desktop PC

Operating System

Windows 10


My Question or Issue

When I start the Spotify-App (either the one from the Windows Store or the regular one) and try to play songs I get the error "Spotify can't play this right now. If the file is on your computer you can import it" or the app continues trying to play and skips endlessly. Also downloaded songs won't play.

I noticed that it is possible to listen to local files even without administrator rights. 



Tried rebooting, reinstall, disabled virus scanning, firewall etc. Didn't work. It's also definitely not an audio-routing issue, everything else (including the Webplayer) works finely.



12 Replies

Hey @Virmiculum 


What version of Windows 10  and Spotify app are you on? 🙂
You can check the Spotify version in the app by clicking three dots - Help - About Spotify.


I suggest checking out this Issue thread and its Status Update as it seems to match what's happening on your end.


Have a nice day!

Hi there @Virmiculum,

thanks for reaching out !


I would first recommend trying to connect to your account on the desktop app on a  different device if possible to see if you're getting the same error.


In addition, please make sure Spotify has all anti-virus/firewall exceptions to work freely on your device.


Keep me posted 🙂

Thanks for your answer!


My version of Windows is Version 10.0.18363 Build 18363.

My version of Spotify is


Concerning to your link: Been there, done that, didn't work 😕

Hey, thanks for your answer!


Strangely it does work on my laptop. It has the same version of Windows and Spotify (which is the latest) as my Desktop PC, and also the same antivirus. I whitelisted Spotify in every configuration I could find (firewall, network traffic control, program control), unfortunately didn't work.


Maybe you have some other advice for me 🙂

I started having the same problem a few days ago. The Spotify desktop application refused to play anything and only provided the vague, "Spotify can't play this right now. If you have the file on your computer you can import it." Reinstalling it a few times using the standalone installer and via the Windows store didn't help anything. Finally I tried running Spotify in administrator mode and everything worked fine.


I'm using Windows 10.0.18363 and Spotify version


Help? Perpetually running this application in administrative mode is not an acceptable permanent solution.

Hey @Medicinalgoat  and @Virmiculum 


Another user with the same issue proposed this method that solved it for them. I suggest trying it out to see if that works for you as well. 🙂

1. Right click on speaker in sys tray

2. Open Sound settings

3. Advanced sound options

4. Click Reset

5. Attempt to play a song on Spotify. At that point the Spotify app appears as below:


Spotify now works as expected.


Let me know how it goes!

Hey there, thanks for the reply. But that doesn't work either, the Spotify-Symbol appears but the error "Spotify can't play this right now..." keeps coming up.



That's ok, let's look for something else 🙂


Do you happen to have a soundcard with S/DPIF connection? I'm noticing many users with the issue have Asus Xonar DGX or something similar with that connection.


Another user raised this method as a possible solution. If you have a soundcard with S/DPIF, it's worth giving a try:

1. Close Spotify
2. Enabled "S/PDIF PassThrough Device" having disabled all other devices
3. Start playing music on Spotify
4. Leave Spotify open and playing
5. Re-enable desired sound device (Speaker usually) and disable the "S/PDIF PassThrough Device"


Let me know how you get on 🙂


Wow, that curiosly worked, thank you! But just until I start Spotify the next time, then the error occurs again. At least we know that the audio-routing seems to be the problem.



Yeah, it appears to be a temporary solution for others too...


I recommend going to this Issue thread, add your vote to it as well as information requested in the Status Update. Do mention what soundcard you have as it may have something to do with this. 🙂


All that info will be helpful for the relevant Spotify team troubleshooting this issue!


Have a nice day!

As it turns out I also have an Asus Xonar DSX however the two outlined workarounds did not work for me.


I'll take a look at the other thread. Thanks for assistance!

It worked! Thanks a lot

Suggested posts