Help Wizard

Step 1


Fully Disable Announcements

Fully Disable Announcements

Premium | Windows 10 and Fresh install of Windows 10 |

I keep getting announcements & new releases popping up in the Spotify client once a day when I first start it. I have the option switched off in preferences. I don't want to see ads, that's why I pay premium.

6 Replies

Hey there @Mr_Rhee


Thanks for reaching out to us about this - we'll be glad to help you out here.

It's possible that you've created multiple accounts. Sometimes Spotify users create more than one account for different reasons. In such a case you might have both free and Premium accounts. If you're accidentally logged in to your free account, you won't be able to see Premium features and you'll hear and see ads. 


We suggest you head to this help page. Make sure you check all the troubleshooting steps and especially the ones for finding other accounts. 


Hope this helps. Keep us posted. 

Nope. Fresh OS and install of Spotify with premium account logged in.

I’m also gettin pop-ups in the app every single day, with suggestions. I only have one account. I have looked at all my settings and the only “notifications” I should be receiving are via email. Yet these pop up recommendations in the app keep appearing. How do I disable them?? 

Judging by the month no response or advice, it's probably something Spotify get paid lots to do. Advertise to those who already pay to not see adverts.

Yeah. And why respond at all if you’re then just going to ignore the problem?

Announcements (advertisements lets be honest) for new releases have started appearing on home screen since the last update. 

The following toggle is UNCHECKED

Edit> Preferences > Display>Show announcements

So they should not be showing (Premium Family subscription).

Suggested posts