Keyboard media launch button

Reply
Highlighted

Keyboard media launch button

Newbie

I am using win 10 with a regular keyboard with media buttons (Alienware default PC keyboard, but I'm using an Asus Rog so no Alienware local programs to check). All buttons work correctly when Spotify is running so no problem there. But no matter what I tried I cannot get the music player launcher button to launch Spotify instead of Groove. Groove is the default music player. I went to default program settings and spotfiy is not there to choose, and I cannot get it to show up there (the file is not stored in programs as you know). I had the regular Spotify and I also tried downloading the Windows store version, still not there. There is no possibility to click and choose the location of program.

 

I also tried to find the key functions from registry but I couldn't find it. This could have helped. Or any other keyboard function modification.

 

I went to spotify.exe settings, keyboard shortcuts, but cannot define it there either because it launches Groove when I press the media button to assign and doesn't recognise the button as shortcut.

 

So how can I associate the launch media player button with Spotify?

5 Replies
Highlighted

Re: Keyboard media launch button

Casual Listener

You find the Spotify.exe file in the AppData/Roming folder. It should be here: C:\Users\<your name>\AppData\Roaming\Spotify\Spotify.exe

Highlighted

Re: Keyboard media launch button

Roadie

Hello rosengela,

 

I associated the Spotify with .cda extension and the media keys started responding to Spotify only.

 

You can do it like this:

Control Panel-> All Control Panel Items-> Default Programs-> Associate a file type of protocol of program -> ... find .cda, click on it and click "Change program..." -> Click on the bottom "More apps" -> Scroll to the bottom and select "Look for another app on this PC" -> At the top of the window insert this: %AppData% -> Find and enter the folder Spotify -> Choose Spotify.exe  -> Click "Open" at the bottom or double click Spotify.exe

 

Voila!

 

Highlighted

Re: Keyboard media launch button

Casual Listener

I've just been faced with this same problem and managed to solve it by modifying the registry. There's a standard disclaimer with editing the registry - be careful, be precise, if you break it you get to keep both pieces.

 

The behaviour of the keys are defined here:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AppKey\16

 

You can create a string key + value here of "ShellExecute" and the path to your spotify. This is what I'd done with Win7.

 

However, as an optimisation, Spotify registers "spotify://" as scheme to be handled by Spotify, so a string key + value of "Association" and "spotify" works.

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AppKey\16]
"Association"="spotify"

Highlighted

Re: Keyboard media launch button

Newbie

Hi!

SKIP TO BOTTOM FOR STEPS

This was a great workaround, but the procedure to do this seems to have changed slightly. First off, through the Win10 Default Apps screen you can't select Spotify for some reason. The good thing is you can do this very easily through file properties.

The other thing is this doesn't seem to work with the ".cda" extension anymore. When I changed the file association for ".mp3" this trick worked perfectly!

STEPS
1 - Right click any ".mp3" file (it can even be a new text file with a renamed extension). 
2 - Click "Properties"

3 - In the "General" tab under the "Opens with:" section click "Change"
4 - If you don't see Spotify click "More Apps" and "Look for another app on this PC"

5 - In the top bar type "%AppData%"
6 - You should click the Spotify.exe file in the Spotify folder.

 

Highlighted

Re: Keyboard media launch button

Newbie

I just faced with this problem, and the registry editing method actually works, thank you very much!

SUGGESTED POSTS