Announcements

Help Wizard

Step 1

NEXT STEP

FAQs

Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...

VIEW ALL

Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...

VIEW ALL

Offline Storage Location is not changing

Offline Storage Location is not changing

Plan

Premium

Country

Poland

 Device

Asus

Operating System

Windows 10

 

My Question or Issue

I can't change offline storage location e.g to a different disk. Every time when I'm trying to change it to a new location, it is back to default folder path after program restart. In new location there is bunch of new folders, but when I download playlists they are dowloading to a default folder location. Is there any solution ?

Reply
3 Replies

Hey @ana22, welcome to the Community.

 

Hope you are doing great!

 

Sorry to hear that it didn't work.


I know it sounds simple, but it's often overlooked. Could you try restarting your device? If that doesn't help, try a quick clean reinstallation of the app. Just follow the steps here. If that doesn't work try to use this guide for a more thorough uninstall of Spotify 🙂

If you're still having trouble, could you let me know the exact version of Spotify and the exact version of the operating system you're running?

I'll see what I can suggest!

LoxerSpotify Star
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Note: I'm not a Spotify employee.

Hi, I was having this issue too. I'm on a laptop with a 128GB SSD and a 1TB HDD.

I wanted to comment in case anyone else found this in a google search like I did.

In my case it was a folder permissions issue. I'm on Windows 10 1909 for reference.

 

Windows had already created a "Program Files" folder on [D:] (the 1TB HDD) for windows store apps. I had created a folder called "SpotifyData" within it, which Windows prompted me for admin permission to do so. I didn't realize it at the time but that was the sign of a permissions issue.

 

My user didn't own the "Program Files" folder, and by creating the "SpotifyData" folder with the admin prompt, my user didn't own it either and had read only permissions.

 

The solution to fix permissions is to:

-Right Click on the folder, select 'Properties' from the context menu.

-Go to the 'Security' tab on the folder's properties page.

-Click the 'Edit' button underneath the first list, of users and groups.

-On the permissions dialog that pops up, Click the 'Add' button under the list of users and groups.

-On the 'Select Users and Groups' dialog that pops up, click the 'Advanced' button.

-On the new larger 'Select Users and Groups' dialog that appears, click the 'Find Now' button on the right middle.

-In the 'search results' list at the bottom, scroll through and find your Windows user name for the computer(the one used/displayed when you login to your computer.)

-Select your user name and click on the 'OK' button, that dialog should close and the previous one's textbox should be filled out with your computer name and user something like this: COMPUTERNAME\UserName

-Click 'OK' again and now your Username should appear in the list of users and groups, select it.

-With you Username selected you can now click on the 'Allow' checkbox for the list item 'Full Control' under the permissions list for your Username.

-Verify all checkboxes under the 'Allow' column are now checked, and click 'OK'

-Click 'OK' again on the folder properties dialog to finish saving the settings and now Spotify should be able to properly work with that folder.

 

Hope this helps someone in the future who finds this via a search or however.

I took a screenshot of all the dialogs for reference. Order is roughly left to right, though the last two are also top to bottom.

Clipboard01.jpg

This helped me! Thank you so much!!

Suggested posts