Help Wizard

Step 1



Please see below the most popular frequently asked questions.

Loading article...

Loading faqs...


Ongoing Issues

Please see below the current ongoing issues which are under investigation.

Loading issue...

Loading ongoing issues...


Sorry, couldn't find that

Sorry, couldn't find that

So I use Spotify on my phone (Android) and my pc (Windows) and out of nowhere my web player doesn't let me access it anymore. I click the login button, but it doesn't work anymore. It gives me a new firefox window that says "Sorry, couldn't find that" and now I can't get into Spotify on my pc. It still works on my phone though. I use Firefox on Windows 10.





My Question or Issue


7 Replies

Hey @ledrewd13, welcome to the Community.


Hope you are doing great!


Please try to clear the cache or use incognito mode on Firefox. Maybe even try to use another browser to access it.

Could you tell me more about the issue you are having on your Desktop app? Do you get any error messages? If possible please include a screenshot of the issue you are having with it 🙂

I know it sounds simple, but it's often overlooked. Could you try restarting your device? If that doesn't help, try a quick clean reinstallation of the app. Just follow the steps here.

If you're still having trouble, could you let me know the exact version of Spotify and the exact version of the operating system you're running?

I'll see what I can suggest!

I believe OP is talking about the Web Player, not the app. They were using Firefox (version unstated), but I'm having the same issue on Chrome, Version 68.0.3440.106.  Windows is on latest version. Only happens on one computer, though. I even logged out and back in, but I was redirected constantly to, which has one button (screenshot attached), which opens a new window with Dead URL, screenshot attached.

I deleted my cookies, logged out and back in (yes, I was already logged in to begin with), and tried incognito mode. Same result.

And yes, I've rebooted. I find myself doing that a lot.


I find it curious that this happens on my laptop, which I've used before with the web player; yet, it doesn't happen on my PC, which is brand new.


Similar problem (resolution not stated):

And upon further investigation, when signed out, redirects to

hey ledrewd13, I had this problem too, but after a few hours of attacking the problem from different angles, I decided to swallow my pride as a problem solver and just jump ship on the web browser--after downloading the desktop app, I was listening to music in minutes. I downloaded it here


I hope this works for you! It looks like a lot of people have had this problem, but I think when it comes down to it, the web browser is just unreliable.

"Sorry, couldn't find that"


I have the same infuriating issue, and have had it for weeks.  Other PC works fine, Android phone works fine.


Clear cache & history - fails to resolve problem

Use a different browser - fails to resolve problem

Private browsing - fails to resolve problem

Paid VPN - fails to resolve problem

Disabling Javascript - fails to resolve problem

Subscribing to Tidal - resolves problem

Spotify and its spotty web player can bite this DAC (digital-analog converter)

While trying to address other issues I was having on my Windows 10 machine, I inadvertently resolved my connection issues with Spotify.  The solution was to perform a Network Reset.  This feature is a function of Windows 10 and can be accessed in Settings.  (Google for more info if you like, I don't click on or post links in forums)


Long story:

I was having a persistent and repeatable error while logging into Gmail or trying to access certain Google services.  Specifically, my browser would not navigate to Gmail at all once I had signed into my account.  No error, no timeout, no redirects, just endless "working" animation in the browser tab.  I could access Drive, but attempting to download a file would always fail with the same redirect error.  Clearing the browser's cache would alleviate the issue for one session, but not permanently.  Using different internet connections and even a paid VPN failed to resolve the issue, which made me suspect it wasn't IP related.  The final straw was booting the machine into Ubuntu and finding that all the same issues (Google and Spotify) were present in that OS.


I am not an expert on networking and while I wish I had a better understanding of what the exact problem was, but I am relieved that it is sorted.  Seems that some bizzare hardware misconfiguration on my end, and not Spotify, was to blame for the persistent "Sorry, Couldn't Find That" error.

Hey @smallmachine,


Thanks for providing that solution 🙂


@ledrewd13 @jlco - did you guys try this out and see if it works?


Keep us posted!


Suggested posts