Help Wizard

Step 1

NEXT STEP

Spotify starting automatically

Solved!

Spotify starting automatically

Out of the blue Spotify decided to start automatically when I boot my PC. In the Spotify settings it is NOT set to start after logging in and in my startup settings Spotify is disabled. The Spotifty Windows app is not installed.

I already tried reinstalling the Spotify app through a download.

Windows 10 N, latest updates.
Spotifiy version: 1.0.73.345.g6c9971ef

Reply

Accepted Solutions
Marked as solution

This is a bug caused by the fact that Spotify's default setting is to run when the computer starts up. I could write an essay about why software shouldn't do this and how tacky it makes Spotify look. People don't have a computer just to use Spotify but it seems that the software developers didn't realise this because every time we start our comptuers, Spotify opens and covers the whole screen and we're forced to close it. It slows down start up and becomes a huge annoyance.

 

Anyway, onto the bug: the bug is caused when you update spotify. For some reason, the updater sets Spotify to open on startup even if you've disabled this option. That's the bug. The fix is to go to advanced settings, set opening on startup to be Yes and then change it back to No. Having to do this every time we update Spotify, however, is going to get really annoying. I urge Spotify to fix this issue, or better yet, remove the open on startup feature because seriously, nobody wants random software to start when they turn their computers on. If I wanted Spotify to open, I'd open it myself.

View solution in original post

10 Replies

Same here. In the settings it is disabled, but still comes up on restart.

Yeah, Putin

Go to "Edit" in the top left corner and select preferences.

At the bottom click "Advanced Preferences" and file the section "Startup and Window Behavious". Toggle "Open Spotify Automatically after you log into the computer" to be "No".

 

Capture.JPG
Marked as solution

This is a bug caused by the fact that Spotify's default setting is to run when the computer starts up. I could write an essay about why software shouldn't do this and how tacky it makes Spotify look. People don't have a computer just to use Spotify but it seems that the software developers didn't realise this because every time we start our comptuers, Spotify opens and covers the whole screen and we're forced to close it. It slows down start up and becomes a huge annoyance.

 

Anyway, onto the bug: the bug is caused when you update spotify. For some reason, the updater sets Spotify to open on startup even if you've disabled this option. That's the bug. The fix is to go to advanced settings, set opening on startup to be Yes and then change it back to No. Having to do this every time we update Spotify, however, is going to get really annoying. I urge Spotify to fix this issue, or better yet, remove the open on startup feature because seriously, nobody wants random software to start when they turn their computers on. If I wanted Spotify to open, I'd open it myself.

If you read my post you would have noticed I already checked that option, it is set to no.

Screenie.png

I'll try that. Would be nice if that works, at least for now. It's only after the latest update I've had this issue.

That indeed worked, I hope they fix it with the next update.

Unfortunately that workaround works only once, just booted my PC and Spotify starts again.

Yes, I found the same 😞

Another solution which has worked for me is to hold the Windows Key and press R, type "msconfig" and press Enter. Then, go to Startup and disable Spotify Web Helper. Hope this helps 🙂

In Window 10 that's under Task Manager now. 😉 Under startup there is only the Spotifywebhelper and that's already disabled.

Suggested posts