Announcements

Tracks skips back to start after 2 seconds

Tracks skips back to start after 2 seconds

Greggy300

Plan

Free

Device

PC

Operating System

Windows 10

 

My Question or Issue

Every track I play skips back to start after about 1-2 seconds. This occurs on ALL tracks no matter if its in my playlists or not. Sometimes it skips back 2 seconds twice in a row. After the skip it then plays as normal. When I switch to another track the very same skip effect starts there too. It's always skipping back to start after starting. Totally annoying. I'm all up to date on both Spotify and Windows. Restarting Spotify doesn't help, neither does restarting Windows. What's up with this?! 

 

 

Reply
5 Replies

Jeremy

Hey there @Greggy300,

 

Thank you for reaching out to the Community. We'd like to take a closer look into this.

 

We recommend that you perform a clean reinstall of the app. This will make sure there's no old cache files causing this.

 

If that doesn't do the trick, can you remove all lines from your hosts file by following the steps bellow:

  1. Open Notepad as an administrator (right-click - Open as Administrator)
  2. go to File - Open and navigate to C:\Windows\System32\drivers\etc
  3. Choose "All Files" instead of "Text Documents" next to the File Name box. You'll see a handful of files. Pick hosts and click on Open
  4. When the file is open, you will see a block of text with # in front of each line and might see entries like 0.0.0.0 website.com127.0.0.1 website2.com
  5. Check for any entries with Spotify in the address. Examples may look like: 0.0.0.0 weblb-wg.gslb.spotify.com0.0.0.0
  6. If you do find any lines with Spotify, please remove them
  7. Save your changes and restart Spotify

Let us know how it goes 🙂

Take care!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

Greggy300

Jisses, do you really expect your users to dig into the file structure of Spotify to that extent?! I'm stunned. Deleting and re-installing the application didn't solve anything. I have no idea if the second suggestion would work. Look, it's not like this error is unique, I read that many users are experience much of the same playback errors. Couldn't Spotify for once try to find a global solution to this? And while your at it: please fix this community section as it's constantly producing errors when trying to reply to posts. Constantly prompting me to accept that I'm over 18, then sending me in a perpetual loop. This message is stored so I can try to send it every day, if you read this them I'm lucky. Been days!

Ver

Hey @Greggy300,

 

Thanks for getting back to us.

 

Sometimes clearing the hosts file resolves different issues. This is why we suggested trying these steps.

 

In case the issue persists, you might be experiencing the issue mentioned in this thread. You can share the required info in that thread to avoid confusion.

 

If you experience another issue, you can share with us a video recording of it. We'll look into this further.

 

If you again get an error message while posting in the Community, it's a good idea to try clearing the cache and cookies.

 

The Community is here for you if there's anything else!

Ver Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

iRedFox
I have the same problem, the song go on for a bit and then it starts repeating a bit then goes on, the CPU goes up to 15% and power usage goes up to very high, it's because of the new update.

Fix: Go on the internet and find spotify version before the latest one
it worked fine for me.

Greggy300

As that thread proves there's nothing wrong locally on my system, it's an application bug that Spotify needs to fix.

Suggested posts

Env: prod