Announcements

Windows 10 Spotify app very slow

Windows 10 Spotify app very slow

Plan

Free

Country - India

 

Device

HP laptop , intel core i-7 , 8 gb ram

Operating System

Windows 10

 

My Question or Issue

I really love spotify but it really test my patience most of the times... The desktop app for windows 10 is very slow , sometimes when I try to play the songs which my friends are listening to then the song never gets played but in the friends window it shows as being played currently in the app...

 

Spotify_Issue.png

Spotify_Issue.png
Reply
18 Replies

Hey there @BuggerMe

 

Thanks for reaching out to us about this - we'll be glad to help you out here.

 

Most common issues can be fixed with a quick reinstall of the app. In some situations however, a clean (more thorough) reinstall of the app might be needed. This way you can start afresh with Spotify on your laptop. 

 

Check out this help page in order to find the steps for clean reinstall on the affected device. 

 

If it doesn’t do the trick, we’ll provide you with further help. 

 

We'll look out for your reply. 

hi,
i don't think it is fair to always push back to the end user when something just doesn't work as it should. There was a big push to use the Windows 10 app, yet as the poster has mentioned, it is extremely slow. i have seen many posts about this situation, it is clearly not isolated therefore, i feel there needs to be some investigation put into if, the app is fit for purpose if not, let us use the original which worked perfect well

I have exactly the same issue. I tried these solutions, they don't work. The problem is obviously the software design. The only version of Spotify I have enough patience to use on my PC is the browser version, the desktop app lags terribly, it's impossible to use. My computer runs GTA V, Sony Vegas Pro and other heavy software perfectly so why would a f***ing music player be running so slow? Obviously it's bloated and it's very annoying, because I'm paying you guys for the premium version. Please, fix this. It's ridiculous how bad the desktop app lags.

I recommend the installation of the Spotify app to SSD disk.

I share the same pain brother !
I deleted and reinstalled the app on my windows 10 but no use .

It still lags and haunts me every time , I was hoping to get a better response from Spotify team which have some of the world's best algorithms and engineers working for them but it's really unbelievable that they still have largely neglected there Windows app 😞

Unfortunately I don't have an SSD 

I tried everything @Ivan but nothing helps.

Please provide a better solution.  _/\_

Hey folks, 

 

Thank you for reaching out to us about this.

 

We actually have two ongoing issue when it comes to this. Have a look here and here. You can leave your vote to show to show that you're experience this.

 

Hope this information was helpful.

 

We're always one reply away if you need us.

Mario Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

It is on SSD - still no good!

Toggle show local files off as mentioned in one of your suggested solutions helped - but with many local songs not on spotify I now have a need for an additional music player 😞
I suggest you keep on looking to better the application

Spotify becomes a nightmare, 3 minutes to open.
TIDAL opens in less than 20 seconds.

Hey there @gonzalojp76,

 

Thank you for your post and feedback. We're happy to help.

 

Can you confirm if you performed a clean reinstall as @Ivan mentioned? This will make sure there's no old cache files causing this.

 

It can also be good to try with another internet connection to see if the issue persist.

 

We'll keep an eye out for your reply.

 

Cheers!

JeremyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
Live, love, laugh and listen to music 🙂

I'm also in the same boat. The app lags horribly. Even changing the volume takes a second to reflect. Skipping through songs, seeking the progress bar are all very laggy experiences. I hope Spotify pays some development attention to its desktop apps.

Hey @bhargavbuddy,

 

Thanks for reaching out about this. 

 

Would you mind letting us know if you followed the suggestions previously made by @Ivan and @Jeremy?

 

If possible, could you ask a friend or a family member to log into their account using your device to see if they can replicate this?

 

Let us know how it goes. We'll be on the lookout for your reply. 

NovyModerator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

Yeah I reinstalled my app. Didn't change anything. It's installed on an SSD, show local files disabled too.

Hey @bhargavbuddy,

 

Thanks for getting back to us.

 

It's also a good idea to make sure that Hardware Acceleration is turned off in the setting menu. Sometimes this setting can cause behavior like the one you're describing. 

 

On another note - did you give @Novy's suggestion a go and checked if the issue comes up with another account? It would be helpful to check if the app still responds slow when using a different internet connection. Perhaps a mobile hotspot could be a convenient way to test this?

 

Keep us posted, we'll keep an eye out for your replies.

Mihail Moderator
Help others find this answer and click "Accept as Solution".
If you appreciate an answer, maybe give it a Like.
Are you new to the Community? Take a moment to introduce yourself!

This has always been an issue for me on windows 10. I used to be able to clear out some files from the appdata folder, but not anymore. This is awful. Its unusable. Even after a clean reinstall, it only helps so long. 

Hey there @NetGurl84,

 

Thanks for reaching out to the Community.

 

Just to confirm, did you try disabling the option Enable hardware acceleration in the app's settings? It's also worth toggling the option Show Local Files on > disabling all the sources that appear there > toggle Show Local Files back off.

 

Keep us posted on how it goes.

CarlosEModerator
 
Help others find this answer and click "Accept as Solution".
If you appreciate my answer, maybe give me a Like.
 

Suggested posts