Announcements

Help Wizard

Step 1

NEXT STEP

spotify does not play over audio interface

spotify does not play over audio interface

hi there,

 

i have a Focusrite 2i4 USB audio interface, which i use to work with programs like sibelius and ableton. Problem is that whenever it's connected, spotify wont play. this is of course very annoying. 

 

Any one experienced problems like this?

 

best regards

 

Edgar

Reply
28 Replies

Try changing the sample rate of your device on Focusrite Control app.

 

Hey! Thanks but i already found a fix back then, i guess it was just installing the newest spotify update or something

I understand that this is from 2013, but this is one of the two threads on spotify's forums that had popped up when I searched this on google. The other one is marked "Solved", so I'll put info here for anyone desperate like I was.

 

First of all, you've probably already done this if you're a the bottom of this thread looking for answers, but disable your hardware acceleration, leave it off, and then close spotify.

Next, go to your manufacturer's website for your audio interface, and download your newest drivers. If you're using Native Instruments, I'm using the 6 Mk2, and for some reason I needed to install both the 5.22 and 5.0 drivers before I got them to work. If you're plugged into the default positions like I am (1st input mic, 1st input headphones, switch near headphones set to line 1-2), make sure you have your default device set to Output 1/2. To do this, right click your audio icon on your task bar, click on sounds, and click on Output 1-2 and set to default if it isn't already.

Next, right click on your audio icon again and click sound settings, yes, these two sound settings windows are in different locations completely. Windows is very f*****g stupid. You're going to want to scroll down to the very bottom down by advanced sound options, and click on App volume and device preferences, and you would think that spotify would be smart enough to actually use your default devices here, but it's not. Spotify is just a small indie company worth 30.5 billion dollars, so you can't really expect them to fix simple issues within 7 years. So you're going to want to manually select the same device that you set as your default earlier. For me, again, on Native Instruments (with the newest drivers), this is Output 1/2.

You should be good to go now. For me, it took about 5 seconds or so and then it started playing the audio. I hope this helps.

I had the same issue, I tried all the standard suggestions, but because the issue was potentially a soundcard issue, what worked was going to Focusrite website and downloading the software for my device. A restart was prompted and Spotify worked perfectly afterwards. I had a new laptop which was why I had to re download the software.

god bless your soul albert i love you

 

madonnis

Increasing the sample rate from 44.1kHz to 88.2kHz in my audio device app/settings (Focusrite Control) fixed crackle and glitchy audio

 For anyone having this exact issue where spotify says "if you have the file you can import it", for me what fixed it was on Windows go to Settings - System - Sound - on the right there is Sound control panel - on the "playback" list select your Audio Interface and click "properties" (or just double-click it) - Advanced - then on Default Format make sure it's on 2 channel and on Exclusive Mode select atleast the first box. For some reason my computer put it on on it's own 8 channel which is why it didn't recognize my monitors. After selecting 2 channel there isn't even an option for 8 channel anymore. 1 Channel enables only 1 monitor so if you have 2 monitors select 2 channel. Hope it helps.

This fix is not working for me in 2023. Any other ideas? Can't play from Spotify to my Audio 6. Have reinstalled the current driver as Administrator.

This comment right here saved me, after much searching! Thank you good sir

Suggested posts