AirPods Pro Automatic Switching conflict with Spotify Connect

Plan

Premium

Country

USA

Device

iPhone Xs, iPad Pro (2019), and AirPods Pro

Operating System

iOS 14 and iPadOS 14

My Question or Issue

With iOS 14, Apple released automatic source switching between different apple devices depending on which source emits audio. If I have spotify open on both devices, and try and play music on either one, spotify connect and the switching goes into a loop where the AirPods Pro bounce between devices. I can pause, but that doesn’t help. I have to quit spotify on one of the devices to fix it.

Hey everyone,

 

We appreciate you taking the time to report this issue here. All the information you shared has been passed on to the right folks and they are looking into it.

 

In order to investigate further, we will need to gather more details. Could you share a video of what's happening exactly? That'd really help the right team to get to the bottom of this.

 

Thanks again!

Comments
34534633
Newbie

Plan

Premium

Country

Germany

Device

iPhone 12, Google Home Mini

Operating System

Windows 10

 

My Question or Issue

Spotify connects automatically to my main phone, when I connect my AirPods. Please enable a switch in settings to disable this function. I don't want that Spotify is all the time connecting automatically to my iPhone, if I play music on Google Home Mini or Desktop, only because I connected my AirPods or something like this. It happens when I start a call and connect my Airpods or even when I end a call. 

Novy
Moderator
Moderator

Hey there @34534633

 

Thanks for reaching out about this in the Community, and welcome 🙂

 

Could you let us know if you notice any difference after performing a clean reinstall of the app? This is often an overlooked step, but it’s more thorough than a regular one and can be helpful to get rid of any cache that might be causing trouble. 

 

We'll keep an eye out for your reply. 

34534633
Newbie

Hey Novy,

sadly this isn't solving my issue. Its still the same like before. 😞

Novy
Moderator
Moderator

Hey @34534633

 

Thanks for getting back to us. 

 

If possible, could you send over a video where we can take a better look at this issue?

 

You can send a link to it or attach it using the Insert Video option in the post editor.

 

Keep us posted so we can continue investigating. 

34534633
Newbie

Why Spotify? Why?

I need to enter this text twice, just because this forum puts an error out and I can't go back and see my text. wth. And why a captcha? I mean I've a account. Really?

And I can't create an video for this issue. Is a little to much.

Maybe I described not good enough:

I listen to music on Google Home or any other device.

I unlock the iPhone to start a call. I put on the Airpods to call. But this triggers (maybe) something in the back and Spotify put the music to my Airpods.

And this I don't want. If the music is playing on antoher device. I should stay that way. I don't need this kind of feature. Please, please. Give me an option to disable this.

Eni
Moderator
Moderator

Hey there @34534633

 

Thanks for getting back in touch. 

 

Would you mind letting us know if this only happens with Spotify or with other streaming apps as well?

 

Additionally, could you let us know if when this happens the app is open on your phone too or only on your PC? 

 

We'll be on the lookout. 

34534633
Newbie

 

Thank you for taking time on this issue.

 

It happens only with Spotify. There is no other app who force the user to use this automatic device switching feature.

 

As I say, it mostly happens when I connect my Airpods to the iPhone. Then it puts the music on my Airpods, even if it plays on the Desktop /PC or Google Home.

 

Best wishes

Jeremy
Moderator
Moderator

Hi there @34534633,

 

Thank you for your reply.

 

We've received reports about devices automatically switching the audio output when connecting with another bluetooth audio device, such as headphones or speakers.

 

Usually this is controlled by the device OS itself, but there might be a way to have Spotify customize the behavior.

 

There's an idea - [Mobile][Bluetooth] Stop Spotify Autoplaying on App Open. You can leave a +VOTE and Subscribe to the thread for any updates.

 

Let us know if we can help you with anything else.

 

Take care!

BayesianModel
Casual Listener

Please properly fix this issue - Spotify has to operate in the constraints of iOS and the Apple ecosystem.

 

Disabling Automatic Switching on the Airpods is a very suboptimal solution. It is basically disabling a (very nice) feature of Airpods. There must be a distinction between the two devices. When Spotify Connect is "Playing" on MacOS when the actual audio is being outputted on an iOS device (i.e. listening on the iOS device), the Airpods do not attempt to switch back to macOS.

 

This implies that however Spotify implements Spotify Connect on iOS devices convinces iOS the audio is actually coming out of the iOS device, rather than the device actually being listened on. Said another way - when listening on macOS and an iOS device is connected via Spotify Connect, Spotify Connect starts "playing" on the iOS device, and iOS believes it is playing audio, which triggers transferring the Airpods to iOS. But no audio is actually playing on iOS, and the stream stops on macOS as it is treated like headphones being disconnected on macOS (triggering a pause). I think that's as detailed as I can describe the behavior. Let me know if you have questions. Steps to reproduce:

 

1. Start listening on Airpods Pro on macOS

2. Open spotify on a device where the airpods have been connected before

3. Wait for spotify connect to launch and realize macOS is playing music

4. At this point, the Airpods are moved to iOS by macOS, as iOS just informed macOS an audio stream started on iOS

5. Spotify pauses on macOS, because headphones were just disconnected.
6. Spotify on iOS pauses via Spotify Connect.
7. No music 😞

 

 

 

Are there any plans to address this problem more formally within Spotify's solution? Spotify Connect is great, but this is a big negative!

Novy
Moderator
Moderator
Status changed to: Under investigation

Hey folks,

 

Thanks for reporting this issue to us.

 

We’ve passed your info on to the relevant team, who are currently looking into it.

 

If you’re experiencing this issue, make sure to click +VOTE and Subscribe to the thread to be notified of any developments.

 

Could you also make sure to provide us with the following info, if you haven’t already:

  • device + OS version
  • exact Spotify version

Thanks! We’ll keep you posted and let you know as soon as we have any updates on this.

Related Issues